quick build questions - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 04-24-2007, 02:20 PM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: May 2006
Location: Athens, GA
Posts: 247
Total Cats: 0
Default quick build questions

I'm at step 53 (map sensor) and everything has tested fine so far, I just had a couple quick questions:

1. I skipped step 22 for the stepper IAC and the VR circuit, no problem, right?

2. Looks like I might have to go back by DIY to pick up the extra part for the IAC, I don't think I got it when I picked up my kit. I do need this mod kit, right? http://www.diyautotune.com/catalog/p...kit-p-134.html

3. When should I load squirt-n-spark? Right now I am testing with the MS-1 code variant.

4. Is everyone running easytherm instead of the GM coolant temp sensor? I have the sensor (picked up on ebay) but don't know where a good place to tie it into the flow would be. Using the GM sensor would negate the need for easy therm?

I've attached a pic of my board too...

Many thanks!

-scott
Attached Thumbnails
quick build questions-mega-4-22-07.jpg  
GTS Miata is offline   Reply With Quote
Old 04-24-2007, 02:25 PM   #2
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,780
Total Cats: 1,106
Default

It is looking good so far.
1.Yes skip step 22
2. Yes you need to go back and order that mod kit. It is very east to install once you get it in.
3. I loaded squirt-n-spark after I was done building everything.
4. I am running easytherm setting with the mazda clt. If you use the gm clt sensor you do not need to change anything with easytherm.
shuiend is offline   Reply With Quote
Old 04-24-2007, 02:28 PM   #3
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

My local radioshack has the tip120/122 or whatever as well as the n1 .... whatever diode in stock and they are cheap. Might save you some time and money.
akaryrye is offline   Reply With Quote
Old 04-24-2007, 02:32 PM   #4
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: May 2006
Location: Athens, GA
Posts: 247
Total Cats: 0
Default

Thanks guys. I'll have to check radio shaft, it would save me the drive down to DIY during lunch...
GTS Miata is offline   Reply With Quote
Old 05-08-2007, 02:31 PM   #5
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: May 2006
Location: Athens, GA
Posts: 247
Total Cats: 0
Default

New questions:

5. I was looking at cjernigan's board in this thread:

https://www.miataturbo.net/forums/showthread.php?t=7735

and I was wondering if this is where everyone mounted their tip120/122? I guess we don't need Q16 (what is supposed to go in that spot)?

6. I'm at step 65 and I can't quite figure out what I'm supposed to do here? It says to go to the MSnS-E site for instructions on wiring the high current circuit. I went there but can't seem to figure out what I'm supposed to do. I'm probably just not looking in the right spot.

7. Step 69, yes or no on the PWM flyback damping circuit? It looks like cjernigan installed it.

8. How did you attach R37 and R38 to the heat sink?

Sorry for all the q's, I'm sure I have just overlooked the answers in other threads on this site.

-Scott
GTS Miata is offline   Reply With Quote
Old 05-08-2007, 04:28 PM   #6
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

5. You don't need Q16, and can stick the TIP120 there, with the leads wired to the board. Or you can mount it to a hole drilled in the case - that's usually how we do this on assembled units that have Q16 installed.

6. Don't use the high current driver. Use our ignition mod guide instead.

7. Might as well put it in; this is not needed with stock injectors but can give you more options later.

8. If yours did not come with through bolts (there are several different styles out there), use the strips of double sided heat sink tape.
Matt Cramer is offline   Reply With Quote
Old 05-08-2007, 05:13 PM   #7
Elite Member
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,658
Total Cats: 39
Default

Quote:
Originally Posted by GTS Miata View Post
New questions:

5. I was looking at cjernigan's board in this thread:

https://www.miataturbo.net/forums/showthread.php?t=7735

and I was wondering if this is where everyone mounted their tip120/122? I guess we don't need Q16 (what is supposed to go in that spot)?
-Scott
I mounted mine in the Proto area as so...

richyvrlimited is offline   Reply With Quote
Old 05-08-2007, 05:15 PM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

Braineack is offline   Reply With Quote
Old 05-08-2007, 07:13 PM   #9
Elite Member
iTrader: (12)
 
Join Date: Aug 2006
Location: Central-ish VA
Posts: 4,449
Total Cats: 16
Default

thats so pretty, who did that?
neogenesis2004 is offline   Reply With Quote
Old 05-08-2007, 07:14 PM   #10
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

why sir i believe you did!
Braineack is offline   Reply With Quote
Old 05-08-2007, 09:04 PM   #11
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: May 2006
Location: Athens, GA
Posts: 247
Total Cats: 0
Default

you guys are too funny.
GTS Miata is offline   Reply With Quote
Old 05-21-2007, 02:04 PM   #12
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: May 2006
Location: Athens, GA
Posts: 247
Total Cats: 0
Default

OK, I have everything done except the LED's and the miata mods. I'm going to install the LED's and make sure the thing works with the stim before doing the miata mods.

Looking at images of everyone else's boards, it looks like no one has Q6 and Q8 installed (over by LED's). Why aren't these installed? I would guess it has to do with the ignition mods for the miata, but I don't see it documented to remove these anywhere?
GTS Miata is offline   Reply With Quote
Old 05-21-2007, 02:40 PM   #13
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

Quote:
Originally Posted by GTS Miata View Post
Looking at images of everyone else's boards, it looks like no one has Q6 and Q8 installed (over by LED's). Why aren't these installed? I would guess it has to do with the ignition mods for the miata, but I don't see it documented to remove these anywhere?
They apperantly lower the voltage too much to fire the coil if you leave them in...
Braineack is offline   Reply With Quote
Old 05-21-2007, 06:35 PM   #14
Supporting Vendor
iTrader: (5)
 
Join Date: Jun 2006
Location: Duluth, GA 30097
Posts: 798
Total Cats: 0
Default

I've had no problem leaving them in... though others have had to remove them. Basically there are two ways to mod the boards now, our way and Kag's way-- do one or the other, not mixing the two....
FoundSoul is offline   Reply With Quote
Old 05-23-2007, 10:09 PM   #15
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: May 2006
Location: Athens, GA
Posts: 247
Total Cats: 0
Default

Finally, I have the squirt together, but I haven't done the miata specific mods yet.

I hooked it up to the stim and the computer and pretty much everything seems to be working as they should. I did have a couple questions regarding the led's on the stim:

1. The IG one isn't lighting up, but I don't have the ignition mods done yet, so I'm not too worried about that.

2. The I1 led flashes, faster as the rpms go up. The I2 led seems to be on steady, it doesn't flash. Is this normal or should it be flashing alternately with I1?
GTS Miata is offline   Reply With Quote
Old 05-23-2007, 10:17 PM   #16
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

I don't know much about the actual stim operation but as long as it is working in megatune and you can adjust your values under realtime tuning then it should be good to go. Once you do the miata mods the LEDs don't work anymore anyway so i never really paid much attention to them.
Sorry if this sounds a bit ignorant about that much of it.
cjernigan is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
15x10 - 15x11 6UL @ 949 Racing emilio700 Wheels and Tires 151 06-02-2017 03:36 PM
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:07 AM.