MEGAsquirt A place to collectively sort out this megasquirt gizmo
Sponsored by:
Sponsored by:

setting up LC-1

 
Old 11-19-2006, 04:36 PM
  #1  
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,641
Total Cats: 41
Default setting up LC-1

Just finished installing an LC1 to my MS1

I've set the configurator to LC-1 and in the EGO settings changed the dropdown to wideband.

is that all I need to do or have I missed something?

Thanks
richyvrlimited is offline  
Old 11-19-2006, 05:00 PM
  #2  
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,651
Total Cats: 111
Default

I'm sorry I can't help you with the MS aspect, but from my experience, you need to set up the lc-1 with lm programmer. When I got mine, none of the factory defaults were set as they should have been.
__________________
DIYAutoTune.com Tech Support
10AE-T|BEGi S4|MSPNP-Pro EMS|Enthuza Duals|6UL|Etc
Track Rat|2001|VVT|MS3-Pro EMS|Enthuza|Exocet in Progress

Originally Posted by concealer404 View Post
Buy an MSPNP Pro, you'll feel better.
Ben is offline  
Old 11-19-2006, 05:52 PM
  #3  
Newb
 
Join Date: Nov 2006
Posts: 2
Total Cats: 0
Default

You need to use LM programmer and setup Analog out1 (if you use Analog out1):
0V -> 0,5 Lambda
5V -> 1,5 Lambda

Then select in MT Configurator:

Innovate LC-1 Default

Also you need to change EGO switch point (in Exhaust gas settings) to 2.51! -> Burn to ECU.

disc is offline  
Old 11-19-2006, 06:06 PM
  #4  
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,641
Total Cats: 41
Default

Originally Posted by disc View Post
You need to use LM programmer and setup Analog out1 (if you use Analog out1):
0V -> 0,5 Lambda
5V -> 1,5 Lambda

Then select in MT Configurator:

Innovate LC-1 Default

Also you need to change EGO switch point (in Exhaust gas settings) to 2.51! -> Burn to ECU.

Nice first post!

Welcome btw
richyvrlimited is offline  
Old 11-20-2006, 02:39 AM
  #5  
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,567
Total Cats: 235
Default

Originally Posted by disc View Post
You need to use LM programmer and setup Analog out1 (if you use Analog out1):
0V -> 0,5 Lambda
5V -> 1,5 Lambda
No no no! Set:
0V -> 10:1 AFR
5V -> 20:1 AFR

Then go in MegaTune Configurator and set:
car1 -> settings.ini -> LAMBDA_SENSOR: INNOVATE_0_5_LINEAR: Innovate, PLX 0-5V 10-20:1 AFR

Open your .msq in MegaTune and set:
Basic Settings -> Exhaust Gas Settings -> EGO Sensor Type: Wide band, EGO Switch Point (v): 2.332, Ignition Events: 16, Controller Step Size: 1, Controller Authority 15, Active Above Coolant Temp (C): 65, Active Above RPM: 1100, EGO Correction Step Counter: mSec
__________________
Originally Posted by ninerwfo View Post
The “into to megasquirt thread” mentions that the MS3 basic has 5 inputs with built in pull up resistors - and I was just wondering why it would have so many, while the MS3Pro PnP has just 2 (with no pull ups?)
MS Labs: Plug and Play Megasquirt ECUs for ANY 90-05 Miata (NA, NB1, NB2 w/VVT, MSM), including basemaps to get you started ASAP. PM me or email or details.
For support on MS Labs ECUs: Please email, be sure to include the unit's serial number and include a datalog and your current map.
Reverant is offline  
Old 11-20-2006, 04:31 AM
  #6  
Newb
 
Join Date: Nov 2006
Posts: 2
Total Cats: 0
Default

Hey! He can use whatever he want settings!

Why Active Above RPM: 1100 ?
As far as I can say this guy is in the beggining of tune of his engine... so EGO correction MUST be OFF.
Active Above RPM: 10000 will disable EGO correction...

He even didn't say what version of firmware is using... 029q2?

P.S. Sorry, but my english is not quite good, it's not my native language.
disc is offline  
Old 11-20-2006, 06:35 AM
  #7  
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,567
Total Cats: 235
Default

Originally Posted by disc View Post
Hey! He can use whatever he want settings!
Of course he can. 0.5 to 1.5 lambda is about 7.5:1 to 22:1 AFR. These AFRs (7.5-10 and 20-22) are not needed, the engine will not run with such rich or lean mixture. If you narrow the area from 7.5-22 to 10-20 you will have higher resolution in that area which is highly recommended.

Originally Posted by disc View Post
Why Active Above RPM: 1100 ?
Because you don't want the algorithm to hunt at idle. MS1 is lacks processing power to correctly set the mixture at idle without hunting.

Originally Posted by disc View Post
As far as I can say this guy is in the beggining of tune of his engine... so EGO correction MUST be OFF.
I believe he needs it. He will datalog what the EGO correction was, run it through the VE analyzer in MegaLogViewer, which corrects your VE bins based on the logged EGO correction.
__________________
Originally Posted by ninerwfo View Post
The “into to megasquirt thread” mentions that the MS3 basic has 5 inputs with built in pull up resistors - and I was just wondering why it would have so many, while the MS3Pro PnP has just 2 (with no pull ups?)
MS Labs: Plug and Play Megasquirt ECUs for ANY 90-05 Miata (NA, NB1, NB2 w/VVT, MSM), including basemaps to get you started ASAP. PM me or email or details.
For support on MS Labs ECUs: Please email, be sure to include the unit's serial number and include a datalog and your current map.
Reverant is offline  
Old 11-20-2006, 03:53 PM
  #8  
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,641
Total Cats: 41
Default

Reverant you're a ledge thanks!
richyvrlimited is offline  
Old 11-20-2006, 05:57 PM
  #9  
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,641
Total Cats: 41
Default

hrm when I ro a run with logworks I get AFR's i was kinda expecting, i.e. 13-10:1 (room for improvment..)

however within megatune my afr's are displayed waaaaaay lean at around 17:1 what's wrong with that? I've double checked my settings and they all look fine to me?

Help! (again!!)
richyvrlimited is offline  
Old 11-20-2006, 06:59 PM
  #10  
Senior Member
 
Join Date: Oct 2005
Location: Knoxville
Posts: 1,168
Total Cats: 0
Default

Did you make sure to change the MS settings?
Al Hounos is offline  
Old 11-20-2006, 07:18 PM
  #11  
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,641
Total Cats: 41
Default

Originally Posted by Al Hounos View Post
Did you make sure to change the MS settings?
yup!
richyvrlimited is offline  
Old 11-21-2006, 01:43 AM
  #12  
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,567
Total Cats: 235
Default

Originally Posted by richyvrlimited View Post
hrm when I ro a run with logworks I get AFR's i was kinda expecting, i.e. 13-10:1 (room for improvment..)

however within megatune my afr's are displayed waaaaaay lean at around 17:1 what's wrong with that? I've double checked my settings and they all look fine to me?

Help! (again!!)

1) Where did you ground your LC-1? You absolutely need to ground it on the same location as the Megasquirt. Different points on the chassis will not do!
2) Can you post your MS .msq and MT settings.ini?
__________________
Originally Posted by ninerwfo View Post
The “into to megasquirt thread” mentions that the MS3 basic has 5 inputs with built in pull up resistors - and I was just wondering why it would have so many, while the MS3Pro PnP has just 2 (with no pull ups?)
MS Labs: Plug and Play Megasquirt ECUs for ANY 90-05 Miata (NA, NB1, NB2 w/VVT, MSM), including basemaps to get you started ASAP. PM me or email or details.
For support on MS Labs ECUs: Please email, be sure to include the unit's serial number and include a datalog and your current map.
Reverant is offline  
Old 11-21-2006, 02:43 AM
  #13  
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,641
Total Cats: 41
Default

Originally Posted by Reverant View Post
1) Where did you ground your LC-1? You absolutely need to ground it on the same location as the Megasquirt. Different points on the chassis will not do!
2) Can you post your MS .msq and MT settings.ini?
yup same ground points as MS, 4c and 4d.

settings.ini and msq attached
Attached Files
File Type: rar
richy.rar (7.2 KB, 61 views)
richyvrlimited is offline  
Old 11-21-2006, 09:27 AM
  #14  
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,567
Total Cats: 235
Default

Can you please put them in a .zip file? I don't have winrar on this pc and I don't intend to install one, thanks!
__________________
Originally Posted by ninerwfo View Post
The “into to megasquirt thread” mentions that the MS3 basic has 5 inputs with built in pull up resistors - and I was just wondering why it would have so many, while the MS3Pro PnP has just 2 (with no pull ups?)
MS Labs: Plug and Play Megasquirt ECUs for ANY 90-05 Miata (NA, NB1, NB2 w/VVT, MSM), including basemaps to get you started ASAP. PM me or email or details.
For support on MS Labs ECUs: Please email, be sure to include the unit's serial number and include a datalog and your current map.
Reverant is offline  
Old 11-21-2006, 12:37 PM
  #15  
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,641
Total Cats: 41
Default

Originally Posted by Reverant View Post
Can you please put them in a .zip file? I don't have winrar on this pc and I don't intend to install one, thanks!
WinRAR, for all you compression needs

no need I've sussed it, tho I'm not sure I want to admit what I'd done wrong....
.
.
.
.
ah well, someone might learn from my miatake!

I'd set the voltages the wrong way around in LM config.
richyvrlimited is offline  
Old 11-21-2006, 01:39 PM
  #16  
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,567
Total Cats: 235
Default

Ooops! Happy end though
__________________
Originally Posted by ninerwfo View Post
The “into to megasquirt thread” mentions that the MS3 basic has 5 inputs with built in pull up resistors - and I was just wondering why it would have so many, while the MS3Pro PnP has just 2 (with no pull ups?)
MS Labs: Plug and Play Megasquirt ECUs for ANY 90-05 Miata (NA, NB1, NB2 w/VVT, MSM), including basemaps to get you started ASAP. PM me or email or details.
For support on MS Labs ECUs: Please email, be sure to include the unit's serial number and include a datalog and your current map.
Reverant is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
StratoBlue1109
Miata parts for sale/trade
21
09-30-2018 01:09 PM
stoves
Suspension, Brakes, Drivetrain
5
04-21-2016 03:00 PM
90 Turbo
MEGAsquirt
19
10-19-2015 03:23 PM
mx592
Suspension, Brakes, Drivetrain
1
10-01-2015 12:45 AM


Thread Tools
Search this Thread
Quick Reply: setting up LC-1


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.