Tach output for 2000 NB - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 07-26-2011, 01:50 PM   #1
Senior Member
Thread Starter
 
Join Date: Jun 2006
Location: Orlando FL - UCF
Posts: 688
Total Cats: 1
Default Tach output for 2000 NB

For some reason I never got the tach output working with my old build. Thought I'd get that sorted now the car is back up.

So I remember it being different than the NAs, but I can't remember how, so can anyone point me to the right thread? I tried searching around for the past bit and can't find anything.

Thanks
coastertrav is offline   Reply With Quote
Old 07-26-2011, 02:08 PM   #2
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,323
Total Cats: 1,920
Default

The dashboard tach on an NB is fed by the ECU, similar to a '95.5 or later NA.

On an '00, it's a green / orange wire at position 2K of the ECU. Set up a circuit in the MS to give it a 0-12v squarewave with one pulse per ignition event.
Joe Perez is offline   Reply With Quote
Old 07-26-2011, 02:39 PM   #3
Senior Member
Thread Starter
 
Join Date: Jun 2006
Location: Orlando FL - UCF
Posts: 688
Total Cats: 1
Default

So a two channel optoisolator fed from the ignition signals on the MS passing 12V through a 10K resistor, or thereabouts?
coastertrav is offline   Reply With Quote
Old 07-26-2011, 02:48 PM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

you just need one pn2222 transistor a 10K and a 1K resistor.

Attached Thumbnails
Tach output for 2000 NB-lowvtacho.gif  
Braineack is offline   Reply With Quote
Old 07-26-2011, 02:54 PM   #5
Senior Member
Thread Starter
 
Join Date: Jun 2006
Location: Orlando FL - UCF
Posts: 688
Total Cats: 1
Default

Dang, duh.

Thanks, I'll get in there tonight and get that gauge finally working. You know I just lived with it for 6 months before the car went down that I didn't work...

Appreciate it guys.
coastertrav is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
another noob kr307 Meet and Greet 1 09-26-2015 11:33 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:44 AM.