Tach Output Pin - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 06-30-2007, 03:11 AM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2006
Location: Kirkland, WA
Posts: 239
Total Cats: 0
Default Tach Output Pin

So, I built the circuit described here:
http://megasquirt.sourceforge.net/extra/tachopin.html

But it didn't make my tach work. I have 94 wiring and dash.

I played with it on my little proto board (the kind where you have two power and ground rails, and it just has a bunch of holes you can stick components into to test circuits), and with 12v connected to pin 3 via a 1k resistor, and pin 1 connected to ground, there was only 9v across pins one and 3. When I put +5 to pin 2 via 1k resistor, voltage dropped basically to 0 across pins 1 and 3. So if I understand properly, this should be generating a 0 to 9v square wave at pin 3, which is what I connected to the tachometer wire that goes to the diagnostic connector, the tachometer, and would normally attach to the coil (but I have a 2000 coil).

Anyone know how to make this work?

-Mike
grippgoat is offline   Reply With Quote
Old 07-01-2007, 03:36 PM   #2
Newb
 
Join Date: Feb 2007
Location: Qc, Canada
Posts: 43
Total Cats: 0
Default

You know your tach need to be fed by a negative coil signal to work properly. If you have multi coil (coilpack), you need to build this:

mazdasly75 is offline   Reply With Quote
Old 07-02-2007, 02:01 AM   #3
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Apr 2006
Location: Kirkland, WA
Posts: 239
Total Cats: 0
Default

Nah, I figured out the problem today. I messed up the circuit. I connected the DB37 to the wrong side of the resistor on the 12v side of the 2n2222. So basically, I was just always sending the tach 12v. Once I switched the output wire to the correct end of the resistor, the tach worked fine.

-Mike
grippgoat is offline   Reply With Quote
Old 07-02-2007, 02:05 AM   #4
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

sly75
thanks for the diagram; that makes so much sense.

COPS are in my future.
Ben is offline   Reply With Quote
Old 07-07-2007, 05:54 PM   #5
Newb
 
Join Date: Feb 2007
Location: Qc, Canada
Posts: 43
Total Cats: 0
Default

No problem dude, all diagrams are available through the different manual that msefi.com share
mazdasly75 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
how to Make 94-95 tach work with MSPNP2 JacksonRacingEngines Engine Performance 10 09-10-2015 10:52 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:27 AM.