Time for MS3 on this thing. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 08-02-2013, 05:08 PM   #1
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2006
Location: Shelton, CT
Posts: 672
Total Cats: 2
Default Time for MS3 on this thing.

Brain has the MS3 on the way to me and now it is FINALLY (after about five years) time to get rid of the band-aids. Goodbye Bipes, O2 clamp and BEGI FMU.

I will track the shenanigans of installing the MS via this thread. Mostly I will likely track my inevitable frustrations as I mess something up.

I've got an upgraded Greddy setup (stripes IC and Tony downpipe) that I've been running on this thing. The fact that I drive it only at autocross and I eventually got a wideband to make sure I wasn't running lean probably contributed to me not blowing it up.

Gonna need to get some new piping to remove the AFM. Probably just get something off CXRacing since I suck at making things. Also need to have someone weld the bung into the IC piping for the AIT. I'll probably take off all the piping and get it powder coated as the paint on the pipes is flaking.

Anyway, that's just background. I'll try to confine my talk in here to MS related issues.
Harv is offline   Reply With Quote
Old 08-05-2013, 11:30 AM   #2
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2006
Location: Shelton, CT
Posts: 672
Total Cats: 2
Default

Okay, so everyone says the TPS on the 90 is basically useless. So, I need to get some sort of VTPS on the thing now that I'm going to the MS3.

Brain pointed me to this thread which has some good info.

https://www.miataturbo.net/megasquir...ble-tps-72554/

This site has the various options on it.

http://westfieldmx5.devocht.com/mega.../variable-tps/

I'd probably prefer to splice the #1 option since it bolts right on, but when I called bmrparts.com up they couldn't even find those first two part numbers in their system.

Seems they have 0-280-120-277 as the E30 TPS (this is for the 90+ E30 cars, but even the previous part doesn't match the numbers from the site).

Anyone done this recently that can comment on those first two options? I can definitely find option #2, but I'm less inclined to do it as I need to figure a way to bolt it on. I suppose I could gut the TPS I have now to make an adapter.

If I can buy the 277 part I noted above and it works I'd go with that.
Harv is offline   Reply With Quote
Old 08-05-2013, 11:51 AM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,818
Total Cats: 1,780
Default

there's always a BMW TPS on the for sale section here... I've never done that route.

I have a #3 solution. I've done the #4 until one of the butterfly screws went through my motor. People say the #5 solution (which is pretty much the same as #3) can be tricky to shave down the tabs just right.
Braineack is online now   Reply With Quote
Old 08-05-2013, 12:10 PM   #4
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2006
Location: Shelton, CT
Posts: 672
Total Cats: 2
Default

Quote:
Originally Posted by Braineack View Post
there's always a BMW TPS on the for sale section here... I've never done that route.

I have a #3 solution. I've done the #4 until one of the butterfly screws went through my motor. People say the #5 solution (which is pretty much the same as #3) can be tricky to shave down the tabs just right.
Ah, this is pertinent to my interests as I am a poor fabricator, splicer. I see there are some enterprising fellows that have taken this cause up. I will see what I can get.

Any real reason to go to the #3 over a BMW TPS?
Harv is offline   Reply With Quote
Old 08-05-2013, 12:22 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,818
Total Cats: 1,780
Default

I like using the OEM connector... I don't like splicing wires.
Braineack is online now   Reply With Quote
Old 08-05-2013, 12:48 PM   #6
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2006
Location: Shelton, CT
Posts: 672
Total Cats: 2
Default

How does the Vishay option avoid the splicing? I see wires hanging out there in the example pics. Or does it have a matching connector that I'm not seeing? I see that it fits onto the D connector on the throttle body.

I'm annoyed, because I busted the stock TPS at one point and then had to replace it, of course I paid too much for the part, being stupid. And now I have to gut it to put this new one in if I go with #3, because I threw away the old busted one.

Harv is offline   Reply With Quote
Old 08-05-2013, 12:56 PM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,818
Total Cats: 1,780
Default

you'd connect them the same way as seen in #5.
Braineack is online now   Reply With Quote
Old 08-05-2013, 01:13 PM   #8
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2006
Location: Shelton, CT
Posts: 672
Total Cats: 2
Default

I see, so there is some soldering involved, but no splicing in the #3 case. I can see how you would be comfortable with soldering.

Gah, I hate making things! Plus, the Vishay is from ze germans. How much is 34,10 €?
Harv is offline   Reply With Quote
Old 08-06-2013, 10:32 AM   #9
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2006
Location: Shelton, CT
Posts: 672
Total Cats: 2
Default

I have the package. This is gonna be cool as soon as I can actually get some time to work on installing it.

Okay, if I don't get a VTPS right away how hard is it to slap one on and update the settings after the fact? IE, should I get it first?
Harv is offline   Reply With Quote
Old 08-06-2013, 10:36 AM   #10
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,818
Total Cats: 1,780
Default

Just make sure that your acceleration enhancements are set to MAPdot instead of TPSdot.
Braineack is online now   Reply With Quote
Old 08-06-2013, 11:20 AM   #11
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2006
Location: Shelton, CT
Posts: 672
Total Cats: 2
Default

I get the feeling this doesn't matter, but I figure I will ask anyway.

The timing currently is set to around 13 degrees and then the Bipes pulls a bunch out in boost. Do I need to reset the timing to 10 before I pull everything off and put the new computer in? I'm assuming that's a no since the new computer is doing everything differently and that I just need to verify the timing using the light once the car is started.

Now that I write this out, this seems like a really dumb question.
Harv is offline   Reply With Quote
Old 08-06-2013, 11:21 AM   #12
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,818
Total Cats: 1,780
Default

Braineack is online now   Reply With Quote
Old 08-06-2013, 12:21 PM   #13
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2006
Location: Shelton, CT
Posts: 672
Total Cats: 2
Default

Stupidity++
Harv is offline   Reply With Quote
Old 08-07-2013, 12:25 PM   #14
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2006
Location: Shelton, CT
Posts: 672
Total Cats: 2
Default

Damned work and babies. I gotta get the AIT bung welded on to the manifold pipe before I can do anything connecting up the MS. Probably find someone to do that.
Harv is offline   Reply With Quote
Old 08-07-2013, 08:13 PM   #15
Boosting since 1984
iTrader: (1)
 
stefanst's Avatar
 
Join Date: Sep 2011
Location: Levittown
Posts: 1,198
Total Cats: 68
Default

I was driving with the ait sensor on the passenger seat for a while. No big deal, if you have an IC and don't boost heavily.
stefanst is offline   Reply With Quote
Old 08-08-2013, 12:55 PM   #16
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2006
Location: Shelton, CT
Posts: 672
Total Cats: 2
Default

Ech, I'd rather just do it right the first time. Plus, I have to bring it out to autocross on 8/18, so I'm thinking I might not go full out on the install until after that as I'll have a full month between events to get everything right.
Harv is offline   Reply With Quote
Old 08-08-2013, 02:08 PM   #17
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2006
Location: Shelton, CT
Posts: 672
Total Cats: 2
Default

I'm glad I started looking up threads about the AIT location.

So, optimally I want to mount this thing in the cold side intercooler pipe as close to the intercooler as possible to minimize heat soak from the engine?

A guy I know who did the BEGI kit said that his AIT would constantly heat soak and keep the car from starting if he ran the car, got it hot and then parked it with the hood down. Not sure if it's just because of his car setup or what, but that sounds pretty damned annoying.
Harv is offline   Reply With Quote
Old 08-08-2013, 02:12 PM   #18
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,818
Total Cats: 1,780
Default

its not such a big deal on ms3; it was on ms1.
Braineack is online now   Reply With Quote
Old 08-08-2013, 02:47 PM   #19
Senior Member
Thread Starter
iTrader: (4)
 
Join Date: Jul 2006
Location: Shelton, CT
Posts: 672
Total Cats: 2
Default

That's interesting. What's the difference? Different type of AIT?
Harv is offline   Reply With Quote
Old 08-08-2013, 03:24 PM   #20
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,818
Total Cats: 1,780
Default

the code.
Braineack is online now   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:54 PM.