WOT "Hesitation" @ 8psi - HELP - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 11-14-2012, 10:50 PM   #1
Newb
Thread Starter
 
Join Date: Jun 2012
Location: Greenville, SC
Posts: 32
Total Cats: -1
Default WOT "Hesitation" @ 8psi - HELP

Ok, I'm losing my mind with this thing. I'm running a MSPNP on a 1.6L with a Greddy turbo intercooled @ 8psi and an Innovate LC-1. I had it tuned pretty well, but recently added a BOV, and GM IAT sensor and reflashed the MSPNP firmware (thanks to brain's assistance) for the calibration. I tracked down a fuel pump relay transistor that was blown and replaced it, and removed the hated AFM.

So, after a few days of tweaking the idle and fuel maps, it's running pretty well. I have been using VE autotune to get the maps dialed in, but when I go WOT, and it reaches +5psi the car starts to lunge and hiccup. It's as if the fuel has been cut momentarily. Sometimes, depending on the rpm range, it will make it "through" the hiccup area and continue into boost. I replaced spark plugs, smoothed the map (fairly well?), and have checked out the BOV (thinking maybe it could be boost leak? - maybe it still is?). I'm at a loss. I feel pretty sure it's something simple, but it's making me wish I had left the AFM in and not re-tuned.

Please help!
slpstream4 is offline   Reply With Quote
Old 11-14-2012, 10:52 PM   #2
Newb
Thread Starter
 
Join Date: Jun 2012
Location: Greenville, SC
Posts: 32
Total Cats: -1
Default Pics / log

added pic of megalogviewer and a tune file of the issue. The vertical line marks the start of the "hesitation"
Attached Thumbnails
WOT "Hesitation" @ 8psi - HELP-wot-shutter.png  
Attached Files
File Type: msl 2012-11-14_19.38.51.msl (28.4 KB, 58 views)

Last edited by slpstream4; 11-14-2012 at 10:57 PM. Reason: Adding pics
slpstream4 is offline   Reply With Quote
Old 11-14-2012, 11:48 PM   #3
Senior Member
iTrader: (2)
 
Join Date: Jun 2007
Location: Shalimar, FL
Posts: 965
Total Cats: 7
Default

Your fuel IS being cut completely. You can see the duty cycle drop to 0. What is your boost/MAP cutoff at? RPM limit?

Also, it would be more helpful to you and us if you put other variables on that MLV screenie other than MAP, AFR, and Duty Cycle 3 times. Add TP, RPM, etc.
messiahx is offline   Reply With Quote
Old 11-15-2012, 12:05 AM   #4
Newb
Thread Starter
 
Join Date: Jun 2012
Location: Greenville, SC
Posts: 32
Total Cats: -1
Default

Well, I updated the chart, and added my maps. I have no TPS, so I didn't put that on the chart. As for boost / MAP, are you referring to the VE map? It goes well above my 8psi levels. If not, you'll have to forgive my newness to MS. I added a shot of the RPM limits, but my max was only ~5500 on the chart. The hiccups seem to start as low as 3900 at 151kpa....


Well... as I type this, I find the "Over Boost Protection" menu.... was it really that easy all along???
Attached Thumbnails
WOT "Hesitation" @ 8psi - HELP-screen-shot-2012-11-14-10.56.58-pm.jpg   WOT "Hesitation" @ 8psi - HELP-screen-shot-2012-11-14-10.57.50-pm.png   WOT "Hesitation" @ 8psi - HELP-screen-shot-2012-11-14-11.01.22-pm.png   WOT "Hesitation" @ 8psi - HELP-screen-shot-2012-11-14-11.04.39-pm.png  
slpstream4 is offline   Reply With Quote
Old 11-15-2012, 01:03 AM   #5
Senior Member
iTrader: (2)
 
Join Date: Jun 2007
Location: Shalimar, FL
Posts: 965
Total Cats: 7
Default

Bingo! Don't feel too bad, I made plenty of silly mistakes learning. Killed a motor, too.
messiahx is offline   Reply With Quote
Old 11-15-2012, 01:07 AM   #6
Newb
Thread Starter
 
Join Date: Jun 2012
Location: Greenville, SC
Posts: 32
Total Cats: -1
Default

Thanks so much for the help!!! This forum is great.
slpstream4 is offline   Reply With Quote
Old 11-15-2012, 08:00 PM   #7
Newb
Thread Starter
 
Join Date: Jun 2012
Location: Greenville, SC
Posts: 32
Total Cats: -1
Default

So, I updated the Over Boost Protection to 170kpa last night. It was too late to take my loud car out after the update. I checked my oil, and noticed it was very low, so I added a quart or so, and installed another smaller air filter, so that I could get the air coming in from behind the headlight. Those were the ONLY changes I made last night. When I drove in to work this morning, I now barely make 5psi. What the heck? I was making 8psi (hence the 152kpa limit hit) all night long last night.

When I took the intake pipe off this evening, I noticed a slight amount of oil from the turbo, but found very little on the boost side. I'm stumped. Boost leak, maybe? But I can't find anything that's any different than it was last night.

Would the overboost protection change make it not make boost now? That would seem really odd, if so...
slpstream4 is offline   Reply With Quote
Old 11-16-2012, 08:42 PM   #8
Senior Member
iTrader: (2)
 
Join Date: Jun 2007
Location: Shalimar, FL
Posts: 965
Total Cats: 7
Default

Changing overboost protection won't cause that. Something else has changed. I wouldn't be overly concerned with the oil, though if your turbo is ball bearing you will want to invest in a restrictor if you haven't already.

Start checking couplers. Are you running EBC? Easiest way to check for leaks is to let it idle and spray WD-40 or carb cleaner on all hose connections and it'll jump pretty quickly if any gets in.
messiahx is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1.8 TB/TPS for use with 1.6 wiring Elfering MEGAsquirt 17 12-16-2016 07:44 PM
Miata new person and a what's it worth! Model192 Meet and Greet 16 09-29-2015 09:50 PM
TPS based AFR map for better mileage (?) elior77 MEGAsquirt 30 09-23-2015 07:38 PM
WTB: PNP injectors for NA (92) Besusjesus WTB 2 09-01-2015 10:19 AM
What do you think? malcpw DIY Turbo Discussion 8 05-26-2007 02:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:54 PM.