Wrong Code Loaded? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 01-23-2016, 12:42 PM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2015
Posts: 77
Total Cats: -7
Default Wrong Code Loaded?

I recently bought a 94-95 DIYMS2 and rejumpered it for a 90-93, and attempted the "first start" last night. I am still N/A and am running the stock injectors.

At first, I was having a hard time flashing the firmware, but I eventually got it. Unfortunately I've been trying to use the PNPMS2 firmware setting instead of Megasquirt 2, so I reflashed it today. I'm using the newest MS firmware.

Alright, so boot jumper on, do the flash process, boot jumper off, open TS, start new project, get a message like the first picture that says my firmware and tune file signatures don't match(first issue), click load anway, all setting are wacky, load the 1.6L tune from DIYAUTOTUNE's website, and everything goes wonky. Well, stays wonky. The pictures show all of the errors.

Another side note, when I power the car, my fuel pump goes on and off continuously, until I go into TunerStudio and either load a project or load a tune in the project, then it stops. But if I power cycle, it comes right back on until I reload the same tune.

Also, my left radiator fan was going while the firmware was being flashed, and turned off when the firmware was finished.

I do have internet connection through the process. I also have many other error pictures from last night, if those would help, but that was when I was trying to use the PNPMS2 firmware setting.

It also looks like I have been trying this without removing the TPS pigtail, big difference?

Thank you.
Attached Thumbnails
Wrong Code Loaded?-0123161123b.jpg   Wrong Code Loaded?-0123161123a.jpg   Wrong Code Loaded?-0123161123.jpg   Wrong Code Loaded?-0123161117.jpg   Wrong Code Loaded?-0123160152e.jpg  

Wrong Code Loaded?-0123160152f.jpg  

Last edited by Bodhimeister; 01-23-2016 at 12:52 PM.
Bodhimeister is offline   Reply With Quote
Old 01-23-2016, 01:49 PM   #2
Junior Member
Thread Starter
 
Join Date: Jul 2015
Posts: 77
Total Cats: -7
Default

I'm just an idiot. Don't worry about replying to this one. I didn't consider that maybe the DIYPNP setting was right for my DIYPNP.
Bodhimeister is offline   Reply With Quote
Old 01-23-2016, 02:22 PM   #3
Junior Member
Thread Starter
 
Join Date: Jul 2015
Posts: 77
Total Cats: -7
Default

Alright. So I've loaded the correct firmware, and now my fuel pump doesn't go crazy and I don't get a ton of errors. However, when I try to load the 1.6L tune to Tunerstudio, the signatures still don't match. I was also under the impression that TS would find the correct .ini file for me, but it instead made me do it manually. So I chose the same file that I used for the firmware, Microsquirt module.ini. Very little of the tune actually loads into Tunerstudio.
Bodhimeister is offline   Reply With Quote
Old 01-26-2016, 09:23 AM   #4
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

Sometimes that can happen - usually if (1) you're using a code that is either newer than your download of TunerStudio or rather obscure, and (2) you're not connected to the Internet when you connect.
Matt Cramer is offline   Reply With Quote
Old 01-26-2016, 10:21 AM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,867
Total Cats: 1,790
Default

Quote:
Unfortunately I've been trying to use the PNPMS2 firmware setting instead of Megasquirt 2, so I reflashed it today. I'm using the newest MS firmware.
dude. READ. seriously. open your eyes and look at the freaking options.




Quote:
Originally Posted by Bodhimeister View Post
Alright. So I've loaded the correct firmware, and now my fuel pump doesn't go crazy and I don't get a ton of errors. However, when I try to load the 1.6L tune to Tunerstudio, the signatures still don't match. I was also under the impression that TS would find the correct .ini file for me, but it instead made me do it manually. So I chose the same file that I used for the firmware, Microsquirt module.ini.

Reflash the firmware file again, correctly.

It's really easy if you just start a new project and let TS download the correct firmware file once you click detect. If you've already set up a project under a different firmware, then you have to change it manually.

Quote:
Very little of the tune actually loads into Tunerstudio.
Youre trying to jam a square peg into a round hole -- the DIY basemap is a very old firmware, so if you have any newer one installed on your project, of course very little of the tune actually loads, because it doesn't have half the newest features included. That map will only load what's still common between the two.
Attached Thumbnails
Wrong Code Loaded?-80-undefined_ebe9ba9a68d2e21eb5b7d0221323740fc62fb7fc.png  
Braineack is online now   Reply With Quote
Old 01-26-2016, 10:30 AM   #6
Junior Member
Thread Starter
 
Join Date: Jul 2015
Posts: 77
Total Cats: -7
Default

Appreciate the reply. I was being an absolute idiot. I got the Microsquirt(DIYPNP) firmware flashed and loaded up a newer tune a few days ago. With some advanced settings tweaking, the signatures matched. Now I'm on to timing.
Bodhimeister is offline   Reply With Quote
Old 01-26-2016, 11:25 AM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,867
Total Cats: 1,790
Default

sweet.
Braineack is online now   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
M-Tuned / 949racing Custom Coolant Re-route Code Monkey Miata parts for sale/trade 10 02-04-2016 11:53 PM
got it running but its being funny (datalogs and tune file present) itsMikey MEGAsquirt 11 01-15-2016 10:27 AM
Bought'a'miata! DrSchmoll Meet and Greet 3 01-11-2016 11:45 AM
NA/NB Fuel Pump Assembly Interchange aidandj General Miata Chat 0 01-01-2016 02:23 PM
Megasquirt pnp2 engine gets flooded as soon as I turn the key Jerrypena1881 MEGAsquirt 1 12-25-2015 07:40 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:15 PM.