injectors injectors injectors.... - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 05-08-2010, 09:17 PM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Oct 2008
Location: Edmonton, Alberta
Posts: 86
Total Cats: 0
Default injectors injectors injectors....

Hey still having issues with my injectors. My previous thread was this..
https://www.miataturbo.net/diy-turbo-discussion-14/injector-issue-46929/.

but I made a mistake. Actually ALL injectors are firing wide open causing a buttload of fuel when KEY ON ENGINE OFF. I took a peak at the 1.6L service manual and traced the circuit. The PCM is the control side of the injector circuit. Power all the time but grounded via PCM. I checked the connectors with the multimeter and did not find a short to ground. I swapped the MSPNP to the stock oem PCM/ECU and it did NOT fire the injectors wide open at KEYON ENGINE OFF.

I took a look at the DIYautotune miata quickstart guide and it didn't say anything else besides pulling the fuse and starting it pretty much. So I don't think I'm missing something obvious?

I just literally had it repaired at diyautotune a month ago and did not touch anything else. This is why you don't used mspnp from unknowns folks...
aphongt is offline   Reply With Quote
Old 05-08-2010, 09:49 PM   #2
I'm a terrible person
iTrader: (19)
 
FRT_Fun's Avatar
 
Join Date: Apr 2009
Location: Arizona
Posts: 7,293
Total Cats: 180
Default

FRT_Fun is offline   Reply With Quote
Old 05-08-2010, 10:20 PM   #3
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Oct 2008
Location: Edmonton, Alberta
Posts: 86
Total Cats: 0
Default

I haven't tried unplugging the TPS connector yet, I'm going to look up on why it would do that. Thats what I don't understand. Must be some aftermarket thing. I'll give that a shot tonight. Apparantly the VTPS mod has been done on the mspnp, but I have a stock manual TPS. I'll do a bit more fishing around and see what I can find, unless sometime explains it to me right here and now.
aphongt is offline   Reply With Quote
Old 05-10-2010, 01:36 AM   #4
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Oct 2008
Location: Edmonton, Alberta
Posts: 86
Total Cats: 0
Default

Quote:
Originally Posted by aphongt View Post
I haven't tried unplugging the TPS connector yet, I'm going to look up on why it would do that. Thats what I don't understand. Must be some aftermarket thing. I'll give that a shot tonight. Apparantly the VTPS mod has been done on the mspnp, but I have a stock manual TPS. I'll do a bit more fishing around and see what I can find, unless sometime explains it to me right here and now.

update: Unplugged the TPS and it stopped flooding the cylinders. Weeeeird. Now I have a massive vacuum leak I have to find. :(
aphongt is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:13 PM.