installed 4 bar in mspnp, car idles, doesnt run under load - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 04-08-2010, 09:40 AM   #1
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Jan 2009
Location: CT
Posts: 271
Total Cats: 0
Default installed 4 bar in mspnp, car idles, doesnt run under load

Hey guys, I'm having trouble with my new 4 bar. Installed it just like the site said, changed all the settings, car starts and idles great, when I put it in gear and put any load on the engine, it stalls out. It fires right back up and idles fine. It seems to cut out the fuel under and type of load. All my tables look normal. Any ideas? Its a 91 mspnp ms1 version 029. Thanks
FastColt is offline   Reply With Quote
Old 04-08-2010, 09:42 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

can you post the MSQ?
Braineack is offline   Reply With Quote
Old 04-08-2010, 09:52 AM   #3
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Jan 2009
Location: CT
Posts: 271
Total Cats: 0
Default

Yeah when I get home I'm on my phone now. Fail....
FastColt is offline   Reply With Quote
Old 04-08-2010, 09:58 AM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

The only thing I can think is that you didn't change a setting, but even still it should run without problems.

did you turn barometric correction on? did you install the little capacitor?
Braineack is offline   Reply With Quote
Old 04-08-2010, 10:07 AM   #5
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Jan 2009
Location: CT
Posts: 271
Total Cats: 0
Default

Yes and yes. I'm so stumpt and its bugging the **** outta me.
FastColt is offline   Reply With Quote
Old 04-08-2010, 10:09 AM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

did you make sure the corrections were within 90-100kPa and not the full spectrum?
Braineack is offline   Reply With Quote
Old 04-08-2010, 10:14 AM   #7
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Jan 2009
Location: CT
Posts: 271
Total Cats: 0
Default

Not sure about that part. When I switched it to 400kpa it kept my tables the same buy just added fuel above 256kpa.
FastColt is offline   Reply With Quote
Old 04-08-2010, 10:39 AM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

Might be the issue; there's a setting to put the range in which you need barometric corrections. Sea level should be 100kPa give or take and then when you go up into mountains it'll drop to 90Kpa or so (not quite sure what reading you get that high). So the range to input should be around 90-100kPa. I've seen some maps that have the scale set to 20-255kPa, which pretty much kills your tune because it's over-correcting like whoa.
Braineack is offline   Reply With Quote
Old 04-08-2010, 02:17 PM   #9
Junior Member
Thread Starter
iTrader: (5)
 
Join Date: Jan 2009
Location: CT
Posts: 271
Total Cats: 0
Default

Braineak is an understatement. I think i have a man crush on you! You were right, I changed to boro limits from 36-376kpa to 90-100kpa and the car runs perfect. Thanks for the help! I owe you a cold one when im in VA, if i ever go there lol.
FastColt is offline   Reply With Quote
Old 04-08-2010, 02:25 PM   #10
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

I only know because I've done it myself
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
91 1.6l turbo complete part out. Tony the Tiger Miata parts for sale/trade 63 12-29-2016 03:23 AM
MS PNP requires reading and following directions??? satisfied MEGAsquirt 141 10-06-2015 11:44 AM
Now shipping NC MX-5 (2006-15) Precision Sliding Seat Mounts FAB Fab9 Tuning - Miata Performance Parts 0 09-11-2015 01:02 PM
Missfires on idle and cruising (no load) emarkey DIY Turbo Discussion 2 09-05-2015 07:59 PM
Help Rough Idle Backwoodsballer General Miata Chat 0 09-04-2015 07:39 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:04 PM.