Intake air temp causing car to run lean MSPNP1 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 08-15-2014, 03:56 PM   #1
Newb
Thread Starter
 
Join Date: Aug 2014
Posts: 13
Total Cats: -2
Default Intake air temp causing car to run lean MSPNP1

I think I have tracked down an issue where the car runs very lean once it heats up and the hood is closed. The AFR jumps from around a healthy ~14 to closer to 16 and fights to idle smoothly. This is setup with the maf delete so the GM ait sensor seems to be playing havoc or the calibration is way off!

The sensor is near the filter on the hot side of the engine but I wrapped the intake in insulation.

Should I swap the sensor out?
scareyourpassenger is offline   Reply With Quote
Old 08-15-2014, 03:59 PM   #2
Elite Member
iTrader: (3)
 
concealer404's Avatar
 
Join Date: Aug 2011
Posts: 8,460
Total Cats: 782
Default

What are your temps showing?
concealer404 is offline   Reply With Quote
Old 08-15-2014, 04:00 PM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

tune the clt-related air density table (turn it to AIT under advanced)
Braineack is offline   Reply With Quote
Old 08-15-2014, 04:00 PM   #4
Newb
Thread Starter
 
Join Date: Aug 2014
Posts: 13
Total Cats: -2
Default

I don't have access to the logs now but it seems to make sense according to the map. Soon as the ait temp jumped the AFR dropped.
scareyourpassenger is offline   Reply With Quote
Old 08-15-2014, 04:01 PM   #5
Newb
Thread Starter
 
Join Date: Aug 2014
Posts: 13
Total Cats: -2
Default

Thanks, I will take a look at that.
scareyourpassenger is offline   Reply With Quote
Old 08-15-2014, 04:01 PM   #6
Elite Member
iTrader: (3)
 
concealer404's Avatar
 
Join Date: Aug 2011
Posts: 8,460
Total Cats: 782
Default

Quote:
Originally Posted by scareyourpassenger View Post
I don't have access to the logs now but it seems to make sense according to the map. Soon as the ait temp jumped the AFR dropped.
Dropped? Got richer?

Do what Brain said.
concealer404 is offline   Reply With Quote
Old 08-15-2014, 04:03 PM   #7
Newb
Thread Starter
 
Join Date: Aug 2014
Posts: 13
Total Cats: -2
Default

Leaner

Quote:
Originally Posted by concealer404 View Post
Dropped? Got richer?

Do what Brain said.
scareyourpassenger is offline   Reply With Quote
Old 11-24-2014, 06:30 PM   #8
Newb
Thread Starter
 
Join Date: Aug 2014
Posts: 13
Total Cats: -2
Default

And then I discovered that the previous owner removed the EGR but didn't put a plate on the intake manifold blocking it off..
scareyourpassenger is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
91 1.6l turbo complete part out. Tony the Tiger Miata parts for sale/trade 63 12-29-2016 03:23 AM
1.8, C30-74 Rotrex, 9psi, 235WHP/190WTQ (E85) Lincoln Logs Dynos and timesheets 4 09-23-2015 01:26 PM
Help multi issues here! ReallyRottenTurbo MEGAsquirt 4 09-22-2015 01:49 PM
Ms2e 99-00 ac control Dobzeh MEGAsquirt 23 09-15-2015 05:49 PM
VE values too low? compuw22c MEGAsquirt 4 09-12-2015 08:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:08 PM.