MS PnP Virgin - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 03-11-2009, 04:38 PM   #1
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Leeds, UK
Posts: 31
Total Cats: 0
Default MS PnP Virgin

Hi All,
Just got back from my hols in New York (I live in the UK) and managed to hide a pnp in my suitcase (from the wife).
I want to try and get my car up and running NA, but with the pnp before fitting my tubby.
I've got the AIT sensor and an apropriate pipe.
Can anyone think of anything else I need before fitting the pnp to get it running smoothly NA.
Thanks,
Pat...
Avoneer is offline   Reply With Quote
Old 03-11-2009, 04:54 PM   #2
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

As long as you have a laptop, you're good to go. You can even put the MSPNP in before installing the IAT sensor if you have the stock MAF or AFM in place.
Matt Cramer is offline   Reply With Quote
Old 03-11-2009, 04:58 PM   #3
Senior Member
iTrader: (4)
 
Join Date: Oct 2006
Location: Tampa
Posts: 780
Total Cats: 0
Default

That is all you need Pat. I would install the MSPNP as it is. Select whatever project you are working on 90-93, 94-95, 96-97. Follow the instructions to set all the parameters in the MS. Once you have all of that settled. Then install the AIT and select your project without the AFM or MAF.

Also, put your car's info in the signature so we can better help you.
96rdstr is offline   Reply With Quote
Old 03-11-2009, 04:58 PM   #4
Senior Member
iTrader: (1)
 
Join Date: Sep 2007
Location: Trenton, NJ
Posts: 1,125
Total Cats: 0
Default

Wideband 02 sensor.
ArtieParty is offline   Reply With Quote
Old 03-11-2009, 07:20 PM   #5
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Leeds, UK
Posts: 31
Total Cats: 0
Default

Hi All,
Cheers for the speedy reply.
I'm going to fit the AIT at the same time as the pnp.
Eventually I'll be fitting an old FMII turbo and in the mean time can utilise the FM air filter and heat shield that surrounds the air filter just behind the headlight.
I've got an LC-1 so shall I fit that at the same time or do that once the car is up and running again.
Cheers,
Pat...
Avoneer is offline   Reply With Quote
Old 03-11-2009, 07:25 PM   #6
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Leeds, UK
Posts: 31
Total Cats: 0
Default

Ooops, can't get my sig to appear - I have tried, honest!

Pat...
Avoneer is offline   Reply With Quote
Old 03-11-2009, 07:25 PM   #7
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Leeds, UK
Posts: 31
Total Cats: 0
Default

Ahh, there we go,

Pat...
Avoneer is offline   Reply With Quote
Old 03-12-2009, 07:20 PM   #8
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Leeds, UK
Posts: 31
Total Cats: 0
Default

Do I really need to fit the LC-1 now or will it cope without it?

Thanks,

Pat...
Avoneer is offline   Reply With Quote
Old 03-13-2009, 11:54 AM   #9
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

It can run off the stock narrow band; I would add the LC-1 before forced induction or serious tuning efforts though.
Matt Cramer is offline   Reply With Quote
Old 03-13-2009, 05:26 PM   #10
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Leeds, UK
Posts: 31
Total Cats: 0
Default

Thanks - thought so.

Will fit the pnp and AIT tomorrow and see what happens.

Then LC-1 in a few weeks.

Then tubby.

Watch this space - no doubt I'll be frequenting here more often!

Pat...
Avoneer is offline   Reply With Quote
Old 03-14-2009, 04:58 PM   #11
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Leeds, UK
Posts: 31
Total Cats: 0
Default

Hi All,

pnp fitted with the AFM removed.

I opened megatune and opened the 90-93 w/o AFM.

The car started up and idled, but was a little rough at first.

Once we had set the timing, idle was fine.

Two problems though:

1) The water temp was showing as 200 F and some ????

2) When driven, there's some hesitation/kangarooing between 3k and 5k revs.

I haven't upgraded any firmware or loaded or saved any maps yet.

Can someone point me in the right direction please.

Thanks,

Pat...
Avoneer is offline   Reply With Quote
Old 03-14-2009, 06:48 PM   #12
Elite Member
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,658
Total Cats: 39
Default

Quote:
Originally Posted by Avoneer View Post
Hi All,

pnp fitted with the AFM removed.

I opened megatune and opened the 90-93 w/o AFM.

The car started up and idled, but was a little rough at first.

Once we had set the timing, idle was fine.

Two problems though:

1) The water temp was showing as 200 F and some ????

2) When driven, there's some hesitation/kangarooing between 3k and 5k revs.

I haven't upgraded any firmware or loaded or saved any maps yet.

Can someone point me in the right direction please.

Thanks,

Pat...
1) Set the configurator to read Deg C

2) Tune the VE table with MegaLogViewer
richyvrlimited is offline   Reply With Quote
Old 03-14-2009, 08:18 PM   #13
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Leeds, UK
Posts: 31
Total Cats: 0
Default

Is the config file held inside the pnp or on the laptop or both?

I take it you edit it on the laptop and then burn to pnp?

Thanks for the pointer - off to search and educate myself on megalogviewer.

Thanks and sorry for me being "simple".

Pat...
Avoneer is offline   Reply With Quote
Old 03-15-2009, 09:32 AM   #14
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Leeds, UK
Posts: 31
Total Cats: 0
Default

Right, I've have managed to log a good 15 minute session, upload it into MLV and analysed it.

Uploaded the new MSQ back to the pnp and it ran a lot better, although still a bit rough between 3.5k and 4.5k.

Have done another 15 minute log and concentrated on keeping the revs between those values and just uploaded another MSQ back to the pnp.

Yet to run car again, but I'm beginning to understand.

Even managed to change the display to degrees C!

Thanks for the pointers.

LC-1 to fit soon, then tubby.

Pat...
Avoneer is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
15x10 - 15x11 6UL @ 949 Racing emilio700 Wheels and Tires 151 06-02-2017 03:36 PM
Complete BEGI S3 NB Kit, Full Enthuza 3" Exhaust, ACT HD Clutch, MS2 PNP, Wideband kronikker Miata parts for sale/trade 17 10-06-2015 11:18 PM
Any pnp megasquirt for 2001 Big_gumby WTB 0 09-30-2015 04:34 PM
1996 Turbo Build Goldwar DIY Turbo Discussion 2 09-29-2015 10:20 AM
Flex fuel settings on Rev build MS3 PnP for NB8B nitrodann MEGAsquirt 0 09-07-2015 09:01 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:00 PM.