MSPNP2 1994 BEGI S3 ISSUES! - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 07-16-2013, 10:52 PM   #1
Newb
Thread Starter
 
Join Date: Oct 2012
Location: Northern California!
Posts: 26
Total Cats: 0
Default MSPNP2 1994 BEGI S3 ISSUES!

2 current problems.

1st is minor. Launch control turned on when driving normal for no apparent reason. Start up again car drives normal again. I feel like there is a fault in my mspnp2 ecu. Once it hits launch control set at 3000 rpms I pulLED to the side and turn it off and restart it to re jump my ecu and it drives fine after that. I hope someone would understand and have solved a similar issue.

2nd issue is sometimes when at wot the car will hit 5000-5500 rpms and have some sort of fuel cut or ignition cut immediately. Car when then proceed to accelerate at wot. Afr is correct... boost kpa max safe is correct and extended. Any answers? This is done with launch control off or on doesn't matter. Only does this sometimes. Feels like when it wants to.

Rechecked everything motor is freshly swapped in re route. S3 kit on a 1.8 550 inj. 255 lph fp. Bkr7 iridiums. Never had problems before some how just arise.
Thanks for any kind of help, wrote this on the phone. Will upload msq.
Attached Files
File Type: msq CurrentTune.msq (83.6 KB, 55 views)

Last edited by NobleMiata; 07-16-2013 at 11:14 PM. Reason: wrote on phone
NobleMiata is offline   Reply With Quote
Old 07-17-2013, 10:11 AM   #2
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

Check your neutral safety switch; they can trigger launch controll too.

Can you get a data log of the ~5000 RPM cutout and post it?
Matt Cramer is offline   Reply With Quote
Old 07-17-2013, 10:01 PM   #3
Newb
Thread Starter
 
Join Date: Oct 2012
Location: Northern California!
Posts: 26
Total Cats: 0
Default

Quote:
Originally Posted by Matt Cramer View Post
Check your neutral safety switch; they can trigger launch controll too.

Can you get a data log of the ~5000 RPM cutout and post it?
Im on it now. Just got back from work. Morning drive to work got it warmed up to 180 degrees and wot on the free way. Hit that 5k rpm cutout again. Keep doing it whenever I got on it.

Drive home in the afternoon car did not do it. All the way home I was testing and went fine all the way up to 7k rpms. Will try to route more grounds around ecu even though there is alot already.
NobleMiata is offline   Reply With Quote
Old 07-18-2013, 12:13 AM   #4
Newb
Thread Starter
 
Join Date: Oct 2012
Location: Northern California!
Posts: 26
Total Cats: 0
Default

Data logged, I haven't got to wiring the LC-1 into the MSPNP2. But it's been showing 11.5-12 afrs at wot and steady. This was done while data logging and it didn't cut out this time around. Maybe tomorrow it will, lol. Regrounded maybe that helped.
Attached Files
File Type: msl cutout test 1.msl (214.8 KB, 252 views)
File Type: msl cutout test 2.msl (1.40 MB, 57 views)
NobleMiata is offline   Reply With Quote
Old 07-18-2013, 12:15 AM   #5
Newb
Thread Starter
 
Join Date: Oct 2012
Location: Northern California!
Posts: 26
Total Cats: 0
Default

Oh and my neutral safety switch has been unplugged and wrapped as it should be for the launch control to work when clutch is depressed as i READ the other posts. It worked fine but for some reason it started kicking on whenever it wanted to. So i turned launch control off and is still currently off. I rather not deal with it.
NobleMiata is offline   Reply With Quote
Old 07-18-2013, 09:42 AM   #6
Newb
Thread Starter
 
Join Date: Oct 2012
Location: Northern California!
Posts: 26
Total Cats: 0
Default

Ok drove it this morning and it happened again. The whole drive it was cutting out at around 5k rpms. Didnt bring laptop couldnt log it. Is it when cold? Lights on drawing too much power? Im really lost now. Thanks for any help.
NobleMiata is offline   Reply With Quote
Old 07-18-2013, 10:38 AM   #7
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

With the information so far, I had to consult the Magic 8 Ball. Unfortunately, it came up with "Reply hazy. Please get a data log."
Matt Cramer is offline   Reply With Quote
Old 07-18-2013, 12:27 PM   #8
Newb
Thread Starter
 
Join Date: Oct 2012
Location: Northern California!
Posts: 26
Total Cats: 0
Default

Log named cutout test 1 and 2 attached up top.
NobleMiata is offline   Reply With Quote
Old 07-18-2013, 04:03 PM   #9
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

Yes, but they're the wrong data logs. I need a data log of the 5000 RPM cutout. A data log where nothing goes wrong tells me nothing about what's going wrong.
Matt Cramer is offline   Reply With Quote
Old 07-18-2013, 05:36 PM   #10
Newb
Thread Starter
 
Join Date: Oct 2012
Location: Northern California!
Posts: 26
Total Cats: 0
Default

Ok I guess I will have to hope for it to come up. Like I said its random. Will try to data log every drive when it comes on. Thanks.
NobleMiata is offline   Reply With Quote
Old 07-19-2013, 09:48 AM   #11
Newb
Thread Starter
 
Join Date: Oct 2012
Location: Northern California!
Posts: 26
Total Cats: 0
Default

I believe I figured it out. I set on boost safety cutout at 180 kpa. Data log shows 178.8 kpa when wot on a 95 degree weather day afternoon. So when cold I was guessing it pulled more than 180 kpa so I turned boosr safeth cutout to 200 kpa. Car drover perfect this moening and is boost spiking to 12 psi. Thanks for the help.
NobleMiata is offline   Reply With Quote
Old 07-19-2013, 09:51 AM   #12
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,889
Total Cats: 1,792
Default

boost cut will happen BEFORE you breach the limit. give yourself a good 2psi tolerance headroom window space hysteresis.
Braineack is offline   Reply With Quote
Old 07-19-2013, 04:54 PM   #13
Newb
Thread Starter
 
Join Date: Oct 2012
Location: Northern California!
Posts: 26
Total Cats: 0
Default

Will do. Thanks will keep that in mind. Scared me. Thought it was something big.
NobleMiata is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
91 1.6l turbo complete part out. Tony the Tiger Miata parts for sale/trade 63 12-29-2016 03:23 AM
MS PNP requires reading and following directions??? satisfied MEGAsquirt 141 10-06-2015 11:44 AM
Help Rough Idle Backwoodsballer General Miata Chat 0 09-04-2015 07:39 AM
New manifold and DP .... FM or BEGI? jayc72 DIY Turbo Discussion 32 01-23-2008 07:45 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:10 PM.