Preparing .msq for first startup - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 09-18-2008, 03:11 PM   #1
Elite AbsurdFlow Member
Thread Starter
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Question Preparing .msq for first startup

Ok, the rebuild is progressing very nicely and the engine is probably in the car by today. See https://www.miataturbo.net/forum/sho...332#post309332

The car will be started for the first time early next week. I talked to the guy in the shop doing most of the work on my car and his intention is to start it up with the 550's and MSPNP and not bother with the old ECU.

So, I am preparing a .msq for the 550's. I want to check with you guys if I am taking the proper steps?

1. Install MegaTune 2.25p1 as per CD-ROM
2. Upgrade MegaTune to 2.25p3 from site
3. Choose which firmware 029y4 or HiRes to go with. I don't feel like installing a 0.1uF capacitor right now.
4. Open base map, adjust for 550's*

*) I came up with this using Excel:

Code:
		 OEM 	 550cc 
Req Fuel	 13,0 	 6,4 
Inj opening	 1,2 	 1,2 


Cr PW	 OEM 	 550cc 
-40	 8,8 	 4,9 
-29	 8,3 	 4,7 
-18	 7,8 	 4,4 
-7	 7,3 	 4,2 
4	 8,2 	 4,6 
16	 7,5 	 4,3 
27	 6,3 	 3,7 
38	 4,8 	 3,0 
54	 3,6 	 2,4 
71	 3,1 	 2,1
I also want to change from F to C. Just replace everything in the .msq and where else?

What else?

Then put it in the car, and:
- Calibrate TPS
- Check sensors for plausible readings (CLT, MAP, ?)


Thanks!
Laur3ns is offline   Reply With Quote
Old 09-18-2008, 04:51 PM   #2
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

Often the best way to go from F to C is load the MSQ file, disconnect, change MegaTune over to C, then download it from the ECU.

If that's a Rev C (check the label underneath) it will already have the cap mod. The cap isn't just for hi res code.
Matt Cramer is offline   Reply With Quote
Old 09-18-2008, 05:01 PM   #3
Elite AbsurdFlow Member
Thread Starter
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Default

Quote:
Originally Posted by Matt Cramer View Post
Often the best way to go from F to C is load the MSQ file, disconnect, change MegaTune over to C, then download it from the ECU.
Do I only change #set CELSIUS in mtCfg/settings.ini or anything else?

Quote:
If that's a Rev C (check the label underneath) it will already have the cap mod. The cap isn't just for hi res code.
Ok, so in that case there is no reason to not run HiRes?
Laur3ns is offline   Reply With Quote
Old 09-19-2008, 11:21 AM   #4
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,266
Total Cats: 51
Default

That's the only change needed. You can run HiRes on it if you like, the hardware's ready for it.
Matt Cramer is offline   Reply With Quote
Old 09-19-2008, 07:05 PM   #5
Elite AbsurdFlow Member
Thread Starter
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Question Input on base MSQ wanted!

Thank for the input. I've tried to establish a base map to work with when we get the car started. What I've done is this:
  1. Change to Celsius
  2. Recalculate MSPNP9495 MSQ from F to C
  3. Place HiRes code in project folder
  4. Recalc REQ_FUEL based on 1862cc (83.5mm bore), 550cc, 13.1AFR
  5. Recalc Cranking PW using Excel
  6. Change LAMBDA_SENSOR in MegaTune Configurator
  7. Change EGO settings in MSQ to Wideband
  8. Re-enter AFR targer table1 because of Volts to AFR change by hand
  9. Set lower rev limit (6600 soft, 6800 hard)
  10. Configure boost control basics
  11. Set overboost protection to 230kPa
  12. Configure Knock Sensor settings

Would like to hear your comments on this map.
Attached Files
File Type: msq megasquirt200809192358.msq (35.2 KB, 112 views)
Laur3ns is offline   Reply With Quote
Old 09-21-2008, 10:45 AM   #6
Elite AbsurdFlow Member
Thread Starter
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Default

Ok, no comments so far. Other way around: who with 550s on an 1.8 (94-95) will share its msq? Please specify your turbo setup.
Laur3ns is offline   Reply With Quote
Old 09-21-2008, 11:41 AM   #7
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

"paul" on the forum (that's his username, search it) has a 94 with a 2560R and 550's. You need his maps. He's posted his timing maps for sure as I've seen them. I think he's posted his fuel ones too. Maybe he will chime in. FWIW, his timing maps are in a thread called "take a look FM, we need your timingz" or something like that.
patsmx5 is offline   Reply With Quote
Old 09-21-2008, 05:09 PM   #8
Elite AbsurdFlow Member
Thread Starter
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Default

Thanks, found that and will have that handy.

Couple of questions before we head off:
1. Best configure WBO2 to INNOVATE_0_5_LINEAR and configure its output as such?
2. The MSPNP9495 base map has const baro correction enabled. Is that correct?
3. My injector PW is still 1.2ms. Is that right for RC 550's High Imp?
4. I need a baseline for my accel enrich. How do I scale them?

Thanks!

Last edited by Laur3ns; 09-21-2008 at 05:30 PM.
Laur3ns is offline   Reply With Quote
Old 09-21-2008, 05:29 PM   #9
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

I run:

PWM time threshold: 1.0ms
PWM current limit: 30%
Injector Pulsewidth Period: 66 us (micro seconds, not milli seconds)

But I'm MS2. I though you can't run low ohm injectors with MS1?
patsmx5 is offline   Reply With Quote
Old 09-21-2008, 05:30 PM   #10
Elite AbsurdFlow Member
Thread Starter
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Default

Sorry I got High Ohm...
Laur3ns is offline   Reply With Quote
Old 09-21-2008, 05:39 PM   #11
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

explain what you mean by 4) Do you need someones acceleration enrichment numbers? i got mine for 550's that would work for you, but they aren't perfect. I just made them yesterday. Like it or not here they are.

Name:  accelerationsettings.jpg
Views: 4
Size:  101.1 KB

And here's my timing map, but use it with extreme caution. It's not perfect.

Name:  mytimingtableV2.jpg
Views: 4
Size:  149.0 KB
patsmx5 is offline   Reply With Quote
Old 09-21-2008, 05:42 PM   #12
Elite AbsurdFlow Member
Thread Starter
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Default

Thanks, but since I have MS1 (MSPNP9495) Ill have to do TPS or MAP based accel enrich. Not sure which is better. I read TPS gives faster throttle response, but Savvington is having lean tip in at higher RPM?

I will probably just recalc the accel enrich PW just like I recalculcated the cranking PW for the 550's and have the dyno guys figure it out from there.
Laur3ns is offline   Reply With Quote
Old 09-21-2008, 05:45 PM   #13
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Well I'm actually running different values then what I just posted. The map ones work good. IE, if I set it to map only, the car runs ok. the TPS based ones suck. I have now increased those values. So if anything do map based with my values, or TPS based with someone elses. MS2 FTW.
patsmx5 is offline   Reply With Quote
Old 09-21-2008, 06:06 PM   #14
Elite AbsurdFlow Member
Thread Starter
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Default

Quote:
Originally Posted by Spookyfish View Post
2. The MSPNP9495 base map has const baro correction enabled. Is that correct?
This is actually mentioned in the feature list, so I fail and it is correctly enabled.
Laur3ns is offline   Reply With Quote
Old 09-25-2008, 09:21 AM   #15
Elite AbsurdFlow Member
Thread Starter
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Default

Reporting back: base MSQ was excellent. Car started right up on the 550's.
I changed:
- Injector opening time to 1.0ms
- We had to bring down PWM Idle control minimum and closed values to 0 and 5 DC or it would stick at 9% and the car would idle too high. Any comments on this?

Laur3ns is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Oregon New Guy Wino Meet and Greet 7 08-29-2015 03:26 PM
First MS maps kotomile MEGAsquirt 12 04-09-2008 07:28 PM
please look at my .msq and tell me what's wrong with cold start hustler MEGAsquirt 5 12-30-2007 10:28 PM
1.6 w. DIYAutotune MS1 extra start issues Hakan MEGAsquirt 14 09-15-2007 12:57 PM
1.6 stock injectors .msq adbradley MEGAsquirt 1 03-05-2007 09:36 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:17 AM.