greddy hits the boost only at 5k rpm - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 08-19-2010, 04:50 AM   #1
Newb
Thread Starter
 
Join Date: Aug 2008
Posts: 12
Total Cats: 0
Default greddy hits the boost only at 5k rpm

hello,

I'v installed greddy kit with FMIC and 2,5" exhaust in my 92 mx-5.
but I'm having problem, miata hits full boost only from 5K rpm.

can it be wrong timing?
can it be coused by abit lose wastegate plate?

few pics of my shitty built:




Last edited by baronas_Lithuania; 08-19-2010 at 08:43 AM. Reason: one more pic
baronas_Lithuania is offline   Reply With Quote
Old 08-19-2010, 04:55 AM   #2
Elite Member
iTrader: (24)
 
Join Date: Jun 2007
Location: Sherman Oaks, CA
Posts: 4,481
Total Cats: 3
Default

Check your wastegate. Make sure it's not stuck open.
UrbanSoot is offline   Reply With Quote
Old 08-19-2010, 05:01 AM   #3
Newb
Thread Starter
 
Join Date: Aug 2008
Posts: 12
Total Cats: 0
Default

i have checked that... every thing ok...
baronas_Lithuania is offline   Reply With Quote
Old 08-19-2010, 05:35 AM   #4
Junior Member
iTrader: (5)
 
Join Date: Jan 2009
Location: frederick MD
Posts: 348
Total Cats: -6
Default

i would say something with the waste gate or a boost leak in the intake track somewhere
nice drawing!!! hahaha
nickblackbelt is offline   Reply With Quote
Old 08-19-2010, 07:13 AM   #5
Junior Member
iTrader: (2)
 
Join Date: Sep 2009
Location: Chicago, IL
Posts: 250
Total Cats: 0
Default

Leak between exhaust mani and head? Leak between exhaust mani and turbo?
saedrin is offline   Reply With Quote
Old 08-19-2010, 07:50 AM   #6
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,107
Total Cats: 518
Default

The turbo will only spool with proper fuel, if you're not tuning with a wideband, you don't know if your fuel system is working properly. Also, do you even have a boost gauge? That green piece of vacuum line is where one is usually connected.
curly is offline   Reply With Quote
Old 08-19-2010, 08:38 AM   #7
Newb
Thread Starter
 
Join Date: Aug 2008
Posts: 12
Total Cats: 0
Default

I have boost gauge. it connected tu intake manifold closer tu firewall. it is working fine. it shows after 5k rpm - 0,36bar
baronas_Lithuania is offline   Reply With Quote
Old 09-28-2010, 04:42 AM   #8
Newb
Thread Starter
 
Join Date: Aug 2008
Posts: 12
Total Cats: 0
Default

problem solved.

wastegate was allways opened becouse of dented "leg".

now i can hear surge even at 3k rpm now my miata comes out of vacuum at 2,4k rpm
baronas_Lithuania is offline   Reply With Quote
Old 10-07-2010, 09:27 PM   #9
Elite Member
iTrader: (7)
 
Join Date: Jan 2007
Location: Renton Washington
Posts: 1,742
Total Cats: 3
Default

I liked the Greddy turbo. Insta-spool with 3" exhaust.
SKMetalworks is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
The "other" spool question stefanst DIY Turbo Discussion 44 09-28-2015 08:16 PM
ME221 Now has Autotune and Long Term Fuel Trim Tables Motorsport-Electronics ECUs and Tuning 0 09-05-2015 09:02 AM
It runs! But not well.. Input appreciated. viriiguy MEGAsquirt 10 09-04-2015 07:28 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:25 AM.