O2 Clamp Installation? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 03-26-2007, 12:14 PM   #1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Jul 2006
Location: Birmingham, Alabama
Posts: 209
Total Cats: 0
Default O2 Clamp Installation?

Even though I have installed a pretty nice low budget Greddy turbo set-up with an RX-7 intercooler and successfully installed my Bipes unit, I am not the most capable person when it comes to wiring electronic stuff. I just got the "olderguy's" O2 Clamp, and while he has included instructions, they are not as idiot proof as the Bipes was, and I need idiot proof.

Does anyone have any nice pictures, or links, or actual numbers for the wires coming out of the ecu that I am supposed to wire to. Sorry for the stupid question, but I like to have as much relevant input as possible before I install something. I did a search here and on miata.net, but found no conclusive results. Thanks for any help.
92Black&Tan is offline   Reply With Quote
Old 03-26-2007, 12:22 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

If i can do it you can. There is only three wires that go into the ecu, ground, power, and o2. (2) of which you have already tapped into with the Bipes.

the other goes to the pressure switch, that's easy.

the pressure switch is then routed into the vacuum line for your boost gauge, again, easy.

I trust you can do it.

Here is my pressure switch ready to get plumbed into the vacuum line. The wires are just routed behind the center console into the ecu area where the clamp resides.



here is where the clamp resides:

Braineack is offline   Reply With Quote
Old 03-26-2007, 12:39 PM   #3
FHS
Senior Member
iTrader: (2)
 
Join Date: Oct 2004
Location: Los Angeles, Ca.
Posts: 502
Total Cats: 0
Default

Hey '92,

I just finished the installation yesterday but I don't have a digital cam. Here's the wiring schematic for your ECU if you haven't seen it.

http://www.madracki.com/miata/images/wiring/92diag.pdf

The red wire from your clamp splices into the ECU +12 power supply. That's the wt/red 1B wire.

The black wire splices into a ground. I spliced into blk 2A, but you can splice into blk 2B, blk/lt grn 2C, or blk/lt grn 2D.

There are three terminals on the pressure switch. The white wire from the clamp goes to the pressure switch as per Bruce's instructions (NO terminal).

You have to cut the NB O2 signal to the ECU. That's red/blu 2N (pita for me to find because I had already cut it for EMB installation).

The wire coming from the ECU goes to the pressure switch as per instructions (C terminal), and the other end coming from the O2 sensor goes to the final prong (NC terminal). If you are feeding a simulated NB signal from a WBO2 controller, attach that wire to the NC terminal instead of the signal from the stock NB O2 sensor.

Hope this helps.
FHS is offline   Reply With Quote
Old 03-26-2007, 01:38 PM   #4
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Jul 2006
Location: Birmingham, Alabama
Posts: 209
Total Cats: 0
Default Thanks, and a follow up question...

Thanks dudes... For some reason, I can't see any of your pictures here at work, but I will take a look at them when I get home and if I have more questions I will post again.

Follow-up question:

Right now my car is running 6psi and I am putting down 146rwhp & 146rwtq. I have a custom/J**b RX-7 intercooler set-up and a Bipes set on the most agressive settings. When I got those numbers on the dyno I did not have the bipes installed, I was running 14 deg base timing, we got no ping, the car runs fantastic... and we dynoed in August on a very hot day. We tried to bump up the boost to about 10, but got some slight pinging at about 3k to 4k and a slightly lean condition right at that spot also.

Since then I have installed the Bipes, and a new fuel filter [Just to make sure, because I have no idea when the old one was last changed.] Last night I installed a VooDoo manual boost control set on the safest setting and I am now going to install the O2 clamp/signal modifier. I plan on going back to the dyno in a few days with the Bipes, O2 clamp, new fuel filter, and a slightly larger [It has larger inlet and outlets] RX-7 intercooler that I have sitting on the shelf.

My question is this:

Do you think I will be able to turn up the boost to about 8psi with the new additions? We will be monitoring the boost level and the fuel and listening for any hint of ping. I am trying for about 170rwhp with the minimum amount of bandaids, just sort of experimenting at this point. I also have a Walbro 190hp and some 1.8 injectors sitting on the shelf if I want to use them, but I am trying to keep the set-up simple and cheap just to see what you can squeeze out of one of these systems for the least amount of money, while maintaining good driveability and fuel mileage.
92Black&Tan is offline   Reply With Quote
Old 03-26-2007, 01:50 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

gotta be logged in to see them, i dunno why but they went to red x's to me, logged out and logged back in and there they were.
Braineack is offline   Reply With Quote
Old 03-26-2007, 02:30 PM   #6
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Jul 2006
Location: Birmingham, Alabama
Posts: 209
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
gotta be logged in to see them, i dunno why but they went to red x's to me, logged out and logged back in and there they were.
Did that and they're still red "X's"
92Black&Tan is offline   Reply With Quote
Old 03-26-2007, 02:32 PM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

this work?

Last edited by Braineack; 10-02-2007 at 04:01 PM.
Braineack is offline   Reply With Quote
Old 03-26-2007, 02:36 PM   #8
Junior Member
 
Join Date: May 2006
Location: Houston Area-Baytown, TX
Posts: 118
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
gotta be logged in to see them, i dunno why but they went to red x's to me, logged out and logged back in and there they were.
Did that and they're still red "X's" Even disable Norton.
1991BRG is offline   Reply With Quote
Old 03-26-2007, 02:37 PM   #9
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Jul 2006
Location: Birmingham, Alabama
Posts: 209
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
this work?
Yeah... that works.
92Black&Tan is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 18 11-22-2016 10:01 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:58 PM.