Go Back  Miata Turbo Forum - Boost cars, acquire cats. > Performance & Tuning > Prefabbed Turbo Kits
Reload this Page >

ok need help i usually post at mazda-speed so i'm not a newbie

Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

ok need help i usually post at mazda-speed so i'm not a newbie

 
Old 11-14-2007, 04:43 PM
  #1  
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2007
Location: Cincinnati Ohio
Posts: 147
Total Cats: 0
Default ok need help i usually post at mazda-speed so i'm not a newbie

exact post from mazda-speed.com
help me please

ok this only happens randomly and has no pattern. sometimes after, during or when i first start my car, my RPMs will kind of "wiggle" down below normal and acts like it wants to stall. problem one. next problem which prolly has to do with this, it does that **** sometimes when i start it up then i will rev it and its fine then when i try to drive away from my house it bogs i guess like i can be in frist gear and it will just act like it wants to stall i can floor it and it just stays at the 2000 or so rpms and acts like it wants to stall. so i rev it up and take off. idk what the problem is but if you could help that would be awesome. if u don't know my car 93 miata greddy turbo, bov, bipes acu, and manual boost controller thanks bye
miata-turbo08 is offline  
Old 11-14-2007, 05:30 PM
  #2  
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,605
Total Cats: 135
Default

Switch out your AFM with a known good one.
olderguy is offline  
Old 11-14-2007, 06:02 PM
  #3  
Boost Czar
iTrader: (62)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 76,399
Total Cats: 2,296
Default

that or a vacuum leak.
Braineack is offline  
Old 11-14-2007, 10:15 PM
  #4  
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,494
Total Cats: 0
Default

have you switched to larger injectors?
Mach929 is offline  
Old 11-15-2007, 05:21 AM
  #5  
Junior Member
 
Join Date: Jan 2007
Location: oakland
Posts: 52
Total Cats: 0
Default

are you running a cat? i had that same problem and it turns out my cat was dead and clogged with sumthin. but like olderguy said i would switch the afm with a friend and see if that works.
roadstereunos28 is offline  
Old 11-15-2007, 08:43 AM
  #6  
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Nov 2007
Location: Cincinnati Ohio
Posts: 147
Total Cats: 0
Default

mmk the bipes acu is very well known at mazda-speed.com 9 out of 10 people recomended it. its the best buy for the $250 that it is it retards up to 16 degrees and increases air flow retards by air temp. and different rpm maps so its a very nice unit.. but i have cheacked for vacum leaks there are none.. my CAT is about two monthes old so i'm not sure it was a universal one so that could be the prob.. i'm thinking the next thing i'm doing is a nice exhaust would u guys agree. then get an intercooler..
miata-turbo08 is offline  
Old 11-15-2007, 08:51 AM
  #7  
Boost Czar
iTrader: (62)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 76,399
Total Cats: 2,296
Default

we are very well versed in the bipes thank you.

how is your BOV routed?
Braineack is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
StratoBlue1109
Miata parts for sale/trade
21
09-30-2018 01:09 PM
Joe Perez
Current Events, News, Politics
8
09-30-2015 04:41 PM


Thread Tools
Search this Thread
Quick Reply: ok need help i usually post at mazda-speed so i'm not a newbie


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.