went for virgin ride... SUCCESS! - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools
Old 10-15-2006, 07:18 PM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2006
Posts: 124
Total Cats: 0
Default went for virgin ride... SUCCESS!

Just went for the virgin ride with the kit! awesome! im using phillips 8psi map on the emanage, but i left the mbc cranked all the way down because i havent recieved the boost guage i ordered like 2 weeks ago. but anyway, it was awesome, no pinging or anything... only thing i noticed was the revs were a little reluctant to come down below 1700rpm for a second when i let off the throttle, im guessing this might be because im running stock psi on the 8psi map tho. thanks for all your help guys, couldnt have gotten thru the tuning process without you!!!!!!!!!
penpen989 is offline   Reply With Quote
Old 10-15-2006, 07:40 PM   #2
Junior Member
 
Join Date: Nov 2005
Location: PA/DC
Posts: 468
Total Cats: 0
Default

Good deal! Just one thing? Wouldent cranking down your MBC increase boost? Anyways, thats how mine works because if you tighten it, it actually compresses the spring and increases boost. Please feel free to shoot me down if I'm wrong?
Snowsurfer03 is offline   Reply With Quote
Old 10-15-2006, 07:42 PM   #3
Elite Member
iTrader: (12)
 
Join Date: Aug 2006
Location: Central-ish VA
Posts: 4,449
Total Cats: 16
Default

i think by turning down he meant loosening.
neogenesis2004 is offline   Reply With Quote
Old 10-15-2006, 08:17 PM   #4
Junior Member
Thread Starter
 
Join Date: Jul 2006
Posts: 124
Total Cats: 0
Default

yea, it says turn to the left to decrease boost, i turned it all the way to the left
penpen989 is offline   Reply With Quote
Old 10-15-2006, 08:21 PM   #5
Elite Member
iTrader: (14)
 
Join Date: Mar 2006
Location: Edmonton, AB
Posts: 4,921
Total Cats: 0
Default

Was it a problem with TPS?
jayc72 is offline   Reply With Quote
Old 10-15-2006, 09:49 PM   #6
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

wtf tps
magnamx-5 is offline   Reply With Quote
Old 10-15-2006, 11:59 PM   #7
Elite Member
iTrader: (14)
 
Join Date: Mar 2006
Location: Edmonton, AB
Posts: 4,921
Total Cats: 0
Default

Throttle Position Sensor.
jayc72 is offline   Reply With Quote
Old 10-16-2006, 01:08 AM   #8
Senior Member
iTrader: (1)
 
Join Date: Mar 2006
Location: Tucson "it's 110" Arizona
Posts: 1,017
Total Cats: 0
Default

title..


thats sweet though
UofACATS is offline   Reply With Quote
Old 10-16-2006, 10:12 AM   #9
Junior Member
 
Join Date: Nov 2005
Location: PA/DC
Posts: 468
Total Cats: 0
Default

i love the virgin ride!
Snowsurfer03 is offline   Reply With Quote
Old 10-16-2006, 10:14 AM   #10
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,847
Total Cats: 1,788
Default

Quote:
Originally Posted by penpen989 View Post
Just went for the virgin ride with the kit! awesome! im using phillips 8psi map on the emanage, but i left the mbc cranked all the way down because i havent recieved the boost guage i ordered like 2 weeks ago. but anyway, it was awesome, no pinging or anything... only thing i noticed was the revs were a little reluctant to come down below 1700rpm for a second when i let off the throttle, im guessing this might be because im running stock psi on the 8psi map tho. thanks for all your help guys, couldnt have gotten thru the tuning process without you!!!!!!!!!

So what was the problem before? something with your EMB? Had to cut that one wire?

And make sure your cranked the MBC all the way "up" not down.
Braineack is offline   Reply With Quote
Old 10-17-2006, 01:50 AM   #11
Junior Member
Thread Starter
 
Join Date: Jul 2006
Posts: 124
Total Cats: 0
Default

yea its cranked "up", and yea the problem was i didnt cut the grey wire! even in this semi untuned state the car is really quick. i think my favorite thing is how it pulls me up hills without using like 60% throttle haha.
penpen989 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Fab9Tuning's NC MX-5 Turbo Kit Discussion- EFR/Garrett V-Band FAB Prefabbed Turbo Kits 216 03-22-2017 05:00 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
mslabs MS2 - Idle control issue ndragun MEGAsquirt 0 09-20-2015 11:28 PM
Track Video & Bluetooth MS3 Questions ofspunk7 General Miata Chat 3 08-31-2015 03:14 PM
Virgin MS forum? Jefe Front Desk 3 03-10-2008 01:59 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:33 AM.