Go Back  Miata Turbo Forum - Boost cars, acquire cats. > Performance & Tuning > Prefabbed Turbo Kits
Reload this Page >

wiring issues..burnt some stuff up. need guidance

Prefabbed Turbo Kits A place to discuss prefabricated turbo kits on the market
Sponsored by:
Sponsored by:

wiring issues..burnt some stuff up. need guidance

 
Old 03-08-2007, 12:10 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Oct 2006
Posts: 257
Total Cats: 0
Default wiring issues..burnt some stuff up. need guidance

ok so.. i had a apex tach installed in my car. i wired it all up behind the cluster. then i installed a apex boost gauge /w the wiring tieing into the same wires behind the cluster.

i tried to install my turboxs boost controller thing to the same lines...i heard a small sizzle sound and smelt burning electronis or something...

i pulled the cluster and stuff and one of the little copper deals on the back was burnt and the cluster doesn't work at all anymore.. i think i just need to solder the connections back together.

ok my real question for you guys is WHERE should i wire for power for my gauges and the turboxs boost controller. i also have a question about the lighting/illumination... when i was tapped into the cluster i just had constant power for the illumination of my gauges...even during the day.

any diagrams are a plus

thanks in advance....
shinobix is offline  
Old 03-08-2007, 12:34 AM
  #2  
Senior Member
 
Join Date: Apr 2005
Location: NAS Oceana/VA
Posts: 759
Total Cats: 0
Default

Did you say wiring diagrams? Have fun! Oh, and this is for a 1.6.

http://www.madracki.com/miata/images/wiring/90diag.pdf
getsidewaysd1 is offline  
Old 03-08-2007, 12:42 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Oct 2006
Posts: 257
Total Cats: 0
Default

oh god. shoot me now. where did you tap into for your gauges ? and illumination ?
shinobix is offline  
Old 03-08-2007, 04:40 AM
  #4  
I'm Miserable!
iTrader: (5)
 
Join Date: Sep 2005
Location: SLC, Utah
Posts: 1,589
Total Cats: 0
Default

my boost guage is wired so that it dims with the factory dimming switch.
zoom2zoom is offline  
Old 03-08-2007, 07:16 AM
  #5  
Newb
 
Join Date: Mar 2007
Posts: 25
Total Cats: 0
Default

ouch....looks like you tried to get more power than it could handle in the circuit....hope it turns out to be easily fixed.....
Sharky is offline  
Old 03-10-2007, 02:10 AM
  #6  
Elite Member
iTrader: (1)
 
Join Date: Jun 2005
Location: Charleston, SC
Posts: 2,978
Total Cats: 14
Default

The blue connector (30 amp heater fan wire) is a good place to wire stuff.
rmcelwee is offline  
Old 03-10-2007, 09:55 AM
  #7  
Newb
 
Join Date: Jan 2007
Posts: 14
Total Cats: 0
Default

Originally Posted by zoom2zoom View Post
my boost guage is wired so that it dims with the factory dimming switch.
How did you do that? I assume you tapped into the line after the dimmer and that's about it?
miatanewb is offline  
Old 03-11-2007, 12:08 AM
  #8  
Senior Member
 
Join Date: Apr 2005
Location: NAS Oceana/VA
Posts: 759
Total Cats: 0
Default

I also wired it so that it dims with the factory dimming switch. Its been a while since I have done it, but if I'm not mistaken, you can tap into the stero wiring harness. Its the orange wire that says ilumination on it.
getsidewaysd1 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
russian
Miata parts for sale/trade
6
10-08-2015 03:01 PM
JxPhan
Meet and Greet
3
10-02-2015 02:17 AM
viriiguy
General Miata Chat
5
09-28-2015 07:39 PM
btabor
ECUs and Tuning
10
09-28-2015 05:33 PM


Thread Tools
Search this Thread
Quick Reply: wiring issues..burnt some stuff up. need guidance


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.