fu**ed up transmission - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Suspension, Brakes, Drivetrain discuss the wondrous effects of boost and your miata...

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 07-13-2010, 08:11 PM   #1
N3v
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Nashville/Knoxville, TN
Posts: 318
Total Cats: 1
Default fu**ed up transmission

I need to elaborate on my setup:
diff/axles/driveshaft = 1997 miata
tailshaft/gearbox = 1999 miata
bellhousing/clutch fork/thrust bearing/slave cylinder= 1991 rx7
engine = 1991 rx7

My problem is that the car appears in neutral but the engine turns with the driveline. I could row through the gears on the trans when it was on the floor, but after i bolted it to the motor, i couldn't. I figured it was because of the tight clutch. now it's in the car, driveshaft on, clutch is plumbed, and it still does it.

The shifter feels like it's in neutral. it goes left and right and will spring back to the center. if i jerk it around a little or rock the car back and forth, i can get it into each gear (some are easier than others) some feel like they are all the way in gears, some feel like I can only get it halfway. This makes no difference on the locked up driveline.

I took off the reverse switch and rooted around with a screwdriver to see if maybe it was stuck in reverse, but i didn't get anywhere. I wasn't totally sure what I was looking for anyway.

please help

Last edited by levnubhin; 07-16-2010 at 05:00 PM.
N3v is offline   Reply With Quote
Old 07-13-2010, 08:54 PM   #2
Senior Member
iTrader: (14)
 
Join Date: Aug 2008
Location: Tinley Park, IL
Posts: 1,488
Total Cats: 0
Default

Quote:
Originally Posted by N3v View Post
I took off the reverse switch and rooted around with a screwdriver to see if maybe it was stuck in reverse, but i didn't get anywhere. I wasn't totally sure what I was looking for anyway.
There is a small notch in the shift rod that should be centered in the switch mounting hole when it's in neutral. Sometimes when assembling the tailshaft housing, the rod coming from the shifter could get bumped and the pawl on the end that meshes with the clevises on the throwout rods for the clutch hubs become misaligned.

What may have happened is the 5th,reverse rod may have been partially engaged in a gear and the pawl cannot get into the clevis, it hits the tips of the clevis instead. What your doing is trying to knock it out of gear so the pawl can find the center of the clevis again.

You want to probe the hole and see if you can feel where the notch is in relationship to the hole. If it's off center, you want to try to pry it over with a small screwdriver and try to get it back in the center of the hole. You may have to have someone move the shifter around to relieve pressure on the components to achieve this.
lordrigamus is offline   Reply With Quote
Old 07-13-2010, 09:08 PM   #3
N3v
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Nashville/Knoxville, TN
Posts: 318
Total Cats: 1
Default

just went and screwed with it while i was waiting for a response.

this has to be 100% correct because it won't go into any gear except fifth, and it doesn't feel like an engagement, it feels like it's in no-man's land.

I'll try this and report back. thanks so much!
N3v is offline   Reply With Quote
Old 07-16-2010, 04:45 PM   #4
N3v
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Nashville/Knoxville, TN
Posts: 318
Total Cats: 1
Default

okay I've been outside messing with it, no luck. The whole driveline is in the car, so I can't see the switch itself, but I could feel it with a tool, and it feels like the reverse switch dimple is centered.

the reverse switch is the one closest to the gearbox on a 99 transmission right? just confuses me cause the reverse and neutral switch are both on the drivers' side.

I think it has something to do with the input shaft because even while clutched in the whole driveline is locked up.

I know the transmission should have no effect on the engine with the clutch pressed in, which is why I think I'm just gonna try starting it on jackstands and letting the rear wheels spin, and trying to clutch in and wriggle around the shifter at that point, once everything gets some oil kicked onto it, it might kick out of this dumb lockup.

If that goes bad I have a spare transmission. we'll see.
N3v is offline   Reply With Quote
Old 07-16-2010, 05:01 PM   #5
Elite Member
iTrader: (30)
 
Join Date: Aug 2007
Location: Va Beach
Posts: 7,282
Total Cats: 0
Default

No swearing in thread titles please.
__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
levnubhin is offline   Reply With Quote
Old 07-17-2010, 12:10 PM   #6
Elite Member
iTrader: (18)
 
Join Date: Dec 2007
Location: oahu
Posts: 1,720
Total Cats: 2
Default

On my 5 speed I can't see the switch but can unscrew/unbolt it and get a stubby flat tip in. It's all done by feel :( I had this happen to me 3.
astroboy is offline   Reply With Quote
Old 07-17-2010, 03:38 PM   #7
!!! NOT CONFIRMED !!!
 
Join Date: Feb 2009
Posts: 53
Total Cats: 0
Default

Quote:
Originally Posted by N3v View Post
I took off the reverse switch and rooted around with a screwdriver to see if maybe it was stuck in reverse, but i didn't get anywhere. I wasn't totally sure what I was looking for anyway.
please help
I was thinking the same thing...
http://www.youtube.com/watch?v=cdgzilEXQL8

video that shows you exactly what to look for. I know that its a miata tanny in the video, and you have a rx7. I hope this helps.
WESamiss is offline   Reply With Quote
Old 07-20-2010, 03:04 PM   #8
N3v
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Nashville/Knoxville, TN
Posts: 318
Total Cats: 1
Default

ok guys, update. I just went to pull my transmission off because I tried all this and it didn't work.

I got the transmission about an inch and a half off of the motor and i can twist it around but i'm having trouble getting it off myself. i'm gonna have to wait until a friend can help. but now with the trans separated a little, i can row through the gears just fine.

I screwed up my input shaft didnt i?
N3v is offline   Reply With Quote
Old 07-20-2010, 04:53 PM   #9
N3v
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Nashville/Knoxville, TN
Posts: 318
Total Cats: 1
Default

update 2:
got trans all the way off. not fun in a motor swapped car without pulling the engine. had to drop the subframe a couple inches.

The input shaft is fine, the clutch is fine and the pilot bearing is fine. So i put the driveshaft in with the trans on the ground and tried to turn the input shaft by hand. i turned it about 300 degrees and then it got hard and the driveshaft wanted to turn over. after the driveshaft flopped over one time, i did this over and over, and eventually it stopped binding at one point. now it turns freely and driveshaft doesn't move. weird fluke?

Edit: further tested it by putting the trans in fourth, driveshaft turns perfectly 1:1, then reverse, driveshaft moves more slowly in the opposite way. trans appears to be functioning perfectly. definitely binding at first though. i dunno. i'm so confused.

Last edited by N3v; 07-20-2010 at 05:18 PM.
N3v is offline   Reply With Quote
Old 07-21-2010, 06:47 PM   #10
N3v
Junior Member
Thread Starter
 
Join Date: May 2008
Location: Nashville/Knoxville, TN
Posts: 318
Total Cats: 1
Default

final fix:

the input shaft that I cut for the build was still too long, and pressing the input shaft into the transmission, causing binding in the geartrain.
N3v is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
Transmission Heat Shield Thread patsmx5 General Miata Chat 46 06-06-2016 11:27 AM
WTB Bellhousing Bolts patsmx5 WTB 1 10-01-2015 10:43 AM
Auto Engine into Manual Car Wino General Miata Chat 0 09-23-2015 09:35 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:03 PM.