EMS4 Wiring 1990 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 08-17-2014, 07:09 PM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2011
Posts: 97
Total Cats: 0
Default EMS4 Wiring 1990

I am putting a 2000 motor into a 1990 using Trackspeed Engineering's patch harness. I think I am down to 4 final wiring/hookup issues (sure there will be more once I get to startup and final tuning).

IAC- can I just swap the 2000 pigtail in? Also, not sure if the pins should be wired identical as 1990 is?

VICS- should I use a GPIO to connect this in and what needs to be done on the map to utilize the sensor

Coolant temp sensor- Not sure how to wire in

Alternator- Do I have to program ECU to handle the alternator, or should I use a NA alternator.

Any advice form those in the know would be very appreciated
gthill13 is offline   Reply With Quote
Old 08-17-2014, 09:12 PM   #2
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,370
Total Cats: 1,332
Default

IAC - swap the pigtail, no polarity

VICS - Use a GPIO, #3/4 is open if you don't have A/C and #7 is open if you aren't using EBC.

CLT - use the '90 sensor and pigtail

Alternator - use a 94-97 alternator

I'm just an email away...
Savington is offline   Reply With Quote
Old 08-17-2014, 09:50 PM   #3
Senior Member
iTrader: (1)
 
Join Date: Apr 2011
Location: Columbia, SC
Posts: 1,342
Total Cats: 78
Default

Frank's board would also work if you already have an NB alternator and wish to go that route. Works great in my '00. Shipped from Belgium FYI.

https://www.miataturbo.net/megasquir...d-75133/page4/
Schuyler is offline   Reply With Quote
Old 08-17-2014, 11:13 PM   #4
Junior Member
Thread Starter
 
Join Date: Oct 2011
Posts: 97
Total Cats: 0
Default

Quote:
Originally Posted by Savington View Post
IAC - swap the pigtail, no polarity

VICS - Use a GPIO, #3/4 is open if you don't have A/C and #7 is open if you aren't using EBC.

CLT - use the '90 sensor and pigtail

Alternator - use a 94-97 alternator

I'm just an email away...
Thank you!
gthill13 is offline   Reply With Quote
Old 08-18-2014, 09:50 AM   #5
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: NH
Posts: 9,093
Total Cats: 90
Default

Just pay attention when using 3 or 4. For some weird reason on the basemap I got from TSE one of them was also set to be a shift light or some bullshit like that and in the infinite wisdom of the AEM programmers that setting is hidden as **** and will make the GPIO its assigned to unusable for anything else without letting you know its unusable in the normal GPIO setup window.
Leafy is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 06:33 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:08 AM.