99 Sport eBay turbo build - Page 4 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 02-08-2016, 08:37 PM   #61
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 34,453
Total Cats: 2,271
Default

99 does have both crank and cam
18psi is offline   Reply With Quote
Old 02-19-2016, 04:49 PM   #62
Junior Member
Thread Starter
 
Join Date: Mar 2014
Location: Jacksonville, FL
Posts: 321
Total Cats: 19
Default

ok, so i got the MS2E yesterday, and CAR NO START. lol

Here is what i did:

Removed stock ecu
Plugged in MS2E
removed and unplugged front o2 sensor and replaced it with Innovate wideband
un pluged MAF
ran vacum line from TB front to MS2
connected wideband serial to ms2 serial plug for digital wideband input (per instructions).
calibrated TPS per instructions in Tuner Studio.

go to start car and it just cranks, no start.

I do hear the fuel pump prime once ignition is on.

what did i do wrong? map is base map from Rev, so it should just fire up.

do i still need the stock front o2 and maf plugged in? i thought i dont need those once i go MS2 ?
borka is offline   Reply With Quote
Old 02-19-2016, 04:51 PM   #63
Elite Member
iTrader: (1)
 
Join Date: Jun 2014
Location: Austin, TX
Posts: 2,696
Total Cats: 240
Default

Check the timing?
Girz0r is online now   Reply With Quote
Old 02-19-2016, 04:53 PM   #64
Junior Member
Thread Starter
 
Join Date: Mar 2014
Location: Jacksonville, FL
Posts: 321
Total Cats: 19
Default

Quote:
Originally Posted by Girz0r View Post
Check the timing?
I have a timing gun, but how can i check timing if car no start?

This was going to be the next step in the instructions, to set the timing, but i need the engine running for that.
borka is offline   Reply With Quote
Old 02-19-2016, 04:56 PM   #65
Sadfab Union President
iTrader: (3)
 
Join Date: May 2014
Location: Kansas
Posts: 2,690
Total Cats: 114
Default

Add to reqfuel till it cranks. Base maps are just that, base configuration settings for inputs and outputs.

You still need to tune fuel.
deezums is offline   Reply With Quote
Old 02-19-2016, 05:13 PM   #66
Elite Member
iTrader: (1)
 
Join Date: Jun 2014
Location: Austin, TX
Posts: 2,696
Total Cats: 240
Default

Quote:
Originally Posted by borka View Post
I have a timing gun, but how can i check timing if car no start?

This was going to be the next step in the instructions, to set the timing, but i need the engine running for that.
You get a buddy to start the crank and use the gun attached to cyl1 ign wire to check, it'll still read if you have spark.

I think it should be 10? Going off of poor memory and guess.
Girz0r is online now   Reply With Quote
Old 02-19-2016, 06:28 PM   #67
Junior Member
Thread Starter
 
Join Date: Mar 2014
Location: Jacksonville, FL
Posts: 321
Total Cats: 19
Default

ok. rev replied to my pm. immobilizer was left on. switched off and car fired up.

will be setting timing now.
borka is offline   Reply With Quote
Old 02-21-2016, 02:54 PM   #68
Junior Member
Thread Starter
 
Join Date: Mar 2014
Location: Jacksonville, FL
Posts: 321
Total Cats: 19
Default

Mounted MS2E under the steering column, what a PITA to mount this box.
I just zipped tied it to other big plugs/wires, sits very secure.




Did the timing, and calibrated TPS.

Enriched the base VE map, as the base map was WAY lean, idle was 20 AFR on base map, so i just added 20 points across the board, which is too rich, but Autotune will bring it back to target.

I got the closed loop idle dialed in pretty well, except AC, it dips way too low, so next i will figure out how to make the rpm go up more when AC is on.

one major problem:

My CEL keeps blinking when i put load on the engine, even at low rpms, and more often in higher revs. this has me worried as i think it detects knock and CEL flashes.
AFR's are rich, 12-13 when under load, so its not knocking due to lean condition

Car is still stock, no turbo, only header and muffler, thats it.

false reading? should i raise the threshold of knock?

here is my timing table, its just Rev's base table:
https://drive.google.com/file/d/0B38...ew?usp=sharing

here is the rough tune from Autotune, its still very rough as i am afraid to do redline runs as CEL keeps flashing like crazy at high rpm's.
https://drive.google.com/file/d/0B38...ew?usp=sharing

Second problem, I cant seem to figure out how to log properly, when i run logging in tuner studio, it does log, but when i open the file in megatune viewer, very few fields are actually being logged, so i cant even run VE Analyzer.
here is the log file that it takes:
https://drive.google.com/file/d/0B38...ew?usp=sharing


Cant wait to tune this properly, so i can start bolting on turbo bits.
Attached Thumbnails
99 Sport eBay turbo build-80-i_kzpdkmv_l_6626f243f1d602f3b2b373e07658177b4ca82315.jpg  

Last edited by borka; 02-22-2016 at 11:29 AM.
borka is offline   Reply With Quote
Old 02-22-2016, 06:00 AM   #69
Autobot Miata
iTrader: (1)
 
Join Date: Dec 2009
Location: Knoxville, TN
Posts: 265
Total Cats: 0
Default

I put my Megasquirt where the factory ECU went. It is a pain to get it in there initially, but it works great.
viriiguy is offline   Reply With Quote
Old 02-22-2016, 11:12 AM   #70
Junior Member
Thread Starter
 
Join Date: Mar 2014
Location: Jacksonville, FL
Posts: 321
Total Cats: 19
Default

Quote:
Originally Posted by viriiguy View Post
I put my Megasquirt where the factory ECU went. It is a pain to get it in there initially, but it works great.
I could not figure out how to mount it there, the ecu box doesnt have a single mounting point, just a smooth box, plus it has big plugs on both sides, front OEM plugs and rear serial and DB big plug. so after breaking my back under there, i said F it and zip tied it under the steering column. I simply put zip ties on the OEM plugs and the serial and DB plugs, and tied them to other big plugs that were near by.

Its very secure, doesnt move around, and i should be able to put the plastic cover under the steering wheel back on, and the ecu will be out of sight.
borka is offline   Reply With Quote
Old 02-27-2016, 10:02 PM   #71
Junior Member
Thread Starter
 
Join Date: Mar 2014
Location: Jacksonville, FL
Posts: 321
Total Cats: 19
Default

more updates.

Emailed Rev my logs and tune, and he suggested that its not actually knocking but its noise being picked up, so to raise threshold of knock. this seems to help.

Install FlowForce EV14 today and, got it idling pretty well, and went for a 30 minute autotune run. car runs pretty good now, a little rich, but more autotune will take care of this.








Ran into a snag, the 5 bolt flange on my little turbo doesn't line up with my downpipe turbo going back to seller and i am ordering a China GT2860

GT25 GT28 T25 T28 GT2860 sr20 CA18DET Turbo turbocharger Water Cooled AR 64 | eBay








Another issue, the inconel studs from FM have a non threaded section in the middle that is too long. do i just use a few washers under the nut? or return them?


Attached Thumbnails
99 Sport eBay turbo build-80-i_jvxngvg_m_592353dfcdf9a4107be19a5394c904ceb07af5b5.jpg   99 Sport eBay turbo build-80-i_3wfrdnk_m_6104121122eb1af7a5007bcaf5ada71b95702560.jpg   99 Sport eBay turbo build-80-i_pc9k7gn_m_043735ac88c64bccd601ff1179aa713784929dbf.jpg   99 Sport eBay turbo build-80-i_frv79wg_m_a6dc61bb2993da0d04223b33a6c47a2da1858f9e.jpg   99 Sport eBay turbo build-80-i_wcnqlmp_l_2de17377461610bfb01f278bbff5d20233d6ce25.jpg  

borka is offline   Reply With Quote
Old 02-27-2016, 10:17 PM   #72
Elite Member
iTrader: (6)
 
Join Date: Feb 2013
Location: Staunton, Va
Posts: 1,976
Total Cats: 145
Default

Double nut them, and drive em in real deep like.
ryansmoneypit is offline   Reply With Quote
Old 02-28-2016, 12:12 AM   #73
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 34,453
Total Cats: 2,271
Default

you installed them backwards
18psi is offline   Reply With Quote
Old 02-28-2016, 12:14 AM   #74
Elite Member
iTrader: (6)
 
Join Date: Feb 2013
Location: Staunton, Va
Posts: 1,976
Total Cats: 145
Default

Oh ****...
ryansmoneypit is offline   Reply With Quote
Old 02-28-2016, 12:23 AM   #75
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,427
Total Cats: 187
Default

I run the ebay 2871 (bit bigger than the 2860 ebay turbo) and it works well. Will make 30 PSI on its own, but can't hold that to redline. And yeah, studs are probably backwards.
patsmx5 is online now   Reply With Quote
Old 02-28-2016, 12:41 AM   #76
Junior Member
Thread Starter
 
Join Date: Mar 2014
Location: Jacksonville, FL
Posts: 321
Total Cats: 19
Default

Quote:
Originally Posted by 18psi View Post
you installed them backwards
They are equal length on both sides


Attached Thumbnails
99 Sport eBay turbo build-80-36_10339_2d63ac60700f9feb5242ae76c5ba26ccee837d87.jpg  
borka is offline   Reply With Quote
Old 02-28-2016, 12:42 AM   #77
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 34,453
Total Cats: 2,271
Default

Attached Thumbnails
99 Sport eBay turbo build-80-36_19300_7bef062e64a0ab4d2b96426badbb9bcc70eb53d2.jpg  
18psi is offline   Reply With Quote
Old 02-28-2016, 12:52 AM   #78
Junior Member
Thread Starter
 
Join Date: Mar 2014
Location: Jacksonville, FL
Posts: 321
Total Cats: 19
Default

Quote:
Originally Posted by 18psi View Post
The main product pic shows the correct looking studs, then the next picture shows the ones I received. I guess it's the new and "improved" version.

I'll try to drive them in deeper with two nuts, I don't know if the no thread area will go into the threaded hole. I just don't want to have a stuck nut on them in case I have to return
borka is offline   Reply With Quote
Old 02-28-2016, 10:37 AM   #79
Elite Member
iTrader: (7)
 
Join Date: Apr 2013
Location: Ohio
Posts: 1,867
Total Cats: 87
Default

Quote:
Originally Posted by borka View Post
I don't know if the no thread area will go into the threaded hole. I just don't want to have a stuck nut on them in case I have to return
No it won't... You'll have a nut stuck onto the broken end after it snaps.

I'd return them and get proper studs. Plenty of places including Stage 8 http://www.stage8.com/importsturbo.html or non-locking with inconel studs here http://gcg.com.au/turbo-parts/studs-nuts or, in fairness, from one of the site vendors http://www.trackspeedengineering.com...x1-25-EFR.html

Last edited by bahurd; 02-28-2016 at 11:11 AM.
bahurd is offline   Reply With Quote
Old 02-28-2016, 01:33 PM   #80
Elite Member
iTrader: (6)
 
Join Date: Feb 2013
Location: Staunton, Va
Posts: 1,976
Total Cats: 145
Default

Quote:
Originally Posted by bahurd View Post
No it won't... You'll have a nut stuck onto the broken end after it snaps.

I'd return them and get proper studs. Plenty of places including Stage 8 Imports Locking Turbo Bolt Kits | Locking Bolts or non-locking with inconel studs here Studs & Nuts or, in fairness, from one of the site vendors Trackspeed Inconel Stud Kit (M8x1.25 EFR)
Probably not. My 2560 had enlarged area for the first 1/8 inch, just for this type of situation. It should take like 5 or ten ft lbs.

If you snap an inconel stud, you has a dumb.
ryansmoneypit is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Miata Garage Sale (Engine parts, Suspension, Interior, Exterior) vehicular Miata parts for sale/trade 24 06-08-2016 05:53 PM
Thread for naturally aspirated manifold design asmasm Engine Performance 93 01-19-2016 08:11 PM
Smoking from exhaust after Turbo Install ya boy willz General Miata Chat 4 01-02-2016 11:35 AM
Posting to classifieds difficulty burningman General Miata Chat 3 12-31-2015 09:55 PM
MIATA 1991 TURBO yoruguaparagua DIY Turbo Discussion 10 12-25-2015 05:37 PM


Tags
miata ebay turbo build

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:55 PM.