Injector Signal Loss at Specific RPM HELP!!! (Video) - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 06-29-2016, 10:30 AM   #1
Newb
Thread Starter
 
Join Date: Sep 2015
Posts: 10
Total Cats: 0
Default Injector Signal Loss at Specific RPM HELP!!! (Video)

Hey all,

I have a 1990 Miata with a turbo and COP setup. When I purchased the car, everything was fine but randomly started acting up.

Exactly at 3k RPM, the injectors lose pulse (I verified this by hooking up an oscilloscope to the PCM). I checked every single input related to the fuel injectors and none of them seemed to lose signal when the injectors did. I also wired a separate ground from the battery to the ground bus, and the injectors still went flat. I purchased a used PCM off of ebay and it had the same problem. The resistance of the injectors is also within spec.

I'm at a loss here and would really appreciate some input.

06MS6 is offline   Reply With Quote
Old 06-29-2016, 11:17 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

Id be more inclined to think it was your CAS. Especially considering it's like the only thing your ODB-I reports back AND you're throwing a CEL.
Braineack is offline   Reply With Quote
Old 06-29-2016, 11:25 AM   #3
Newb
Thread Starter
 
Join Date: Sep 2015
Posts: 10
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
Id be more inclined to think it was your CAS. Especially considering it's like the only thing your ODB-I reports back AND you're throwing a CEL.
I thought the same thing, but the CAS does not lose pulse when hooked up to the oscilloscope. The spark plugs are also firing when they need to...
06MS6 is offline   Reply With Quote
Old 06-29-2016, 11:49 AM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

make sense since the tach isn't going crazy either. but i can hear/see that your fueling goes to complete ****.

is it all injectors or just one pairing?
Braineack is offline   Reply With Quote
Old 06-29-2016, 12:18 PM   #5
Newb
Thread Starter
 
Join Date: Sep 2015
Posts: 10
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
make sense since the tach isn't going crazy either. but i can hear/see that your fueling goes to complete ****.

is it all injectors or just one pairing?
All the injectors are causing the problem. I unplugged each one to verify as well and it does the same thing.
06MS6 is offline   Reply With Quote
Old 06-29-2016, 01:44 PM   #6
Senior Member
iTrader: (2)
 
Join Date: Oct 2007
Location: Northeastern CT
Posts: 547
Total Cats: 2
Default

Are they hi-z or lo-z injectors?

Many years ago i had issues with flyback voltage spikes from lo-z injectors causing issues with my megasquirt. Swapped in hi-z injectors and never had a problem again.
therieldeal is offline   Reply With Quote
Old 06-29-2016, 02:10 PM   #7
Newb
Thread Starter
 
Join Date: Sep 2015
Posts: 10
Total Cats: 0
Default

Quote:
Originally Posted by therieldeal View Post
Are they hi-z or lo-z injectors?

Many years ago i had issues with flyback voltage spikes from lo-z injectors causing issues with my megasquirt. Swapped in hi-z injectors and never had a problem again.
I am not exactly sure, but I believe the injectors are stock.
06MS6 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Purchasing cars remotely Schuyler Insert BS here 36 07-24-2016 01:53 PM
EFR Help (None miata related) ihiryu DIY Turbo Discussion 8 06-17-2016 07:31 PM
Ebay turbo 97 miata Slowpig DIY Turbo Discussion 32 06-15-2016 06:00 PM
Turbo Miata stutters at 4500-5k rpm, then pushes through and hits full boost alienmiata1 General Miata Chat 6 06-12-2016 06:21 PM
1990 Miata fuel pump jumper ? Ruben21 General Miata Chat 5 04-29-2016 12:54 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:37 AM.