no power after 5k rpm - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 10-29-2010, 12:05 AM   #1
Newb
Thread Starter
 
Join Date: Oct 2010
Posts: 12
Total Cats: 0
Default no power after 5k rpm

so just had a t2554r kit put on my car from turbo specialties yes i know it's a **** kit figured that out just now cuz whats happening is i'm getting a popping/spitting sound around 5000 rpm i think it might be that they sent me the wrong fmu or i'm missing something from the kit idk wondering if you guys had any advice oh and i did look up that the kit did come w/a black box but that might be for the fmic kit for a 1.8 idk

heres some info on the car
92 1.6l 162k miles spec stage 3 clutch
H3br3WHAmm3R92na is offline   Reply With Quote
Old 10-29-2010, 12:17 AM   #2
Want fries with that?
iTrader: (3)
 
Join Date: Oct 2009
Location: Twin Cities, Minnesota
Posts: 2,023
Total Cats: -1
Default

Oh my ******* god. So much fail .

That "black box" (or lack thereof) is probably what's causing the popping. Most likely some sort of ignition/fuel control. My guess is you didn't do the work yourself, based on the way it's worded... Because of this, post pictures of EVERYTHING so we can see how bad off you are with this. What FMU are you running? What are you doing for ignition control?

Again, PICS PICS PICS
rider384 is offline   Reply With Quote
Old 10-29-2010, 12:23 AM   #3
Newb
Thread Starter
 
Join Date: Oct 2010
Posts: 12
Total Cats: 0
Default

first off thanks for keeping it light on the epic fail on my part yes turbo work is a new thing for me so i didnt do it myself cuz i didnt want to **** it up. not sure on the fmu just yet and i'll get on the pics
H3br3WHAmm3R92na is offline   Reply With Quote
Old 10-29-2010, 12:24 AM   #4
Newb
Thread Starter
 
Join Date: Oct 2010
Posts: 12
Total Cats: 0
Default

and yes i should have done more research on turbo kits b 4 getting this one now it seems like i'm in for a hell of a ride and not in my car it seems
H3br3WHAmm3R92na is offline   Reply With Quote
Old 10-29-2010, 12:26 AM   #5
Want fries with that?
iTrader: (3)
 
Join Date: Oct 2009
Location: Twin Cities, Minnesota
Posts: 2,023
Total Cats: -1
Default

Dude, type properly. No one is going to take you seriously if you type like a 4th grader.

Trust me, you notice it once you start.

My honest advice? Take that **** kit off. Sell it for muneez. Return it to stock, research what goes into a PROPER turbo kit, and then go from there.
rider384 is offline   Reply With Quote
Old 10-29-2010, 12:37 AM   #6
Newb
Thread Starter
 
Join Date: Oct 2010
Posts: 12
Total Cats: 0
Default

I'll consider the first thing you said thanks. But idk I'll play around w/this and swap out parts. The turbo and manifold are legit along with charge piping and down pipe. It's the fmu and the fuel management i need to fix. I figure since i just want to see what it can do with a base setup, I'll replace the fmu get a mega squirt and see what that dose. Then go from there when i want to make more power/afford it. And don't say it yes i know speed cost good money for a good setup.
H3br3WHAmm3R92na is offline   Reply With Quote
Old 10-29-2010, 12:40 AM   #7
Elite Member
iTrader: (7)
 
Join Date: Jan 2007
Location: Renton Washington
Posts: 1,742
Total Cats: 3
Default

You need a wideband to tell actually whats happening, you could be leaning out or rich as ****. Is your wastegate hooked up?
SKMetalworks is offline   Reply With Quote
Old 10-29-2010, 12:41 AM   #8
Want fries with that?
iTrader: (3)
 
Join Date: Oct 2009
Location: Twin Cities, Minnesota
Posts: 2,023
Total Cats: -1
Default

Good, you seem to have done your homework .
rider384 is offline   Reply With Quote
Old 10-29-2010, 12:48 AM   #9
Newb
Thread Starter
 
Join Date: Oct 2010
Posts: 12
Total Cats: 0
Default

I got an AEM wideband in the works. It just has to get shipped out here.
H3br3WHAmm3R92na is offline   Reply With Quote
Old 10-29-2010, 12:51 AM   #10
Want fries with that?
iTrader: (3)
 
Join Date: Oct 2009
Location: Twin Cities, Minnesota
Posts: 2,023
Total Cats: -1
Default

Oh, and +1 on the wideband. You will need one to get accurate A/F readings.
rider384 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
New personal best 1/8th mile tehzack Dynos and timesheets 10 09-21-2015 07:30 PM
Mystery Engine Trouble. Halp, mt.net! vehicular General Miata Chat 12 09-14-2015 04:17 PM
It runs! But not well.. Input appreciated. viriiguy MEGAsquirt 10 09-04-2015 07:28 PM
1996 niiata issues i am stumped. magnamx-5 General Miata Chat 32 04-22-2007 12:10 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:22 AM.