ECUs and Tuning Discuss Engine Management, Tuning, & Programming
Sponsored by:
Sponsored by:

Cant get over 14psi.

 
Old 09-19-2018, 07:46 PM
  #21  
Elite Member
Thread Starter
iTrader: (30)
 
levnubhin's Avatar
 
Join Date: Aug 2007
Location: Va Beach
Posts: 7,292
Total Cats: 2
Default

Test drive tomorrow.
levnubhin is offline  
Old 09-19-2018, 08:41 PM
  #22  
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 14,335
Total Cats: 1,313
Default

Originally Posted by levnubhin View Post
Test drive tomorrow.
Nice. SonOftheHill has some good posts about what modifications he made to his wastegates to help them seal and hold more boost.
shuiend is offline  
Old 09-19-2018, 10:47 PM
  #23  
Elite Member
iTrader: (2)
 
Join Date: Aug 2016
Location: Woostuh, MA
Posts: 3,817
Total Cats: 102
Default

Originally Posted by nitrodann View Post
Boost leak is in between the turbo pressure outlet and the inlet valves.

Dann
Infraction and all... My point was that the end result is going to be the same. In one case it's because you're bleeding off too much air at the wastegate and that's stopping the turbo from sucking in more air while at the other end there's the boost leak where you can't build up enough pressure because air is leaking out before it can enter the motor.

He'd already wired his wastegate shut and it made more boost, so it probably wasn't a boost leak since the spool should have been atrocious if it was a boost leak... if it even went up that high. My point was that the 'boost leak', so to speak, was happening at the wastegate because he'd already ruled out turbine to TB piping since it worked fine with the wiring. He just couldn't pressurize the system enough because the pressurized air was escaping through the WG and couldn't do the work as intended.

So yes. They're caused by different things, but the end result is the same....for different reasons.
ridethecliche is offline  
Reply
Leave a poscat -1 Leave a negcat
Old 09-19-2018, 11:07 PM
  #24  
Elite Member
 
Join Date: Apr 2010
Location: Newcastle, Australia
Posts: 2,822
Total Cats: 50
Default

I would call that a wastegate leak, whatever strokes your goat.
nitrodann is online now  
Old 09-19-2018, 11:35 PM
  #25  
VladiTuned
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 35,141
Total Cats: 3,141
Default

Originally Posted by ridethecliche View Post
Infraction and all... My point was that the end result is going to be the same. In one case it's because you're bleeding off too much air at the wastegate and that's stopping the turbo from sucking in more air while at the other end there's the boost leak where you can't build up enough pressure because air is leaking out before it can enter the motor.

He'd already wired his wastegate shut and it made more boost, so it probably wasn't a boost leak since the spool should have been atrocious if it was a boost leak... if it even went up that high. My point was that the 'boost leak', so to speak, was happening at the wastegate because he'd already ruled out turbine to TB piping since it worked fine with the wiring. He just couldn't pressurize the system enough because the pressurized air was escaping through the WG and couldn't do the work as intended.

So yes. They're caused by different things, but the end result is the same....for different reasons.
incorrect
18psi is offline  
Old 09-20-2018, 02:05 AM
  #26  
Elite Member
iTrader: (2)
 
Join Date: Aug 2016
Location: Woostuh, MA
Posts: 3,817
Total Cats: 102
Default

Noted.
ridethecliche is offline  
Old 09-26-2018, 07:51 AM
  #27  
Elite Member
Thread Starter
iTrader: (30)
 
levnubhin's Avatar
 
Join Date: Aug 2007
Location: Va Beach
Posts: 7,292
Total Cats: 2
Default

So yea, China wastegate sucks (duh). The turbo turbosmart wastegate is definitely the way to go. Boost holds solid to redline and it feels like the turbo spools faster. I can run 20 psi all day.
levnubhin is offline  
Old 09-26-2018, 07:50 PM
  #28  
Elite Member
iTrader: (2)
 
Join Date: Aug 2016
Location: Woostuh, MA
Posts: 3,817
Total Cats: 102
Default

Have a dyno or VeeDee plot?
ridethecliche is offline  
Old 10-23-2018, 10:07 AM
  #29  
Elite Member
iTrader: (10)
 
leatherface24's Avatar
 
Join Date: Dec 2006
Location: Pembroke Pines
Posts: 4,023
Total Cats: 1
Default

Shouldve just unplugged the wastegate and ran all of it lol
leatherface24 is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
meBlaise
Race Prep
40
09-28-2017 11:02 PM
paul
Dynos and timesheets
104
10-03-2008 12:07 PM
dc2696
Insert BS here
15
06-19-2008 02:33 PM
kotomile
Dynos and timesheets
48
05-18-2008 09:36 PM
samnavy
MEGAsquirt
3
02-24-2008 06:41 PM


Thread Tools
Search this Thread
Quick Reply: Cant get over 14psi.


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.