ECUs and Tuning Discuss Engine Management, Tuning, & Programming
Sponsored by:
Sponsored by:

Car self revving

 
Old 11-10-2018, 02:47 AM
  #1  
Newb
Thread Starter
 
Join Date: Nov 2018
Posts: 3
Total Cats: 0
Default Car self revving

I just finished installing an ms3x I built up using Brain's instructions and base map. The car is a totally stock 10ae other than the ms3, gm iat sensor, aem x-series wideband, and joyfast shift ****, though I doubt that one has much to do with my problem. The car will start up and idle right around 1500rpm when cold (around 45 degrees) and drops down to 1200 or so as it warms up a bit, my issue comes with the application of any throttle at all the car will rev itself up to around 3500 rpm, hold it for a couple seconds after you've let off, then drop back down to idle.

I have searched around and found info on cars with high idles and acceleration enrichment issues but nothing mentioning a tiny blip of the throttle causing it to rev up on its own for a few seconds with no additional input.

I figure all the stock sensors are okay because the car ran perfect on the stock ecu two days ago. I have checked all vacuum connections that I touched and can't hear or see any leaks. The tune is just Brains base map with the basic sensor calibration done.

Any ideas would be appreciated, I am at a bit of a loss here.
Panoramic is offline  
Old 11-10-2018, 08:52 AM
  #2  
Moderator
iTrader: (12)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 18,907
Total Cats: 2,364
Default

It's probably the shift ****.

If not then check the tune. On certain versions there are "dashpot" settings and I can't recall what else they are called right now. But it will be in your basic idle tuning section. Sorry, post-surgery drugs make this tough.
sixshooter is offline  
Old 01-24-2019, 11:36 PM
  #3  
Newb
Thread Starter
 
Join Date: Nov 2018
Posts: 3
Total Cats: 0
Default

So I tried to post this in November and as far as I could see it never went through, then yesterday I got the confirmation email. Weird. Regardless, thanks for the suggestion sixshooter.

For anyone potentially reading this with a similar problem, the issue turned out to be a seriously un-calibrated iacv. A few minutes using the idle valve test mode to dial it in and all was well.
Panoramic is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
mx5-kiwi
Engine Performance
13
08-09-2012 01:14 AM
orion4096
Engine Performance
18
05-03-2012 01:29 AM
Saml01
Insert BS here
23
02-24-2009 11:28 PM
momo182
Engine Performance
3
12-06-2008 08:51 PM
miataspeed1point6
MEGAsquirt
15
07-08-2008 03:45 PM


Thread Tools
Search this Thread
Quick Reply: Car self revving


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.