Help with Logworks3: OBDII Ign Adv logging - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 07-31-2011, 02:27 AM   #1
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 4,682
Total Cats: 216
Default Help with Logworks3: OBDII Ign Adv logging

*Not really Miata related*

I just bought myself a new Innovate OT-2 so that I can start logging some OBDII cars. The plan is to compile fuel and ignition maps of stock vehicles for the purpose of learning how the OEMs tune different setups.

But anyway, Ive tried it on 2 cars now, my gf's Beetle and my Mustang, both of which logged rpm, tps, load, etc just fine but logged bizarre ignition advance readings.
Im a total Logworks noob, all Ive used it for in the past has been logging AFR with my LC-1, so Im pretty sure Im doing something wrong. I noticed in the settings for the channel it was showing as being a 0-5v sensor with a range from like -64 degrees to 63 degrees, which doesnt make a whole lot of sense.

So yah, any help?
Full_Tilt_Boogie is offline   Reply With Quote
Old 07-31-2011, 07:36 PM   #2
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 4,682
Total Cats: 216
Default

Heres a screenshot of what Im talking about:



I know mass air flow is different that speed desnity, but it cannot be that different. The timing numbers make zero sense.
Attached Thumbnails
Help with Logworks3: OBDII Ign Adv logging-mustang_01_ignadv.png  
Full_Tilt_Boogie is offline   Reply With Quote
Old 07-31-2011, 08:26 PM   #3
Elite Member
 
Join Date: Jul 2005
Posts: 6,454
Total Cats: 80
Default

Cool project. I didn't know logworks could do that. What setup are you using? OT2?

Can you also attach a MAP sensor and log that too?
JasonC SBB is offline   Reply With Quote
Old 07-31-2011, 09:23 PM   #4
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 4,682
Total Cats: 216
Default

Thats right, Innovate OT-2
http://www.innovatemotorsports.com/products/ot2.php

It works with the whole "daisy-chain" concept with their other stuff, so you can hook an LC-1 or one of the analog input boxes to it and log it all together. Just by itself you can only log the OBDII stuff, but with these modern ECUs there is a lot to be read, the Mustang even has factory widebands O2 sensors.

Theres also the added benefit of being able to use my iPhone as a gauge, which is sorta cool but Im not sure Ill ever use it.
Full_Tilt_Boogie is offline   Reply With Quote
Old 08-01-2011, 02:03 PM   #5
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 4,682
Total Cats: 216
Default

Alright so today I decided to try to log with the iPhone and was surprised to see that immediately I was getting more logical readings. So I logged some driving around and a couple WOT pulls to redline and got this:

Ignition:



Wideband O2 in lambda:



This is a real problem.
If anybody were to tell me that they didnt know how to datalog their car with a Windows PC but knew how to log with their iPhone, I would make fun of them. Yet here I am.
On a positive note, this shows me that there is nothing wrong with the car or OT-2 or logworks, its simply something Im doing wrong in LM Programmer. So I guess Im going to give Innovate a call sometime today and see if they can de-noob me.
Attached Thumbnails
Help with Logworks3: OBDII Ign Adv logging-musang_ios_02_ign.png   Help with Logworks3: OBDII Ign Adv logging-musang_ios_02_afr.png  
Full_Tilt_Boogie is offline   Reply With Quote
Old 08-01-2011, 04:14 PM   #6
Elite Member
 
Join Date: Jul 2005
Posts: 6,454
Total Cats: 80
Default

Which car is the above?
JasonC SBB is offline   Reply With Quote
Old 08-01-2011, 04:59 PM   #7
Elite Member
Thread Starter
iTrader: (1)
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 4,682
Total Cats: 216
Default

'11 Mustang GT

11.0:1 CR and able to run on 87, which explains the wimpy WOT timing
Full_Tilt_Boogie is offline   Reply With Quote
Old 08-01-2011, 06:25 PM   #8
Elite Member
 
Join Date: Jul 2005
Posts: 6,454
Total Cats: 80
Default

Does it have 4-valve combustion chambers?
JasonC SBB is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:14 PM.