Innovate MTX-L Wideband Display Issue - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 02-19-2013, 06:43 PM   #1
Newb
Thread Starter
iTrader: (1)
 
Join Date: Jun 2010
Posts: 41
Total Cats: 0
Default Innovate MTX-L Wideband Display Issue

My Innovate MTX-L Wideband seems to have a display issue but I am not sure if it is the display or if it is the wiring. The gauge works fine and shows AFR correctly but random pixels sometimes light up on the screen where they are not supposed to. It is not consistent and not a big issue just a bit annoying. Any ideas?
Mason77 is offline   Reply With Quote
Old 02-19-2013, 07:18 PM   #2
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,174
Total Cats: 2,575
Default

you got a defective one?
18psi is offline   Reply With Quote
Old 02-19-2013, 07:34 PM   #3
Newb
Thread Starter
iTrader: (1)
 
Join Date: Jun 2010
Posts: 41
Total Cats: 0
Default

Quote:
Originally Posted by 18psi View Post
you got a defective one?
Im not sure. I contacted Innovate and they said they would replace it if i sent it in I was just curious to see if maybe my wiring is wrong. Heres what it looks like when the random pixels light up.
Attached Thumbnails
Innovate MTX-L Wideband Display Issue-gauges_zps53918541.jpg  
Mason77 is offline   Reply With Quote
Old 02-20-2013, 03:34 AM   #4
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Defective unit, send it in for replacement.
Reverant is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM
1996 Turbo Build Goldwar DIY Turbo Discussion 2 09-29-2015 10:20 AM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 06:33 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:38 AM.