Engine Temperature - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 09-27-2010, 02:05 PM   #1
Newb
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Posts: 38
Total Cats: 0
Default Engine Temperature

I've got an '03 with a non-intercooled BEGI-S kit. It's got
a Garrett GT2554R, and recently, the turbo water line broke and I had it replaced.

Since it was replaced, I'll drive the car without any issues - but when I get somewhere and I let the car sit for a bit to idle it down, the temperature gauge starts to go up sometimes.

When I see it rise, I'll shut it off before it gets any higher. Theories and suggestions?
Scigano is offline   Reply With Quote
Old 09-27-2010, 02:09 PM   #2
Senior Member
iTrader: (10)
 
Join Date: Aug 2007
Location: Fredericton, NB
Posts: 1,187
Total Cats: 4
Default

Does your cooling fan work??? next time you stop, pop the hood and make sure its on.
Preluding is offline   Reply With Quote
Old 09-27-2010, 02:09 PM   #3
Senior Member
iTrader: (23)
 
Join Date: Oct 2009
Location: Chatsworth, SoCal
Posts: 948
Total Cats: 1
Default

Is the fan comming on?

Have a great day,
Jared
Jfornachon is offline   Reply With Quote
Old 09-27-2010, 03:41 PM   #4
Newb
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Posts: 38
Total Cats: 0
Default

How long after idling should they turn on?
Scigano is offline   Reply With Quote
Old 09-27-2010, 04:23 PM   #5
Elite Member
 
Join Date: Jul 2005
Posts: 6,454
Total Cats: 80
Default

Did you burp the system?
JasonC SBB is offline   Reply With Quote
Old 09-27-2010, 05:09 PM   #6
Newb
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Posts: 38
Total Cats: 0
Default

I wasn't there, I took it to
a shop I'm familiar with and they found the leak first, then replaced the line and refilled the system themselves. I'd imagine they did it right.

I'm going with the fans first, I'm going to drive it to another friend's shop - a Miata specialist - when I get there, I'm going to pop the hood and if the fans aren't on - we'll start trouble shooting there.

When the water line went, it did squirt water around, could that have shorted a switch out?
Scigano is offline   Reply With Quote
Old 09-27-2010, 05:12 PM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,846
Total Cats: 1,787
Default

Quote:
Originally Posted by Scigano View Post
How long after idling should they turn on?
once the temps recorded at the sensor reach 207*F.
Braineack is offline   Reply With Quote
Old 09-27-2010, 07:14 PM   #8
Newb
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Posts: 38
Total Cats: 0
Default

The fans are coming on. Crap.

I'm taking it to a Spec Miata friend of mine tomorrow, but I better not run into traffic.

If I stay still for a while, the car starts warming up - with the fans on. At speed, temperatures remain normal or return to normal if they heated up after sitting idle. He's moved to suspecting the radiator or water pump for tomorrow.

What do you guys think of that?
Scigano is offline   Reply With Quote
Old 09-27-2010, 08:49 PM   #9
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

olderguy is offline   Reply With Quote
Old 09-28-2010, 01:48 AM   #10
Newb
Thread Starter
iTrader: (1)
 
Join Date: Feb 2010
Posts: 38
Total Cats: 0
Default

Cool, but I saw both fans running today when the temperature still started to climb up.
Scigano is offline   Reply With Quote
Old 09-28-2010, 05:34 AM   #11
Newb
 
Join Date: May 2010
Location: Scandinavia
Posts: 43
Total Cats: 0
Default

Quote:
Originally Posted by JasonC SBB View Post
Did you burp the system?
How do you do that?
j-po is offline   Reply With Quote
Old 09-28-2010, 05:39 AM   #12
Elite Member
iTrader: (17)
 
Join Date: Apr 2009
Location: Atlanta, GA
Posts: 2,831
Total Cats: 0
Default

just like burping a babie.....
WonTon is offline   Reply With Quote
Old 09-28-2010, 08:52 AM   #13
Elite Member
iTrader: (12)
 
Join Date: Sep 2007
Location: Charlotte, NC
Posts: 6,868
Total Cats: 66
Default

Quote:
Originally Posted by WonTon View Post
just like burping a babie.....
Do you mean baby?

Sounds like you have air in the system IMHO.
How many miles on the engine?
When was the last time you did any maintainence to the cooling system?
Are you having to add coolant to the reservoir?
How much is the needle moving?
Doppelgänger is offline   Reply With Quote
Old 09-28-2010, 08:56 AM   #14
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

Quote:
Originally Posted by Scigano View Post
Cool, but I saw both fans running today when the temperature still started to climb up.
That thread is about both fans coming on, and perhaps not correctly wired.
olderguy is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:54 PM.