Pre-swap wiring questions - BP4W into 92 NA6 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-01-2014, 06:32 PM   #1
Ich verstehe nur Bahnhof
Thread Starter
iTrader: (3)
 
psyber_0ptix's Avatar
 
Join Date: Mar 2012
Location: Northern VA
Posts: 3,713
Total Cats: 320
Default Pre-swap wiring questions - BP4W into 92 NA6

Hello all,
I've finally finished building the motor and am going to attempt to install it this weekend. I just wanted seek clarification or a set of second eyes when it comes to wiring...just to be sure.

I am going to be upgrading to an MS3 unit and will be retaining the BP4W sensors. To merge these sensors into the NA6 harness, I need to ensure that they are connected correctly.

____________________________________

For the Crank/Cam signal
Stock 1.6L CAS:
black w/ light green stripe = Ground
white w/ red stripe = +12V
white = crank signal
yellow w/ blue stripe = cam signal

on the BP4W Crank Sensor:
White w/red stripe = +12v
Black w/blue stripe = ground
Grey w/ Red = Crank signal

on BP4W Cam Sensor:
White w/red stripe = +12v
Black w/blue stripe = ground
Grey w/ Blue = Cam signal

essentially, I can split the power and ground from the stock CAS and wire it into the respective white/red and black wires on the BP4W sensors, then just hook up
[NA6:white to BP4W:grey/red] and
[NA6: yellow/blue to BP4W: grey/blue]


____________________________________

For IACV
just connect the wires as polarity doesn't matter?

Quote:
Originally Posted by Joe Perez View Post
On the stock '99 harness, the orange wire is positive and the violet / red wire is negative, from the point of view of the IAC valve.

Also, I agree that the valve should be insensitive to polarity, as it's just a simple solenoid.
source: http://forum.miata.net/vb/newreply.p...eply&p=5233397
____________________________________

TPS
NA6 Red = 5v reference
NA6 light green/white = TPS signal
NA6 black/green = Ground

BP4W Light Grn/Red = 5v reference
BP4W Green/Black = TPS signal
BP4W Black/Red = Ground


Quote:
Originally Posted by Braineack View Post
Try this:

Code:
TPS              Function        Harness
GRN/BLK        TPS SIG        GRN/WHT
BLK/RED        GROUND         BLK/GRN
GRN/RED          5vref             RED
I had you reverse the sig and ground.
source: https://www.miataturbo.net/megasquir...-93-car-36271/
____________________________________


Electronic boost control solenoid

Is there a switched 12v source I could use for the EBC? I am pretty sure I can hijack one of the wires back to the ecu and relocate it to be used for Megasquirts Boost Control function.


I think that's it for the wiring. As I recall the fan switch that was at the front of the block is now obsolete since megasquirt controls the output.


ANY insight or correction to the above would be greatly appreciated

Last edited by psyber_0ptix; 04-01-2014 at 07:17 PM.
psyber_0ptix is offline   Reply With Quote
Old 04-02-2014, 07:05 PM   #2
Ich verstehe nur Bahnhof
Thread Starter
iTrader: (3)
 
psyber_0ptix's Avatar
 
Join Date: Mar 2012
Location: Northern VA
Posts: 3,713
Total Cats: 320
Default

Can someone take a picture of their blow to so I can see what the colors should be for the plug?

The pigtail I have does not match the factory colors at all.

My tips pigtail has:
Brown with yellow stripe
Brown
Pink with black stripe
psyber_0ptix is offline   Reply With Quote
Old 04-02-2014, 11:46 PM   #3
Ich verstehe nur Bahnhof
Thread Starter
iTrader: (3)
 
psyber_0ptix's Avatar
 
Join Date: Mar 2012
Location: Northern VA
Posts: 3,713
Total Cats: 320
Default

my colors don't match at all :(

can anyone take a pic of their stock 99-00 wires for the TPS and the cam/crank sensors?
Attached Thumbnails
Pre-swap wiring questions - BP4W into 92 NA6-20140402_161142.jpg  

Last edited by psyber_0ptix; 04-03-2014 at 01:15 PM.
psyber_0ptix is offline   Reply With Quote
Old 04-03-2014, 01:19 PM   #4
Ich verstehe nur Bahnhof
Thread Starter
iTrader: (3)
 
psyber_0ptix's Avatar
 
Join Date: Mar 2012
Location: Northern VA
Posts: 3,713
Total Cats: 320
Default

Also my crank sensor pig tail does not match, but am I safe in assuming black is ground, red is power and blue is the signal wire to be connected to the CKP wire from the 1.6L CAS?

Attached Thumbnails
Pre-swap wiring questions - BP4W into 92 NA6-20140402_161207.jpg  
psyber_0ptix is offline   Reply With Quote
Old 04-04-2014, 01:44 AM   #5
Ich verstehe nur Bahnhof
Thread Starter
iTrader: (3)
 
psyber_0ptix's Avatar
 
Join Date: Mar 2012
Location: Northern VA
Posts: 3,713
Total Cats: 320
Default

anyone?
psyber_0ptix is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 06:33 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:08 PM.