running issue help please - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 07-30-2016, 09:59 AM   #1
Newb
Thread Starter
 
Join Date: Jul 2016
Posts: 10
Total Cats: 0
Default running issue help please

94 1.8 got real like lumpy idle, smells like shes over fueling abit, when you rev it works fine then drop back to idle its lumpy, been checking breathers ect and blanked a couple ect still the same, whats the next thing to look at? plus what way should the arrow point on the one way valve for the brake servo?
PhilFPM is offline   Reply With Quote
Old 07-30-2016, 12:56 PM   #2
Elite Member
iTrader: (6)
 
Join Date: Feb 2013
Location: Staunton, Va
Posts: 2,305
Total Cats: 188
Default

This could be caused by a thousand things. Have you done the basic tune up stuff? If so, list them.
ryansmoneypit is offline   Reply With Quote
Old 07-30-2016, 03:22 PM   #3
Newb
Thread Starter
 
Join Date: Jul 2016
Posts: 10
Total Cats: 0
Default

not sure when you say tuneup what you mean so just listing what ive done
new plugs
new leads
fluids, filters
k&n typhoon induction kit
new water pump
cambelt n othwr belts
venier pullys
new gaskets, seals ect all over.
all new pipes ect

not 100% sure on where all the breather ect things went, ive got
the rocker breather going to a oil catch tank and the other as usual into the inlet, couple blanked off top next to
tb and the one near the fire wAll as it goes to cly 4.

PhilFPM is offline   Reply With Quote
Old 07-30-2016, 05:10 PM   #4
Elite Member
iTrader: (6)
 
Join Date: Feb 2013
Location: Staunton, Va
Posts: 2,305
Total Cats: 188
Default

Compression check?
ryansmoneypit is offline   Reply With Quote
Old 07-30-2016, 05:38 PM   #5
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,411
Total Cats: 77
Default

Recheck your timing belt
olderguy is offline   Reply With Quote
Old 07-31-2016, 04:54 PM   #6
Junior Member
 
Join Date: Mar 2013
Location: Flower Mound, TX
Posts: 233
Total Cats: 26
Default

EricJ is offline   Reply With Quote
Old 07-31-2016, 05:26 PM   #7
Newb
Thread Starter
 
Join Date: Jul 2016
Posts: 10
Total Cats: 0
Default

i will check the timing tommrow
thanks i did also remove the cas but did mark where it was and put it back to that
mark but could that also be worth a wobble?
PhilFPM is offline   Reply With Quote
Old 08-09-2016, 05:11 PM   #8
Newb
Thread Starter
 
Join Date: Jul 2016
Posts: 10
Total Cats: 0
Default

got a timing light onit and played about with the timing the exhaust was about a tooth out and then adjusted the cas slightly now
runs a treat
PhilFPM is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Another brake pad thread.. daily vs track Uncle Humjaba Suspension, Brakes, Drivetrain 40 05-11-2017 12:05 PM
nb1 intake manifold/fuel rail, valve covers, oil pan mx5roadster Miata parts for sale/trade 5 04-11-2017 07:22 PM
15 Months & Counting - '92 Mariner Blue 1.8 Turbo Build OGWar Build Threads 57 02-04-2017 12:30 AM
Help with Braineack built MS3 - fuel pump circuit curly MEGAsquirt 38 07-22-2016 08:42 PM
Car cranks over but won't fire, no spark or fuel boileralum ECUs and Tuning 11 05-13-2016 09:10 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:25 PM.