What's restricting my engine? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-02-2011, 12:58 PM   #1
Junior Member
Thread Starter
 
Join Date: Oct 2009
Posts: 46
Total Cats: 0
Default What's restricting my engine?

I've been on the dyno and got a healthy 200bhp at the fly from my supercharged 1.8 96 miata but on every run the car would start to slow down the build up of revs until about 6k where it took off again.
We bypassed the supercharger and had a run on the dyno and the car displayed the same behaviour.
The tuner things that the timing looks good throughout and the AFR's where stable and hitting the right marks for the amount of boost. I've also changed exhausts and it's still there.
It feels like something's opening up at 6k but i've no idea what. Any idea's on what could be moving?
GrahamA is offline   Reply With Quote
Old 04-02-2011, 02:01 PM   #2
Elite Member
iTrader: (3)
 
Join Date: Mar 2008
Location: Granbury, TX
Posts: 6,010
Total Cats: 583
Default

You're looking at this the wrong way. It's not what's restricting, it's what's giving you extra torque at the lower RPMs. Your intake manifold has tuned runner lengths that give you "free" supercharging at certain RPMs. Unfortunately, ram tuning doesn't work across the whole RPM range. Do an internet search on ram tuned induction. I get a huge kick out of the early-60s Chrysler BB intakes. Wild stuff.

A true, passive restriction would show up as a torque and HP fall-off at high RPMs. It would be related to air flow and nothing else.
hornetball is offline   Reply With Quote
Old 04-02-2011, 02:24 PM   #3
Elite Member
 
Join Date: Jul 2005
Posts: 6,454
Total Cats: 80
Default

Maybe knock detection, either real or false.
JasonC SBB is offline   Reply With Quote
Old 04-02-2011, 02:28 PM   #4
Junior Member
Thread Starter
 
Join Date: Oct 2009
Posts: 46
Total Cats: 0
Default

Thanks guys.
Should've said you can see a definite drop off on the dyno graphs like the car's already peaked before it kicks in again.
Not got any knock detection on the car and the tuner couldn't hear anything whilst it was on the rollers.
GrahamA is offline   Reply With Quote
Old 04-02-2011, 02:32 PM   #5
Senior Member
iTrader: (10)
 
Join Date: Jul 2009
Location: Oakdale, CA
Posts: 1,353
Total Cats: 66
Default

you mean these? I bought a set a swap meet a few years ago for $500. They didnt look half as good as these. But I turned around and sold them for $750 later that day. I knew I would never use them. I dont have a BB Chryslers. Only small blocks
Attached Thumbnails
What's restricting my engine?-21333137-273-v8413-long-ram-induction-intake-manifol.jpg  
RyanRaduechel is offline   Reply With Quote
Old 04-02-2011, 06:03 PM   #6
Elite Member
iTrader: (2)
 
fooger03's Avatar
 
Join Date: Jan 2009
Location: Columbus, OH
Posts: 4,133
Total Cats: 188
Default

intake manifold

oh - and supercharger
fooger03 is offline   Reply With Quote
Old 04-02-2011, 09:39 PM   #7
Elite Member
 
Join Date: Feb 2008
Location: Victoria, BC
Posts: 2,322
Total Cats: 12
Default

A good turbo setup would clear those restrictions right away!
dustinb is offline   Reply With Quote
Old 04-03-2011, 05:17 AM   #8
Junior Member
Thread Starter
 
Join Date: Oct 2009
Posts: 46
Total Cats: 0
Default

We bypassed the charger and got the same drop off then sudden return in power so I don't think it's that but if anyone wants to send me a complete turbo setup to test with pm me
GrahamA is offline   Reply With Quote
Old 04-03-2011, 11:54 AM   #9
Senior Member
 
Join Date: Aug 2009
Location: MONROE CT
Posts: 1,100
Total Cats: 2
Default

Quote:
Originally Posted by RyanRaduechel View Post
you mean these? I bought a set a swap meet a few years ago for $500. They didnt look half as good as these. But I turned around and sold them for $750 later that day. I knew I would never use them. I dont have a BB Chryslers. Only small blocks



Here is them on the motor this is a pic from my friends house of the 300G they have been restoring.
miatamike203 is offline   Reply With Quote
Old 04-03-2011, 12:11 PM   #10
Elite Member
 
Join Date: Feb 2008
Location: Victoria, BC
Posts: 2,322
Total Cats: 12
Default

If your car is building revs but slowing down, I would suspect a slipping clutch.
dustinb is offline   Reply With Quote
Old 04-03-2011, 05:03 PM   #11
Junior Member
Thread Starter
 
Join Date: Oct 2009
Posts: 46
Total Cats: 0
Default

That's the trouble, it's not building revs. It revs freely up to this point and then kicks back in again after 6k but feels like it's pulling through treacle for a while.
GrahamA is offline   Reply With Quote
Old 04-03-2011, 09:24 PM   #12
Junior Member
 
Join Date: Dec 2007
Posts: 159
Total Cats: 0
Default

dyno plot available?
dynokiller90 is offline   Reply With Quote
Old 04-04-2011, 05:01 AM   #13
Junior Member
Thread Starter
 
Join Date: Oct 2009
Posts: 46
Total Cats: 0
Default

I've attached the one run image i've got. This is one of the better runs. Normally it's more pronounced than this.
Attached Thumbnails
What's restricting my engine?-dynorun.jpg  
GrahamA is offline   Reply With Quote
Old 04-04-2011, 01:21 PM   #14
Elite Member
iTrader: (9)
 
Join Date: Jun 2008
Location: Houston, TX
Posts: 1,583
Total Cats: 8
Default

Whoa thats weird... What kind of fuel management? I can't really imagine much mechanically doing this...
TravisR is offline   Reply With Quote
Old 04-04-2011, 01:38 PM   #15
Elite Member
iTrader: (3)
 
Join Date: Mar 2008
Location: Granbury, TX
Posts: 6,010
Total Cats: 583
Default

Quote:
Originally Posted by GrahamA View Post
I've attached the one run image i've got. This is one of the better runs. Normally it's more pronounced than this.
That's definitely ECU. Way too high in RPM's and too peaky/pronounced to be related to tuned runner lengths.
hornetball is offline   Reply With Quote
Old 04-04-2011, 03:37 PM   #16
Junior Member
Thread Starter
 
Join Date: Oct 2009
Posts: 46
Total Cats: 0
Default

I'm running a DIYPnp megasquirt v1.1
A few guys in the ms forum have looked at my map before but couldn't see anything up with it.
GrahamA is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 Yesterday 09:00 PM
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:15 AM.