4 wire o2 help - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 03-27-2007, 07:00 PM   #1
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default 4 wire o2 help

I have 2 NTK 2H29 4 wire o2 sensors. Obviously I only need one. Anyway...I searched a bit and couldn't find how to wire it up. I'm having running/Autotune troubles again. When I first start the car up it misfires quite a bit until its warm. When the Autotune turns on the car bogs HARD and misses. I'm pretty sure the 1 wire o2 I have now is the culprit. I still have the Greddy d/p.

They have 2 white wires, a grey and a black. How should this be connected? Thanks!
miataspeed1point6 is offline   Reply With Quote
Old 03-27-2007, 08:02 PM   #2
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

The two white wires go to your 12 volt supply, doesn't matter which is + or -.

Your black goes to a good solid ground that is common with the ECU(there is one on a screw to the motor by the CAS. The grey wire goes to where your single wire was going before.
olderguy is offline   Reply With Quote
Old 03-30-2007, 12:39 PM   #3
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

Quote:
Originally Posted by olderguy View Post
The two white wires go to your 12 volt supply, doesn't matter which is + or -.

Your black goes to a good solid ground that is common with the ECU(there is one on a screw to the motor by the CAS. The grey wire goes to where your single wire was going before.
Above is incorrect. The grey wire is your ground, the black is your sensor wire.

Sorry if I gave anyone else the wrong information. I just pulled one out and tested it.
olderguy is offline   Reply With Quote
Old 04-01-2007, 02:02 AM   #4
Senior Member
Thread Starter
iTrader: (1)
 
miataspeed1point6's Avatar
 
Join Date: Feb 2006
Location: Detroit
Posts: 1,235
Total Cats: 0
Default

I updated my diagram. I'm hoping to get this installed soon. The government needs to hurry up and give me my refund so I can get my wideband! I was planning on doing both at the same time, but I'll pop this is really quick. Thanks!
miataspeed1point6 is offline   Reply With Quote
Old 04-01-2007, 02:11 AM   #5
Elite Member
iTrader: (11)
 
Trent's Avatar
 
Join Date: Feb 2006
Location: Louisiana
Posts: 1,625
Total Cats: 5
Default

http://mymiata.paladinmicro.com/Miata4-WireO2.htm

This is the site i used when i wired mine up. make sure you actually wire up the o2 sensor ground to the same wire as the ECU ground. Going to body ground is not good enough.

And yeah, your symptoms are EXACTLY the same as my symptoms when i had a bad O2 sensor: bogging and hesitation (almost sounds like hitting fuel cut) when the car is cold and trying to enter boost for the first time.
Trent is offline   Reply With Quote
Old 04-09-2007, 10:19 AM   #6
Junior Member
 
Join Date: Dec 2006
Posts: 85
Total Cats: 0
Default

Great link supersaiyan! Thanks! This is exactly the symptoms I've got. I bought the 4 wire sensor today, and it'll go in during the week! MT.net FTW!
t25miata is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 02:11 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 06:33 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:33 AM.