Car is idling lean but fine cruising and under WOT... Help? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 11-16-2012, 06:47 PM   #1
Newb
Thread Starter
 
Join Date: Mar 2012
Posts: 5
Total Cats: 0
Default Car is idling lean but fine cruising and under WOT... Help?

Hey all my car has been having a really lean idle within the past month or so and its starting to worry me. The car will cold start fine and idle normal for a couple seconds and will start to idle leaner as the car warms up to the point where it will actually stall. Once the car is warm it idles about at 17:1-20s:1. when driving however the cars AFR is right where it should be between 14.7 at cruise and 12:1 at WOT. I'm running Megasquirt2pnp. i have a data log that i can post if anyone thinks that would help.

Don't think it is..:
Exhaust Leak - because car is actually running lean to the point that it stalls
Vacuum leak - because i don't have a high idle and from my understanding a vacuum leak would not cause a lean condition like this on a speed density car (correct me if im wrong)
Boost leak - because again with speed density a boost leak would not cause these symptoms
A fuel issue - because the car is fine under WOT
MAP sensor - because mega squirt shows 26-28kpa at idle
IAT sensor - because again mega squirt is showing a good temperature

any ideas on where to look or if im overlooking any of the above? thank you!
bimmeguy is offline   Reply With Quote
Old 11-17-2012, 08:51 PM   #2
Newb
Thread Starter
 
Join Date: Mar 2012
Posts: 5
Total Cats: 0
Default

here is a data log after about a 10 minute drive and just idling until it eventually stalls.
Attached Files
File Type: msl 12 - Copy.msl (1.29 MB, 109 views)
bimmeguy is offline   Reply With Quote
Old 11-20-2012, 04:03 PM   #3
Senior Member
 
Join Date: Dec 2010
Location: Auckland, NZ
Posts: 783
Total Cats: 23
Default

Seeing as no one has answered i'll have a guess....

As it seems temp related, it could be something in the idle circuit...

I know bugger all about the ide circuit but it IS affected by the coolant temp (hoses go to it).......maybe a seal or something in or around that area....?
mx5-kiwi is offline   Reply With Quote
Old 11-20-2012, 04:04 PM   #4
Senior Member
 
Join Date: Dec 2010
Location: Auckland, NZ
Posts: 783
Total Cats: 23
Default

Also, can you go back to a base map and see if it does the same problem.

That will help diagnose ECU (corrupt map) or mechanical problem......
mx5-kiwi is offline   Reply With Quote
Old 11-20-2012, 05:25 PM   #5
Elite Member
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,791
Total Cats: 130
Default

This may be a stupid question, but did you try tuning the car? Open tunerstudio, (going from memory) go to Basic Settings > VE Fuel Table > Add fuel to cells in the bottom left hand corner of the table until it's idling where you want it. If you do this while the car is running you can see exactly where the little dot is and know the exact cell(s) that need fuel.
pdexta is offline   Reply With Quote
Old 11-21-2012, 10:34 AM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

tune the megasquirt. solve the problem.
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
TunerStudio timining issue - 90 Miata 1.6 Turbo spec1sef MEGAsquirt 28 05-09-2017 08:03 AM
91 1.6l turbo complete part out. Tony the Tiger Miata parts for sale/trade 63 12-29-2016 03:23 AM
Cannot set Base Timing to 10* Elfering MEGAsquirt 50 10-05-2015 09:04 AM
Ms2e 99-00 ac control Dobzeh MEGAsquirt 23 09-15-2015 05:49 PM
Missfires on idle and cruising (no load) emarkey DIY Turbo Discussion 2 09-05-2015 07:59 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:12 AM.