Got a CEL, possible culprits. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 05-20-2008, 11:32 PM   #1
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default Got a CEL, possible culprits.

So I have been driving the car the whole weekend without it lighting up, and then today I get one after 45 miles of driving.

I have everything connected that should be connected so I don't know why im getting a code.

Is it possible it threw a code because im still running a bit rich in boost? or is it not smart enough for that?

Any way to troubleshoot it without reading the codes off, or should I just go to the autozone and have them pull em for me?
Saml01 is offline   Reply With Quote
Old 05-20-2008, 11:47 PM   #2
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Some research proves that it could be the culprit. Because there are obd2 codes relating to a/f ratio being to rich or lean.

http://www.miata.net/garage/obdii.html

P1131 HO2S Bank 1 Sensor 1 Signal Below 0.45v (A/F Ratio Too Lean)
P1132 HO2S Bank 1 Sensor 1 Signal Above 0.45v (A/F Ratio Too Rich)
P1143 HO2S Bank 1 Sensor 3 Signal Below 0.45v (A/F Ratio Too Lean)
P1144 HO2S Bank 1 Sensor 3 Signal Above 0.45v (A/F Ratio Too Rich)
P1151 HO2S Bank 2 Sensor 1 Signal Below 0.45v (A/F Ratio Too Lean)
P1152 HO2S Bank 2 Sensor 1 Signal Above 0.45v (A/F Ratio Too Rich)

How do I know which sensors these are? 3 sensors?
Saml01 is offline   Reply With Quote
Old 05-21-2008, 12:47 AM   #3
Junior Member
 
Join Date: Oct 2007
Location: AC, NJ
Posts: 346
Total Cats: 0
Default

There are codes, but it would be silly to stab in the dark. Go get the codes checked. Honestly, it will probably be the first of many with OBDII.
compy is offline   Reply With Quote
Old 05-21-2008, 01:27 AM   #4
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

obd1 > *.life
hustler is offline   Reply With Quote
Old 05-21-2008, 05:29 AM   #5
Senior Member
 
Join Date: Jun 2006
Location: Orlando FL - UCF
Posts: 688
Total Cats: 1
Default

take out the bulb...
coastertrav is offline   Reply With Quote
Old 05-21-2008, 10:33 AM   #6
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Quote:
Originally Posted by coastertrav View Post
take out the bulb...
Gotta pass inspection still. its probably something minor. If Arkmage can get around CEL's on his 97, I shouldnt have an issue.

Quote:
Originally Posted by compy View Post
There are codes, but it would be silly to stab in the dark. Go get the codes checked. Honestly, it will probably be the first of many with OBDII.
Damnit. OK.
Saml01 is offline   Reply With Quote
Old 05-21-2008, 10:34 AM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,892
Total Cats: 1,792
Default

ignore it. I get a CEL when i cruise sometimes. I know exactly what it is; I cruise at 15.5:1 and it doesn't like it over a prolonged period of time and throws an o2 error.
Braineack is offline   Reply With Quote
Old 05-21-2008, 02:42 PM   #8
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

^ Hmm. But I dont cruise at 15.5. My cruise is around 14.7.

Does yours go away at least or always on?
Saml01 is offline   Reply With Quote
Old 05-21-2008, 02:44 PM   #9
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,892
Total Cats: 1,792
Default

goes away once im once the o2 has something better to output to the ECU.
Braineack is offline   Reply With Quote
Old 05-21-2008, 02:47 PM   #10
Senior Member
iTrader: (7)
 
Join Date: Aug 2007
Location: Southern Indiana
Posts: 1,371
Total Cats: -1
Default

Quote:
Originally Posted by Braineack View Post
I cruise at 15.5:1
Hmm.. my cruise is 17:1 am i going to burn up my exhaust valves?

</hijack>
wes65 is offline   Reply With Quote
Old 05-21-2008, 03:08 PM   #11
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Hmmmmm. I think ill get the codes read for ***** and giggles. Maybe get a scan gauge. Maybe.
Saml01 is offline   Reply With Quote
Old 05-21-2008, 10:24 PM   #12
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

P0170 Fuel Trim Malfunction (Bank 1)

Its not even in the list at the above link.

Edit:

I was reading through a bunch of forums and it seems to be Air/Fuel related, either MAF, or O2.

Was this what you were seeing braineack?

I guess this could be caused by the MAF getting one reading, and then the exhaust having completely un related readings. I would imagine the computer some how compares ingested air to what comes out.

Last edited by Saml01; 05-21-2008 at 10:42 PM.
Saml01 is offline   Reply With Quote
Old 05-21-2008, 11:48 PM   #13
Elite Member
iTrader: (7)
 
samnavy's Avatar
 
Join Date: Apr 2006
Location: VIRGINIA BEACH, VA
Posts: 6,020
Total Cats: 175
Default

Spend the $40 for a Code-Scanner... OBDII isn't going anywhere for awhile. I hate relying on AutoPepNapaBoys for anything like that.

I can almost guarantee you it's a rich/lean code... but you can't guess at **** like that. It might be something dumb like an EGR code cause you didn't tighten your gas-cap down fully. Buy the scanner, it won't be the last time you need one.
samnavy is offline   Reply With Quote
Old 05-22-2008, 12:05 AM   #14
Senior Member
iTrader: (2)
 
SamS's Avatar
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 1,254
Total Cats: 7
Default

FWIW, I've never had an a/f related code thrown, even with afr's from 10-17.5. The only code I ever get is the occasional EGR system flow malfunction because I removed my EGR system,
SamS is offline   Reply With Quote
Old 05-22-2008, 10:33 AM   #15
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Quote:
Originally Posted by samnavy View Post
Spend the $40 for a Code-Scanner... OBDII isn't going anywhere for awhile. I hate relying on AutoPepNapaBoys for anything like that.

I can almost guarantee you it's a rich/lean code... but you can't guess at **** like that. It might be something dumb like an EGR code cause you didn't tighten your gas-cap down fully. Buy the scanner, it won't be the last time you need one.
Where do you get it for 40? Because I will go and buy one in a heart beat.

I didnt go to napa to get it read, a friend of mine has a MAC obd reader and he stopped by last night.
Saml01 is offline   Reply With Quote
Old 05-22-2008, 09:41 PM   #16
Senior Member
iTrader: (2)
 
SamS's Avatar
 
Join Date: Jun 2006
Location: Wisconsin
Posts: 1,254
Total Cats: 7
Default

The cheapest I've seen are $75-80 (which I have), but I've seen those models go on sale for around $55.
SamS is offline   Reply With Quote
Old 05-22-2008, 09:45 PM   #17
Elite Member
iTrader: (7)
 
samnavy's Avatar
 
Join Date: Apr 2006
Location: VIRGINIA BEACH, VA
Posts: 6,020
Total Cats: 175
Default

How many Sam's does it take to find a $40 code scanner?
http://cgi.ebay.com/ebaymotors/OBD2-...spagenameZWDVW
samnavy is offline   Reply With Quote
Old 05-22-2008, 10:51 PM   #18
Elite Member
Thread Starter
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Quote:
Originally Posted by samnavy View Post
How many Sam's does it take to find a $40 code scanner?
http://cgi.ebay.com/ebaymotors/OBD2-...spagenameZWDVW
Nice. I found that one on amazon, tried to find it on ebay and couldnt. Cheaper on amazon anyway. Thanks either way.

I had the light removed yesterday and today after 10 miles it came back, im starting to get annoyed.

I'm gonna stop by walmart tomorrow and see what they got, according to Chad they carry some cheap ones, if not ill order it online.
Saml01 is offline   Reply With Quote
Old 05-27-2008, 12:48 AM   #19
Junior Member
iTrader: (1)
 
Join Date: May 2008
Location: NJ
Posts: 146
Total Cats: 0
Default

if you have a harbor freight nearby it's really worth checking there. i kick myself for not buying one of their cheap hand held jobs last time i was there.
ChairFaceChippendale is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM
First to get it out of the way main Meet and Greet 2 09-05-2015 02:03 PM
First to get it out of the way main Meet and Greet 1 09-05-2015 01:39 PM
Emu, 2004 msm & cel p0351/p0352 hershann E-Manage 3 09-07-2008 08:42 PM
New Exhaust - CEL turning on papasmurf Prefabbed Turbo Kits 6 11-30-2007 03:52 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:41 PM.