Problem w/ rx-7 AFM. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 05-03-2008, 03:27 PM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2007
Location: Arvada, CO
Posts: 118
Total Cats: 0
Default Problem w/ rx-7 AFM.

I just got and installed a rx-7 AFM for my 1.6 NA and something is amiss.

The car basically will not idle(or really run w/o me giving it gas). As soon as the RPMs approach idle speeds the car begins to stumble hard and then it dies.

I got it from a guy on this board and I have no reason to suspect he's trying to scam me, so I'm wondering what the problem is.
My old AFM had crapped out on me(i'm pretty sure) and was making my car run like crap, so I'm also wondering if maybe there's something up w/ my car besides the AFM thats not letting it idle.

Please help!

Thank you,
-Sean
honeydesean is offline   Reply With Quote
Old 05-03-2008, 06:23 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,836
Total Cats: 1,786
Default

vacuum leak anywhere?
Braineack is online now   Reply With Quote
Old 05-04-2008, 11:22 AM   #3
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2007
Location: Arvada, CO
Posts: 118
Total Cats: 0
Default

would that be enough to mess with the engine that bad?

I'll double check under the hood today, but I don't remember seeing anything disconnected.
honeydesean is offline   Reply With Quote
Old 05-04-2008, 11:35 AM   #4
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2007
Location: Arvada, CO
Posts: 118
Total Cats: 0
Default

oh and my plugs(which are about a week old) were black as hell when I checked them yesterday. I'm assuming this is from driving it around a little with (what I'm assuming was) a bad AFM, not sure if knowing it's been running rich is useful but whatever. I do need this figured out soon, I'm graduating and moving back to chicagoland in a week.
honeydesean is offline   Reply With Quote
Old 05-04-2008, 02:14 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,836
Total Cats: 1,786
Default

do you hear a click just before it dies? did you tune the rx7 afm at all?
Braineack is online now   Reply With Quote
Old 05-04-2008, 03:48 PM   #6
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2007
Location: Arvada, CO
Posts: 118
Total Cats: 0
Default

Well, it "runs" now. As I was cleaning the rx-7 afm, i noticed the guy who painted it black did such an awesome job that they didn't mask over the damn connector pins on the AFM... so those are clean and it will run.

now it's having the same problems I was having with my old AFM in(which I guess hadn't gone bad after all)

the car will bog down if I don't feather the throttle to accelerate and while I'm at speed the car will tick back and forth between running alright and bogging down somewhat. The onset of this problem originally only happened at low RPMs(would only bog say from a stoplight, and run fine anywhere above 2k). Then after an admittedly thrashing country-road run one afternoon, it was having these 'bogging' issues throughout the RPM band.

It's been suggested that the O2 sensor may be the culprit over on CR.net, any support for this?

*And no, I haven't tuned the rx7 AFM. I wasn't aware I had to do anything (i saw you could adjust the spring tension, but I wasn't going to mess w/ that unless needed).
honeydesean is offline   Reply With Quote
Old 05-04-2008, 04:09 PM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,836
Total Cats: 1,786
Default

yes, you need to loosen the tension about 7-8 clicks on stock injectors.
Braineack is online now   Reply With Quote
Old 05-04-2008, 06:53 PM   #8
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2007
Location: Arvada, CO
Posts: 118
Total Cats: 0
Default

Done. It runs better when it's not bogging down, but it's still bogging down all over the place.
honeydesean is offline   Reply With Quote
Old 05-04-2008, 09:43 PM   #9
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2007
Location: Arvada, CO
Posts: 118
Total Cats: 0
Default

Replaced o2 sensor w/ a bosch universal for the time being. I have 1-2 extra o2 sensors back in my garage at home, so i just paid the $20 to try a new o2 for a week and then I'll put a legit one back in.

car runs better, but I still have to put the AF ratio in check manually w/ the gas pedal(ie slowly depressing it to accelerate) or else I get the same bogged down feel.

oh and Braineack, mebbe change the topic title to something like "car bogs down under accel" since it's not the AFM. I'm just hoping this might get more people checking the thread so it's not just you fielding all my questions, I feel like I'm almost pestering you at this point. Thanks!
honeydesean is offline   Reply With Quote
Old 05-05-2008, 04:24 PM   #10
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2007
Location: Arvada, CO
Posts: 118
Total Cats: 0
Default

anybody have ideas for the car not running right still?
honeydesean is offline   Reply With Quote
Old 05-06-2008, 11:05 AM   #11
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jul 2007
Location: Arvada, CO
Posts: 118
Total Cats: 0
Default

took it to a shop, the coil for cylinder #3 was misfiring.
honeydesean is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Bogging under SLIGHT throttle to the point of dying. Not during idle or mid throttle JesseTheNoob General Miata Chat 1 12-12-2014 03:57 PM
Root of problems? 2 Different part #s!! thirdgen General Miata Chat 15 07-21-2009 09:27 AM
1986 RX-7 V8, looks great, $4375 See Video & Pictures OldSkoolFool Cars for sale/trade 11 11-05-2008 08:25 PM
AFM locations problem zebro racing DIY Turbo Discussion 8 10-31-2007 11:36 PM
RX-7 MAF Problems ruger988 General Miata Chat 4 02-12-2007 04:43 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:37 AM.