Stock 99 runs like crap below 3000rpm - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 05-15-2012, 07:53 PM   #1
Elite Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,782
Total Cats: 119
Default Stock 99 runs like crap below 3000rpm

Does it in all situations. Hot. Cold. Light throttle. Wot.

No CELs.

Above 3000 it is totally happy.

By runs like crap i mean consistently misses and stumbles.

Please help me fix my daily.
Faeflora is offline   Reply With Quote
Old 05-15-2012, 08:12 PM   #2
Senior Member
iTrader: (6)
 
Join Date: Aug 2009
Location: Charlotte, NC
Posts: 924
Total Cats: 16
Default

check timing?

did you put gas in it? if that one gauge on the left points at the E then there is your problem...
Gryff is offline   Reply With Quote
Old 05-15-2012, 09:59 PM   #3
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,110
Total Cats: 518
Default

Spark plug wires? Although when my car used to cook mine, it would only stumble as it revved passed a certain rpm, usually between 3000-4000rpm. Worth a shot, we all know you like throwing money at your car.
curly is offline   Reply With Quote
Old 05-15-2012, 11:28 PM   #4
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,133
Total Cats: 598
Default

Its funny because this sounds kinda like my problem but mine was 2000-2500 rpm. But my problem was anything above 50kpa load between 2k-2.5k and i was running E85 that had stayed there for a week without being touched. A member on miatanet said it was E85 going bad... problem disappeared halfway through the new tank.
triple88a is offline   Reply With Quote
Old 05-15-2012, 11:35 PM   #5
Elite Member
 
Join Date: Mar 2010
Location: Detroit
Posts: 1,524
Total Cats: 27
Default

You need to throw more turbo at it...that and a sawzall.
flounder is offline   Reply With Quote
Old 05-15-2012, 11:44 PM   #6
Elite Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,782
Total Cats: 119
Default

U gays rnt helping.

I am thinking it is due to some VVICSTS bullshi. All vac lines liok ok though. Opinins?
Faeflora is offline   Reply With Quote
Old 05-15-2012, 11:47 PM   #7
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,133
Total Cats: 598
Default

Vics dont do shi t at 3k rpm as far as drivability goes buu.
triple88a is offline   Reply With Quote
Old 05-16-2012, 01:06 AM   #8
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,370
Total Cats: 1,332
Default

Coil packs?
Savington is offline   Reply With Quote
Old 05-16-2012, 01:48 AM   #9
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Unplug whatever we're calling the intake air sensor and see if it behaves differently. I recently had a chaffed wire on my daily and had a similar symptom. I'm guessing it's a spark relate problem.
hustler is offline   Reply With Quote
Old 05-16-2012, 02:33 AM   #10
Elite Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,782
Total Cats: 119
Default

Quote:
Originally Posted by Savington View Post
Coil packs?
Why would it only misfire at low rpm though?

I will try unpluggin ait sensa
Faeflora is offline   Reply With Quote
Old 05-16-2012, 09:23 AM   #11
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,199
Total Cats: 2,584
Default

maybe 3k is the switchpoint for CL/OL and a bad sensor is causing it to freak out in CL?
18psi is offline   Reply With Quote
Old 05-16-2012, 09:48 AM   #12
Elite Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,782
Total Cats: 119
Default

Quote:
Originally Posted by 18psi View Post
maybe 3k is the switchpoint for CL/OL and a bad sensor is causing it to freak out in CL?
Wouldnt this throw a CEL though?
Faeflora is offline   Reply With Quote
Old 05-16-2012, 10:01 AM   #13
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,780
Total Cats: 1,106
Default

Have you hooked up an OBDII scanner to watch what is going on with everything while this is happening?

I have a bluetooth OBDII adapter that I use with the app "Torque" on my phone and it allows me to monitor everything that is going on.
shuiend is offline   Reply With Quote
Old 05-16-2012, 08:05 PM   #14
Elite Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,782
Total Cats: 119
Default

Quote:
Originally Posted by shuiend View Post
Have you hooked up an OBDII scanner to watch what is going on with everything while this is happening?

I have a bluetooth OBDII adapter that I use with the app "Torque" on my phone and it allows me to monitor everything that is going on.
WTF is this OBDII scanner thing. Seriously, I have never heard of it.

I guess I can get one loaned from autozone or something? Or no?...
Faeflora is offline   Reply With Quote
Old 05-17-2012, 02:58 AM   #15
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Faeflora View Post
WTF is this OBDII scanner thing. Seriously, I have never heard of it.

I guess I can get one loaned from autozone or something? Or no?...
Yes, Vatozone will help you.
hustler is offline   Reply With Quote
Old 05-17-2012, 10:40 AM   #16
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,780
Total Cats: 1,106
Default

Quote:
Originally Posted by Faeflora View Post
WTF is this OBDII scanner thing. Seriously, I have never heard of it.

I guess I can get one loaned from autozone or something? Or no?...
The cheap OBDII scanners just hook to the OBDII port and read codes, the expensive ones can read all the data that the ECU outputs. I bought
this this
bluetooth OBDII adapter for my pickup truck. I then use https://play.google.com/store/apps/details?id=org.prowl.torque&hl=en app on my phone as an interface for the adapter.
shuiend is offline   Reply With Quote
Old 05-17-2012, 12:06 PM   #17
Slowest Progress Ever
iTrader: (26)
 
thirdgen's Avatar
 
Join Date: Oct 2007
Location: The coal ridden hills of Pennsylvania
Posts: 5,812
Total Cats: 187
Default

Droid only app?
thirdgen is offline   Reply With Quote
Old 05-17-2012, 12:44 PM   #18
Elite Member
Thread Starter
iTrader: (2)
 
Join Date: Jan 2007
Location: Los Angeles, CA
Posts: 8,782
Total Cats: 119
Default

I'm not a droid plebe.

i ball out with my iPhone 4s s for u iz suckaz
Faeflora is offline   Reply With Quote
Old 05-17-2012, 12:54 PM   #19
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,780
Total Cats: 1,106
Default

Quote:
Originally Posted by thirdgen View Post
Droid only app?
Torque is droid only.

Quote:
Originally Posted by Faeflora View Post
I'm not a droid plebe.

i ball out with my iPhone 4s s for u iz suckaz
Except your iPhone 4s has shitty blue tooth api's so developing blue tooth apps is next to impossible. So they are not exactly baller.

There might be other OBDII software for the iphone, I have never looked and have no desire to.

Last edited by shuiend; 05-17-2012 at 02:00 PM.
shuiend is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Tire temp question tazswing Race Prep 9 10-01-2015 01:33 AM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 06:33 PM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM
BP-6D on CAS only aidandj MEGAsquirt 14 09-25-2015 06:26 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:54 PM.