MX_Eva's 1990 with bonus! - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Media Got any pics or vids to share?

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 02-27-2010, 10:27 PM   #1
Senior Member
Thread Starter
 
Join Date: Jan 2007
Location: Maryland
Posts: 701
Total Cats: 0
Default MX_Eva's 1990 with bonus!

So here's my 1990 Mariner Blue. I've had the car since January of 2005, been doing little odds and ends here and there. Been a long time forum member though haven't had much time to post as of late. After I had thrown a modest suspension at the car I knew I wanted to turbo it and I came here and learned everything I know about turbos and forced induction from right here. Not just turbo sizing, intercoolers, CFMs but all the knowledge I carry about tuning as well.
MX_Eva's 1990 with bonus!-_mg_1237.jpg
The car has gone through a number of engines, the most recent at Summit Point Raceway in WV. After building a second megasquirt (and it refusing to work) I decided I'd attend a drift day and wire open the wastegate. I wasn't seeing any boost which was fine and dandy. Till the exhaust bolts backed off and i went open downpipe. Built up to 4-6 psi and boom. sent a rod out the block.

MX_Eva's 1990 with bonus!-photo0133.jpg

Everything is together now, new engine all sorts of work to try and make that happen even in this cold silly winter. Actually as of thursday of this week I though it was all ready to go. Cept it won't start. Here's a video of it cranking over. I've never heard anything like it, today I replaced the starter which was my only best guess as to the cause.

miata no start video by skank_bait - Photobucket

So if you've got any clue what causes that noise It'd be great to be clued in. Would love to have the car back on the road.
MX_Eva is offline   Reply With Quote
Old 02-27-2010, 11:22 PM   #2
Junior Member
iTrader: (1)
 
Join Date: May 2009
Location: Niagara Falls, ON
Posts: 433
Total Cats: 0
Default

Custom built intake manifold?
stranges12712 is offline   Reply With Quote
Old 03-01-2010, 12:21 AM   #3
Senior Member
Thread Starter
 
Join Date: Jan 2007
Location: Maryland
Posts: 701
Total Cats: 0
Default

Yessir it is. Really opened up the car even N/A at top end and made me wish the rev range went up higher. Should be nice once I actually get some boost into it though since that's what it was made for.
MX_Eva is offline   Reply With Quote
Old 03-01-2010, 12:36 AM   #4
Elite Member
iTrader: (1)
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 4,687
Total Cats: 216
Default

Running the stock ECU with that manifold?
Full_Tilt_Boogie is offline   Reply With Quote
Old 03-01-2010, 12:46 AM   #5
Elite Member
 
Join Date: Feb 2008
Location: Victoria, BC
Posts: 2,322
Total Cats: 12
Default

It sounds like the starter isn't actually engaging almost. If the car is in gear when you crank, does it move forward?
dustinb is offline   Reply With Quote
Old 03-01-2010, 02:01 AM   #6
Elite Member
iTrader: (4)
 
Pen2_the_penguin's Avatar
 
Join Date: Dec 2009
Location: Reno, NV
Posts: 3,690
Total Cats: 97
Default

miliary bonuses are fun. Cant wait for mine here soon... gonna upgrade somethin' major
Pen2_the_penguin is offline   Reply With Quote
Old 03-01-2010, 09:11 PM   #7
Senior Member
Thread Starter
 
Join Date: Jan 2007
Location: Maryland
Posts: 701
Total Cats: 0
Default

Yes I had stock ECU running with that manifold. Not a problem, yeah that seems like what the sound would be, but I swapped the starter out so I dunno.

I haven't cranked it in gear yet. I'll be trying that soon though

Haha, the bonus was not military money, but rather that the car does not run.=)
MX_Eva is offline   Reply With Quote
Old 03-01-2010, 09:13 PM   #8
Elite Member
iTrader: (4)
 
Pen2_the_penguin's Avatar
 
Join Date: Dec 2009
Location: Reno, NV
Posts: 3,690
Total Cats: 97
Default

lame. lol It will run soon tho!
Pen2_the_penguin is offline   Reply With Quote
Old 03-01-2010, 09:19 PM   #9
Elite Member
iTrader: (30)
 
Join Date: Aug 2007
Location: Va Beach
Posts: 7,282
Total Cats: 0
Default

Is the motor spinning when you crank it? It's almost sounds like no compression.
__________________
Best Car Insurance | Auto Protection Today | FREE Trade-In Quote
levnubhin is offline   Reply With Quote
Old 03-02-2010, 01:39 AM   #10
Elite Member
iTrader: (1)
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 4,687
Total Cats: 216
Default

Hmm
Im surprised that the stock ECU runs it well with that manifold, typically such a drastic change would require a bit of tuning.
Id be curious to see how it dynos NA, and of course turbo, haha
Full_Tilt_Boogie is offline   Reply With Quote
Old 03-02-2010, 01:48 AM   #11
Elite Member
 
Join Date: Feb 2008
Location: Victoria, BC
Posts: 2,322
Total Cats: 12
Default

Quote:
Originally Posted by levnubhin View Post
Is the motor spinning when you crank it? It's almost sounds like no compression.
Actually that sounds right. Are there spark plugs in the car?
dustinb is offline   Reply With Quote
Old 03-02-2010, 11:38 AM   #12
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

sounds like death.
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
TunerStudio timining issue - 90 Miata 1.6 Turbo spec1sef MEGAsquirt 28 05-09-2017 08:03 AM
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
MS3 or MSPNP Pro konmo MEGAsquirt 22 11-05-2015 03:32 PM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 06:33 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:48 PM.