'99 DIYPNP CL Idle Issues - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 09-29-2014, 08:01 PM   #1
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2010
Location: Farmington Hills, MI
Posts: 873
Total Cats: 93
Default '99 DIYPNP CL Idle Issues

Here we go again with another idle thread. I still can't seem to figure out closed loop, even after reading every thread out there about Megasquirt idle stuff. It's a Brain build DIYPNP running 3.3.2 firmware, and using TunerStudio 2.6.1 on a 1999 Miata. I've tried messing with closed loop a few times, and always end up going back to open loop. I just got open loop to idle nicely with ID1000's, by playing with the dead times. Now when I switch to closed loop, it cycles from 700 rpm to 1500 rpm. The CL Idle indicator in TS does not illuminate green, the IAC value stays constant, and nothing I change in the PID settings affect the idle.

I've messed with all the other settings, I've run the idle test (successfully), and the idle valve is responsive in open loop. I'm hoping it's just something simple, and I'm just overlooking it!

I've attached a datalog and the msq. The datalog has all PID settings set to zero. If anyone has any suggestions, that would be great!
Attached Files
File Type: msl Idle CL PID0.msl (89.1 KB, 62 views)
File Type: msq 2014-09-29_16.55.53 cl test.msq (110.5 KB, 58 views)
acedeuce802 is offline   Reply With Quote
Old 09-29-2014, 09:21 PM   #2
Junior Member
 
Join Date: Jan 2014
Location: Port Saint Lucie,FL
Posts: 418
Total Cats: 3
Default

Here are my idle settings. They work well for me, and are not too different from the values preloaded from Brain when I bought my MS3x. I idle at about 950-975.

99, stock injectors, NA, but my help give you some ideas.
Mech5700 is offline   Reply With Quote
Old 09-29-2014, 10:50 PM   #3
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2010
Location: Farmington Hills, MI
Posts: 873
Total Cats: 93
Default

Thanks for that. I'm now reading a lot about the gslender firmware with much improved idle capabilities. I'll try that tomorrow. But that still doesn't explain why my valve is totally unresponsive with closed loop.
acedeuce802 is offline   Reply With Quote
Old 09-29-2014, 11:25 PM   #4
Junior Member
 
Join Date: Jan 2014
Location: Port Saint Lucie,FL
Posts: 418
Total Cats: 3
Default

It also looks like you have idle advance turned off as well. Turning that on/tuning it may help as well.
Mech5700 is offline   Reply With Quote
Old 09-30-2014, 09:05 AM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

Quote:
Originally Posted by acedeuce802 View Post
Thanks for that. I'm now reading a lot about the gslender firmware with much improved idle capabilities. I'll try that tomorrow. But that still doesn't explain why my valve is totally unresponsive with closed loop.
with PID at 0|0|0 it would be unresponsive. I suggest you go to gslender 2.8a firmware.
Braineack is offline   Reply With Quote
Old 10-01-2014, 10:21 AM   #6
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2010
Location: Farmington Hills, MI
Posts: 873
Total Cats: 93
Default

Quote:
Originally Posted by Braineack View Post
with PID at 0|0|0 it would be unresponsive. I suggest you go to gslender 2.8a firmware.
If it can idle on 3.3.2, is there still reason to go to gslender v2.8? One thing I see attractive on 3.3.2 is CL boost control initial values, which I'm not sure if gslender firmware supports.

Last night was the first night I've had a VERY stable idle. I found the settings for the CL idle spark advance, and I also tuned in my injector timing table. I probably stay within 30 rpm now. However this is still open loop..
acedeuce802 is offline   Reply With Quote
Old 10-01-2014, 10:23 AM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

it has tons of idle improvements (e.g. voltage pwm% control, spark advance idle control) as well as a/c idle up. It's all I load on any DIYPNP I've assembed in the last few years.
Braineack is offline   Reply With Quote
Old 10-01-2014, 10:36 AM   #8
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2010
Location: Farmington Hills, MI
Posts: 873
Total Cats: 93
Default

It seems that all of gslender's idle improvements got adopted into the new msextra firmware. Now that I've got the spark advance idle control tuned, I'll give it another go tuning CL using the initial value table and voltage pwm control. If that doesn't work I'll try gslender.
acedeuce802 is offline   Reply With Quote
Old 10-01-2014, 10:49 AM   #9
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,842
Total Cats: 1,786
Default

oh interesting. good to know. I'm a bit out of the loop with ms2.
Braineack is offline   Reply With Quote
Old 10-01-2014, 10:52 AM   #10
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2010
Location: Farmington Hills, MI
Posts: 873
Total Cats: 93
Default

I also thought it was awesome that before I updated idle VE for the new settings, it was dead stable at 18 AFR with ID1000's.
acedeuce802 is offline   Reply With Quote
Old 10-02-2014, 09:32 AM   #11
Senior Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2010
Location: Farmington Hills, MI
Posts: 873
Total Cats: 93
Default

I've now switched over to closed loop, tuned in the initial value table, and it's responding very nicely!
acedeuce802 is offline   Reply With Quote
Old 09-18-2015, 07:16 PM   #12
Newb
 
Join Date: Sep 2015
Posts: 2
Total Cats: 0
Default

Can you share your latest msq please? I am just starting to setup my CL and I am curious about the injector timing tuning you did. Can you elaborate? Thanks!
imaplt is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM


Tags
closed, diypnp, idle, loop, ms2

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:55 PM.