Accel Enrichment / Stall issues (90-93 DIYPnP) - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 05-01-2012, 12:44 PM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2012
Location: Portugal
Posts: 199
Total Cats: -12
Default Accel Enrichment / Stall issues (90-93 DIYPnP)

Hey there!

I got the MS running perfectly, the car is idling pretty fine, and the VE table needs some adjustment but otherwise they're good enough to perform some running tests...

Now I have a slight issue. I tee'd a pipe off the FPR and into the cabin for the MAP sensor, and even so I still don't get a proper throttle response. When I press the pedal, even if it's ever so slightly, the car stalls for a fraction of a second and then revs. I'm pretty positive this is the Accel Enrichment acting up, because the AFR on the wideband shows me a very very lean mixture the moment I press the gas pedal. MAPdot wasn't set, so I set it (previous owner had TPS and I missed this bit) and that didn't solve me problem either.

Here's the settings I'm using:




Remember this is a '91 Miata running a 90-93 DIYPNP, aspirated, with no TPS or AFM. All stock except cone filter and cat-back stainless exhaust. Also, using a sealed element sensor for IAT.

Can it be that the pipes for the MAP are too flexible or something?
Attached Thumbnails
Accel Enrichment / Stall issues (90-93 DIYPnP)-capture1.png   Accel Enrichment / Stall issues (90-93 DIYPnP)-capture2.png   Accel Enrichment / Stall issues (90-93 DIYPnP)-capture3.png  
ThunderFox is offline   Reply With Quote
Old 05-01-2012, 12:46 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

blip throttle, watch it move on that slider up. add "value (ms)" in places within the rate shown.
Braineack is offline   Reply With Quote
Old 05-01-2012, 03:29 PM   #3
Junior Member
Thread Starter
 
Join Date: Mar 2012
Location: Portugal
Posts: 199
Total Cats: -12
Default

Oh man, this worked like a charm! I settled at about 6ms/9ms/12ms/15ms (respectively, from the bottom up) and the car does not stall anymore! It's almost as good as stock!

Man, I'm so happy if you were a cute gal I'd kiss you

Thanks so much Brain!
ThunderFox is offline   Reply With Quote
Old 05-01-2012, 04:17 PM   #4
Junior Member
iTrader: (5)
 
Join Date: Jul 2007
Location: South Jersey
Posts: 112
Total Cats: 1
Default

Brain, what is the equivalent of this slider on Tunerstudio?
I don't recall seeing one. Is it more of test-and-feel type for TS users then?

Of course, I do not have the laptop with TS with me today to check.
bogly is offline   Reply With Quote
Old 05-01-2012, 04:27 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

TS uses a curve, and there's a green dot that rides on teh rail. like monorail cat.
Braineack is offline   Reply With Quote
Old 05-02-2012, 12:20 PM   #6
Senior Member
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

So I noticed on mine it never makes it very far up the curve does that mean I need to reset the [arameters using the grey dotted box in top right corner of each graph to make a better map for my setup.

I am totaly lost in tunnng enrichment.
90 Turbo is offline   Reply With Quote
Old 05-02-2012, 12:25 PM   #7
Junior Member
iTrader: (14)
 
Join Date: Sep 2007
Location: Aldie, VA
Posts: 276
Total Cats: 0
Default

Quote:
Originally Posted by 90 Turbo View Post
So I noticed on mine it never makes it very far up the curve does that mean I need to reset the [arameters using the grey dotted box in top right corner of each graph to make a better map for my setup.

I am totaly lost in tunnng enrichment.

Are you looking at the curve while in neutral free reving? Ooor in gear under load?
jtpaintballwdp is offline   Reply With Quote
Old 05-02-2012, 12:51 PM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

Quote:
Originally Posted by 90 Turbo View Post
So I noticed on mine it never makes it very far up the curve does that mean I need to reset the [arameters using the grey dotted box in top right corner of each graph to make a better map for my setup.

I am totaly lost in tunnng enrichment.

the curve is the rate you slam the pedal, if you are never able to get it to scale up the curve, maybe you need to reduce the rate values so you can fine tune the curve.
Braineack is offline   Reply With Quote
Old 05-02-2012, 01:32 PM   #9
Senior Member
iTrader: (3)
 
Join Date: Sep 2011
Location: Plano TX
Posts: 595
Total Cats: 2
Default

Ok that makes sense.
Just so I understand.
move dot up more fuel move dot down less.
How do I tell which to do. Is it based on afr? or Feel of the engine?

My accell enrichment sucks.
90 Turbo is offline   Reply With Quote
Old 05-02-2012, 02:01 PM   #10
Junior Member
Thread Starter
 
Join Date: Mar 2012
Location: Portugal
Posts: 199
Total Cats: -12
Default

You choose whether you want to make the enrichment MAPdot or TPSdot based, and also if you want RPM based enrichment to go with either. AFR is of no importance as far as configuration goes, except you'll want to check whether you're too lean or too rich on acceleration.

For mine (no TPS) I chose MAPdot with no RPM accel enrichment, and used the values I provided above. It still gets a bit on the rich side when I press the pedal, but it's hardly noticeable while driving, and when the car is warm. When the car is cold, I stil get a bit of a lean spot when the car is cold (right after start).

You can see all of my settings above, they change a bit on the Accel Enrichment Wizard if you're using TunerStudio, but they're pretty straight forward. Even if they don't suit your car, they might be a good starting point
ThunderFox is offline   Reply With Quote
Old 05-02-2012, 02:51 PM   #11
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

Quote:
Originally Posted by 90 Turbo View Post
move dot up more fuel move dot down less.
How do I tell which to do. Is it based on afr? or Feel of the engine?

My accell enrichment sucks.

Pretty much. you're adding in extra fuel based of a %/sec rate change in MAP or TPS.

the value you are entering is litterally how much extra pulse width to inject.

the rate value is a % change / sec.

ideally you'd tune it so when you hit the gas off idle, or between shifts, you have plenty of fuel for smooth engagement...otherwise you'll have lean spikes and youll feel the car hesistate.

you'll tune off a curve where heavier inputs may need more fuel, and just little blips not so much. make sure you outer extreme rate isn't so far off the scale that you'll never move the throttle fast enough to hit that area, it's a waste of resolution.



Quote:
For mine (no TPS) I chose MAPdot with no RPM accel enrichment, and used the values I provided above. It still gets a bit on the rich side when I press the pedal, but it's hardly noticeable while driving, and when the car is warm. When the car is cold, I stil get a bit of a lean spot when the car is cold (right after start).
I'd rather spike rich than lean, try to target the 14:1 area if you can.

increase the cold accel multipler to maybe 110% if you need a little more enrichments in the cold.
Braineack is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:09 AM.