Adding Launch Control to DIYPNP - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-04-2016, 09:56 PM   #1
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,791
Total Cats: 130
Default Adding Launch Control to DIYPNP

Making a plea here for some help adding launch control to my megasquirt. I've got a '96 DIYPNP assembled by Braineak.

There are 4 outputs wired on the DB15 connector: power, ground, o2, EBC.

There are 3 extra outputs wired:
flex --- input/output 2 -- 1L -- no idea
PE1 --- input/output 1 -- 1K -- AC switch I believe
PE0 --- boost control

It looks like the instructions I can find say to use input 1/2 for launch control. I don't have AC in the car, so if I need to rob input 1 that's no problem.

I'm assuming I need to add a wire to the DB15 connector but beyond that I'm pretty much lost and can't find anything online that can dumb it down enough for me. Any chance someone could walk me through this (or at least convince me that I don't even want to attempt it).







I'll be happy to get any additional pictures if anyone wants them, just let me know.
Attached Thumbnails
Adding Launch Control to DIYPNP-20160204_195112.jpg   Adding Launch Control to DIYPNP-20160204_195042.jpg   Adding Launch Control to DIYPNP-20160204_193711.jpg  
pdexta is offline   Reply With Quote
Old 02-04-2016, 10:05 PM   #2
Sadfab Union President
iTrader: (3)
 
Join Date: May 2014
Location: Kansas
Posts: 2,690
Total Cats: 113
Default

deezums is offline   Reply With Quote
Old 02-04-2016, 10:17 PM   #3
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,791
Total Cats: 130
Default

Quote:
Originally Posted by deezums View Post
Holy crap, good find. That makes it look like it's already wired. Damn, if I just needed to turn it on in the tune I'm about as retarded as they come. Thanks.
pdexta is offline   Reply With Quote
Old 02-05-2016, 09:13 AM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

it's already wired up. did i build that one? looks like it.
Braineack is offline   Reply With Quote
Old 02-05-2016, 10:02 AM   #5
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,791
Total Cats: 130
Default

Quote:
Originally Posted by Braineack View Post
it's already wired up. did i build that one? looks like it.
Yes. Thanks for the confirmation. For some reason I was under the impression I needed to run a line to the clutch switch from the db15 connector. Can't wait to test it out.
pdexta is offline   Reply With Quote
Old 02-06-2016, 01:24 PM   #6
Elite Member
Thread Starter
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,791
Total Cats: 130
Default

Woo, it works.

My little rubber piece on the clutch sensor was missing so the switch thought the clutch was always down, but once I fixed that it's seems to be working great.

pdexta is offline   Reply With Quote
Old 02-07-2016, 06:10 PM   #7
Junior Member
 
Join Date: Dec 2011
Posts: 75
Total Cats: 3
Default

Not convinced launch control is good for the long term health of the turbo. I've stopped using mine, although it does what it says on the tin with a flame out the back for good measure.
HeresJohnny is offline   Reply With Quote
 
 
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:19 AM.