Anyone running a Mac? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-18-2015, 01:14 AM   #1
Junior Member
Thread Starter
 
Join Date: Sep 2014
Location: Portland (left coast)
Posts: 214
Total Cats: 2
Default Anyone running a Mac?

I live in a household of only Macs so I was wondering if I should try and make a MS2 and TunerStudioMS work with the Mac or just by a cheap PC-based laptop and dedicate it to the Miata.

Thanks.
tazswing is offline   Reply With Quote
Old 03-18-2015, 01:41 AM   #2
Junior Member
iTrader: (20)
 
Join Date: Apr 2010
Location: Redmond, WA
Posts: 494
Total Cats: 15
Default

a mac IS a pc

tunerstudio has a mac version

if that doesn't work, then buy a windows based machine and dedicate it to the miata
bmxfuel007 is offline   Reply With Quote
Old 03-18-2015, 01:45 AM   #3
Senior Member
iTrader: (8)
 
Join Date: Jan 2012
Location: Azusa, CA
Posts: 1,376
Total Cats: 80
Default

I use a mac for tunnerstudio but through windows 7 bootcamp. So that is an option that I know for sure should work.
cyotani is offline   Reply With Quote
Old 03-18-2015, 01:58 AM   #4
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

I use it with no problems at all.
aidandj is offline   Reply With Quote
Old 03-18-2015, 02:00 AM   #5
Junior Member
Thread Starter
 
Join Date: Sep 2014
Location: Portland (left coast)
Posts: 214
Total Cats: 2
Default

Cool. I'll give it a shot.


Did you know they sprinkled something addicting on the random picture thread?
tazswing is offline   Reply With Quote
Old 03-18-2015, 02:01 AM   #6
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

Just make sure your serial cable works with Mac. Anything with an ftdi chip will work. Google is your friend.

I've found the Mac version to be a bit buggy, not sure if that's OSX or just tuner studio.
aidandj is offline   Reply With Quote
Old 03-18-2015, 03:23 AM   #7
Elite Member
 
Chiburbian's Avatar
 
Join Date: Feb 2008
Location: Gilberts, IL
Posts: 2,159
Total Cats: 131
Default

Also, virtualdyno works on Mac if you buy/install codeweavers crossovers.
Chiburbian is offline   Reply With Quote
Old 03-18-2015, 01:28 PM   #8
Senior Member
iTrader: (3)
 
Join Date: Jul 2011
Location: STL
Posts: 528
Total Cats: 24
Default

TunerStudio works great in OSX, I've been running it for a few years now. My Macbook is incredibly old and slow so it's getting replaced with a Lenovo X201 running Linux Mint. If you don't want to bang up a $1k+ Macbook, there are lots of options in the $200 range if you don't mind a used corporate laptop.
midpack is offline   Reply With Quote
Old 03-18-2015, 01:38 PM   #9
Senior Member
iTrader: (1)
 
Join Date: Apr 2011
Location: Columbia, SC
Posts: 1,342
Total Cats: 78
Default

Java is pretty multi-platform friendly.
Schuyler is offline   Reply With Quote
Old 03-18-2015, 01:47 PM   #10
Elite Member
iTrader: (1)
 
Join Date: Jun 2014
Location: Austin, TX
Posts: 2,855
Total Cats: 272
Default

Quote:
Originally Posted by tazswing View Post
I live in a household of only Macs so I was wondering if I should try and make a MS2 and TunerStudioMS work with the Mac or just by a cheap PC-based laptop and dedicate it to the Miata.

Thanks.
Tuner slaves FS right here buddy

https://www.miataturbo.net/stuff-sal...o-slave-83102/

I just got mine fully up and running w/ some upgrades & new 9cell battery
Girz0r is offline   Reply With Quote
Old 03-18-2015, 02:22 PM   #11
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,780
Total Cats: 1,106
Default

I have been using my macbook to tune MS since about 2007. Back before TS was available I used bootcamp with Windows XP and MegaTune. Once TS came out I switched over to OS X for tuning. Occasionally there is some problems with Java that cause problems on closing TS, but other then that have not had issues. I use the built in USB port on my MS3X for the connection. I have tried bluetooth and the connection has never been as stable as I would like.
shuiend is offline   Reply With Quote
Old 03-18-2015, 03:39 PM   #12
Junior Member
Thread Starter
 
Join Date: Sep 2014
Location: Portland (left coast)
Posts: 214
Total Cats: 2
Default

Thanks for the great replies. I have seen many instances of the issue being cable related so I will watch that closely and give it a shot.

Girz0r, thanks for the link. I will keep that in mind.

Cheers!
tazswing is offline   Reply With Quote
Old 03-18-2015, 07:54 PM   #13
Elite Member
iTrader: (5)
 
Join Date: Oct 2007
Location: Canton, Ga
Posts: 1,707
Total Cats: 19
Default

I've ran it no problems on Mac Linux and windows
Stealth97 is offline   Reply With Quote
Old 03-19-2015, 05:36 AM   #14
Senior Member
 
Join Date: Nov 2007
Location: Belgium
Posts: 939
Total Cats: 59
Default

same here, no problems on my macbook air
WestfieldMX5 is offline   Reply With Quote
Old 03-21-2015, 08:37 PM   #15
Junior Member
Thread Starter
 
Join Date: Sep 2014
Location: Portland (left coast)
Posts: 214
Total Cats: 2
Default

Tuner Studio seems happy enough. But wtf about getting a usb to serial adaptor to work on Mac OSx? Just spend like an hour trying to get D2XX, etc. to load for the drivers. There has got to be an easier way...or someone who knows better than me.

Those who use Mac OSx, what are you using for a usb adaptor?
tazswing is offline   Reply With Quote
Old 03-21-2015, 08:42 PM   #16
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

You need an adapter with the right chip in it. Anything with an FTDI will work. This is the link I use:

http://www.ftdichip.com/Drivers/VCP.htm

Or this with the right cable:

http://plugable.com/2011/07/12/insta...er-on-mac-os-x

D2XX drivers are different than what you need.
aidandj is offline   Reply With Quote
Old 03-21-2015, 09:17 PM   #17
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,780
Total Cats: 1,106
Default

Quote:
Originally Posted by tazswing View Post
Tuner Studio seems happy enough. But wtf about getting a usb to serial adaptor to work on Mac OSx? Just spend like an hour trying to get D2XX, etc. to load for the drivers. There has got to be an easier way...or someone who knows better than me.

Those who use Mac OSx, what are you using for a usb adaptor?
I use the built in USB adapter on my MS3X. I have also used the usb to serial adapters that DIY sells with success in the past.
shuiend is offline   Reply With Quote
Old 03-21-2015, 10:51 PM   #18
Junior Member
Thread Starter
 
Join Date: Sep 2014
Location: Portland (left coast)
Posts: 214
Total Cats: 2
Default

Hey Taz, have you tired making sure your com port is changed, too on tuner studio to capture the newly installed driver?

No, I did not check that. I only installed the driver four times and changed nothing else.

Well then.


Thank you so much to aidandj for all your help with this driver issue!!

Last edited by tazswing; 03-22-2015 at 12:39 AM.
tazswing is offline   Reply With Quote
Old 03-21-2015, 11:31 PM   #19
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,999
Total Cats: 1,466
Default

Glad to help!
aidandj is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:45 AM.