Anyone in VA willing to try my Megasquirt? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 11-10-2008, 12:12 AM   #1
Guest
Thread Starter
iTrader: (6)
 
Join Date: Sep 2007
Location: Vaughan, On, Canada
Posts: 1,092
Total Cats: 0
Default Anyone in VA willing to try my Megasquirt?

Some of you may remember I thought my Megasquirt was dead!

https://www.miataturbo.net/forum/t26817/

I've sent it out to Peter Florence (Recommended by DIY) to be fixed and he can't find anything wrong. Anyone in the VA area with a running car willing to try out my Megasquirt in their car? The unit is running 10G.

Thanks!
M-Tuned is offline   Reply With Quote
Old 11-10-2008, 12:19 AM   #2
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Did you ever check to see if you were getting spark? I know you said it was dumping fuel. So likely lost spark then. Did all the gauges in megatune still work fine? Any RPM reading?
patsmx5 is offline   Reply With Quote
Old 11-10-2008, 12:27 AM   #3
Guest
Thread Starter
iTrader: (6)
 
Join Date: Sep 2007
Location: Vaughan, On, Canada
Posts: 1,092
Total Cats: 0
Default

Quote:
Originally Posted by patsmx5 View Post
Did you ever check to see if you were getting spark? I know you said it was dumping fuel. So likely lost spark then. Did all the gauges in megatune still work fine? Any RPM reading?
I honestly don't remember. I will have to ask Peter if spark looks good. He has it on a stim and all looks well..
M-Tuned is offline   Reply With Quote
Old 11-10-2008, 12:30 AM   #4
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,797
Total Cats: 248
Default

Yeah the stim won't tell you if the spark outputs are working. You'll have to put it on the car to test that. I'd suspect something in the spark outputs died. Who built this MS?

I'd suggest putting in on your car and getting a timing light and verifying spark on all 4 cylinders, as well as finding out if MS is seeing an RPM reading. If it's dumping fuel, then it's obviously seeing RPM, so spark outputs is about all it could be (as far as the MS is concerned, not to say that you didn't blow both coil packs simultaneously, loose wire, blown fuse, etc)
patsmx5 is offline   Reply With Quote
Old 11-10-2008, 12:43 AM   #5
Guest
Thread Starter
iTrader: (6)
 
Join Date: Sep 2007
Location: Vaughan, On, Canada
Posts: 1,092
Total Cats: 0
Default

Quote:
Originally Posted by patsmx5 View Post
Yeah the stim won't tell you if the spark outputs are working. You'll have to put it on the car to test that. I'd suspect something in the spark outputs died. Who built this MS?

I'd suggest putting in on your car and getting a timing light and verifying spark on all 4 cylinders, as well as finding out if MS is seeing an RPM reading. If it's dumping fuel, then it's obviously seeing RPM, so spark outputs is about all it could be (as far as the MS is concerned, not to say that you didn't blow both coil packs simultaneously, loose wire, blown fuse, etc)
Keep in mind the car works perfect on the stock ECU, so it must be a squirt issue. If I don't get anyone to test it I might try modifying my system to be spark only and try to get the car running that way.

Chad built the system for me.
M-Tuned is offline   Reply With Quote
Old 11-10-2008, 01:31 AM   #6
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

If you want me to test it I will. Just let me know. I can also go over the circuits I added to the MS. Either way I can verify if spark and fuel are both working correctly. It's a drop in affair in my car whereas it might not work in other peoples due to differences in harness construction.
cjernigan is offline   Reply With Quote
Old 11-10-2008, 01:43 AM   #7
Guest
Thread Starter
iTrader: (6)
 
Join Date: Sep 2007
Location: Vaughan, On, Canada
Posts: 1,092
Total Cats: 0
Default

You da MAN!
M-Tuned is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Any pnp megasquirt for 2001 Big_gumby WTB 0 09-30-2015 04:34 PM
1996 Turbo Build Goldwar DIY Turbo Discussion 2 09-29-2015 10:20 AM
First gen (white) megasquirt pnp 90-93 Miata firmware reflash Johnny Tater MSPNP 1 09-27-2015 01:38 AM
Megasquirt died mid operation psyber_0ptix MEGAsquirt 4 09-22-2015 10:35 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:22 AM.