EBC mod - Writeup - Page 3 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 08-08-2007, 03:05 PM   #41
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

Quote:
Originally Posted by Savington View Post
Braineack, how much re-tuning did you have to do to go from MBC to MS EBC? I ordered the bits from Jerry yesterday, so I have to start figuring out how to tune the car for them.
I can answer that, it wont change your fuel, timing, idle, or anything other than your boost levels. All you gotta do is figure out what duty cycle you need to make the same boost as you were doing before. You obviously need to make some minor adjustments if you wanna go up in boost.
akaryrye is offline   Reply With Quote
Old 08-08-2007, 03:05 PM   #42
Boost Czar
Thread Starter
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,814
Total Cats: 1,780
Default

Quote:
Originally Posted by Savington View Post
Braineack, how much re-tuning did you have to do to go from MBC to MS EBC? I ordered the bits from Jerry yesterday, so I have to start figuring out how to tune the car for them.
not much. I was lucky and tried 50% as my values, it put me right at 12psi...then I had a dip at exactly 5600RPM, so I just increased the % there a touch and then it held flat.

but what I liked for a final result was:



The valve is always closed when I'm trying to build boost, for max spoolup.

200RPM below that mark I set it at 100% again so it doesn't gradually open. Otherwise if I set 3800RPM to 42% in the next column, the valve would gradually open as I gave it revs, slowing spoolup.

Then RPM where I make the boost target I then set the DC.

The rest of the RPM columns is just to maintain the flatness.
Braineack is online now   Reply With Quote
Old 08-08-2007, 03:13 PM   #43
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,353
Total Cats: 1,322
Default

I assume you'll see faster spoolup, and you may have to richen up the VE values in the cells where the spool increased?
Savington is offline   Reply With Quote
Old 08-08-2007, 03:15 PM   #44
Boost Czar
Thread Starter
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,814
Total Cats: 1,780
Default

the difference was trival...i didnt change the fuel at all.
Braineack is online now   Reply With Quote
Old 08-08-2007, 04:39 PM   #45
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

ok this is really wierd ...
so after messing around for awhile in megatune, I on a whim decided to try changing it to simultaneous injection for whatever reason and the damn solenoid started clicking lol!? Now it will go any time the key is in the ON position, but not when the car is turned on. Solenoid is getting power as I tested just grounding out the pin to the chasis and sure enough, click click click. Anyway I think a reflash is in order
akaryrye is offline   Reply With Quote
Old 08-08-2007, 05:18 PM   #46
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

ok so still no luck, solenoid is clickin away when I have the key on but car is off. Turn the car on and it stops ... what gives? Is there a minimum wattage that the resistors must be to work?
akaryrye is offline   Reply With Quote
Old 08-08-2007, 05:21 PM   #47
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

key off, motor's at 100kpa
key on, it's at 30kpa.

start the car, pull vac tube off the ms, see if the ebc solenoid starts clickin around
Ben is offline   Reply With Quote
Old 08-08-2007, 05:27 PM   #48
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

so the code does not allow the boost control circut to work until kpa is at 100?
akaryrye is offline   Reply With Quote
Old 08-08-2007, 05:28 PM   #49
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

ok im gonna go out and just boost it around the block real quick and see if i hit the cutoff, i have the dutycycle set to 25 so if it works ill be around 8-12psi i guess.

ok ... just got yelled at by a neighbor lol, i gotta take my laptop this time though and see if anything changes, im thinking what was happening before was that the fet was grounding on the case and closing the valve, right now the fet is dangling in the air ... brb
akaryrye is offline   Reply With Quote
Old 08-08-2007, 05:35 PM   #50
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Quote:
Originally Posted by akaryrye View Post
so the code does not allow the boost control circut to work until kpa is at 100?
No, and I think that was bad advice anyway. I was trying to account for the differences between engine off and engine on.

But the open loop ebc works off of tps vs rpm. has nothing to do with map.
is your duty cycle table completely filled out, from 0%-100% thorttle position? rpm from 100-7500? (or whatever your limit is)
Ben is offline   Reply With Quote
Old 08-08-2007, 06:23 PM   #51
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

ok I guess it is working now and it was merely grounding against the case before. I just got back from a run and I cant get the damn thing to boost consistantly 15psi up to redline, and I suspect that my bosch bov is the culprit, so ill be on ebay tonight to find a replacement. I had my dutycycles at 95% at 5-7krpm and it would go to 15psi until around 5k and then drop to 12/13psi.
akaryrye is offline   Reply With Quote
Old 08-09-2007, 12:47 AM   #52
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,353
Total Cats: 1,322
Default

Akary, shoot me a PM. I have two good Bosch BOVs sitting in my garage.
Savington is offline   Reply With Quote
Old 08-12-2007, 12:46 PM   #53
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

Goddamnit ben! I swear you put up some closed loop boost control settings you wanted me to try and now they are gone, did you go back and delete them? I am ready to give closed loop boost a shot.
akaryrye is offline   Reply With Quote
Old 08-12-2007, 12:55 PM   #54
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

why are you godamming me? you're the one who can't use the search button
https://www.miataturbo.net/megasquirt-18/1-6-auto-tb-tps-10901/
Ben is offline   Reply With Quote
Old 08-12-2007, 01:25 PM   #55
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

I actually found it and was penning an edit, but got caught up changing some settings on my msq. Seems like there should be some way to adjust how the megasquirt acts in closed loop other than just a KPA value that I am ok with it yoyo'n about. Anyways, I have some time to tune some more today and I am hoping to get it so that from 0-50% TPS it will be pretty much wastegate and from 50% - 100% progressively adding boost from 9 - 14psi. And yeah Im hoping to get it working with closed loop
akaryrye is offline   Reply With Quote
Old 08-13-2007, 03:33 AM   #56
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,353
Total Cats: 1,322
Default

Guys, is there polarity on the connector itself, or can I hook either one up to 12v/the MS?
Savington is offline   Reply With Quote
Old 08-13-2007, 04:54 AM   #57
Elite Member
iTrader: (5)
 
akaryrye's Avatar
 
Join Date: Jul 2006
Location: Central California
Posts: 2,526
Total Cats: 0
Default

no idea, but I used the red wire on the gm pigtail for 12v
akaryrye is offline   Reply With Quote
Old 08-13-2007, 05:30 AM   #58
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,353
Total Cats: 1,322
Default

I built my own pigtail.

Also, here's a bunch of newbie questions. :gay:

1. By hooking up the solenoid to the ECU, I assume it will start automatically attempting to control the boost, or at least the attempts itís been trying to make the entire time wonít be in vain this time. Since the Closed look kpa limit (Advanced > Boost Control) is set at 20, according to the little note there the ECU will automatically use the duty targets vs. the kpa targets.
2. I set the Overboost protection to 210kpa, up from its previous 156kpa. I assume it was freaking out the entire time, but it just didnít have the control over the boost to do anything about it. The maximum Iíve ever seen is 196kpa, and Iím aiming to match that with the EBC, so 210 should give me just enough room to see small spikes without having the ECU shut everything down all the time.
3. I rescaled the duty table TPS percentages to match the zero/WOT settings my TPS is giving to the Megasquirt. (closed throttle = 9%, WOT = 75%) Whatís the theory behind the values that go into the duty cycle table? Ben looks like he has his set up like the MS default, going 20-30-40-50-70-90. At the same time, I donít think it matters, since the duty targets are the same down the columns on Benís table (below).
4. Iím going to start with the RPM columns that Ben used and just set the 500rpm column to 0%, and the rest of them to the same value to start with (50% to start, might have to go lower).
Savington is offline   Reply With Quote
Old 08-13-2007, 06:58 AM   #59
Elite Member
iTrader: (5)
 
Atlanta93LE's Avatar
 
Join Date: Sep 2006
Location: Marietta, GA
Posts: 2,198
Total Cats: 1
Default

Quote:
Originally Posted by Savington View Post
1. By hooking up the solenoid to the ECU, I assume it will start automatically attempting to control the boost, or at least the attempts itís been trying to make the entire time wonít be in vain this time. Since the Closed look kpa limit (Advanced > Boost Control) is set at 20, according to the little note there the ECU will automatically use the duty targets vs. the kpa targets.
The closed loop kpa simply tells the MS at what point to give up; if the difference between boost from duty cycle and boost target is greater than the closed loop kpa limit, then it will stay open loop.
Quote:
Originally Posted by Savington View Post
2. I set the Overboost protection to 210kpa, up from its previous 156kpa. I assume it was freaking out the entire time, but it just didnít have the control over the boost to do anything about it. The maximum Iíve ever seen is 196kpa, and Iím aiming to match that with the EBC, so 210 should give me just enough room to see small spikes without having the ECU shut everything down all the time.
Overboost protection doesn't need boost control to be functional to work. It's like a rev-limiter (I think it cuts fuel) if the boost ventures beyond the protection limit. At least that's how mine has been working.
Quote:
Originally Posted by Savington View Post
3. I rescaled the duty table TPS percentages to match the zero/WOT settings my TPS is giving to the Megasquirt. (closed throttle = 9%, WOT = 75%) Whatís the theory behind the values that go into the duty cycle table? Ben looks like he has his set up like the MS default, going 20-30-40-50-70-90. At the same time, I donít think it matters, since the duty targets are the same down the columns on Benís table (below).
Not sure why your range is 9-75%...did you calibrate the TPS to find the TPS ADC ranges? If you did, MS should calibrate itself to TPS being 0-100%.
Atlanta93LE is offline   Reply With Quote
Old 08-13-2007, 02:29 PM   #60
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,353
Total Cats: 1,322
Default

My range is 9-75 because I never bothered calibrating it. The overboost thing is interesting, since I've been running 196kpa for a month now with the overboost set at 156kpa.

The closed loop KPA is used when you're using the KPA targets, right? If I'm not using those, I don't need to worry about the closed loop KPA limit?

How are you guys telling the MS to use the duty cycle targets vs. the KPA targets then?
Savington is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
VR6 to Miata Swap ScrapinMX5 Meet and Greet 8 09-28-2015 02:04 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:32 AM.