Finally got a MS3x - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 09-24-2014, 07:07 PM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default Finally got a MS3x

OK, so. I bought one with a harness, boost solenoid and a VTPS.

As far as installation, I know it's different than the MSPNP. The harness will just hook up to the MS3x and the stock harness, correct?

Give me some ideas for where to mount this. Glove box a good location?

Can someone load me a file they have that I can use to get the car started or can I download it somewhere?

The boost solenoid, EBC Electronic Boost Control Solenoid Kit DIYAutoTune.com says to just put it between the boost source and the wastegate? Boost source needs to be closest to TB right?

The wiring for the VTPS. Wiring Up Auto (Variable) Tps - Forced Induction & N/A Power Mods - MX5Nutz Forum Correct or not?

I'm sure I will have more once I get it here in my hands. Thanks for any help.
whinin is offline   Reply With Quote
Old 09-25-2014, 04:07 PM   #2
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Ok so scratch the VTPS wiring, guy shipped me an already made one!

Also the wiring, I see how it works now that I have it here.

Would a base file for the mspnp work on the ms3x?
whinin is offline   Reply With Quote
Old 09-25-2014, 08:33 PM   #3
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Ok so I'm reading all this crap about the ms3x

http://www.msextra.com/doc/pdf/MS3XV30_Hardware-1.3.pdf

All of this is already wired correctly with a Braineack build ms3x right?

I should be able to just install the box, hook it up, load a default tune, and start tuning?
whinin is offline   Reply With Quote
Old 09-27-2014, 08:15 PM   #4
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Halp.

I'm reading the ms3x has a basemap loaded on it. But I bought this 2nd hand. Does anyone have a map they could send me?
1.6l
greddy kit
no cat
550cc injectors

or even a basemap (I can't seem to find it) for a 1.6l afm-less.

Thanks for any help.
whinin is offline   Reply With Quote
Old 10-01-2014, 02:36 PM   #5
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

With the 1.6 harness does the MS3x use the same ground (sensor gnd) as the stock ecu? I believe the answer is yes but I can't find a definite answer. Just want to make sure so I can keep my wideband ground with it.

Some pictures to hopefully get some help.






Attached Thumbnails
Finally got a MS3x-cat_halp.jpg  
whinin is offline   Reply With Quote
Old 10-01-2014, 07:31 PM   #6
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Can't get tunerstudio to connect.

Followed the msextra topic. Get to the part where you portcheck and it doesn't recognize the ms3x. Any help? I've tried different COM's, I'm using a USB cable.
whinin is offline   Reply With Quote
Old 10-01-2014, 11:23 PM   #7
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,997
Total Cats: 1,463
Default

Quote:
Originally Posted by whinin View Post
Can't get tunerstudio to connect.

Followed the msextra topic. Get to the part where you portcheck and it doesn't recognize the ms3x. Any help? I've tried different COM's, I'm using a USB cable.
Do you see the com port in Device Manager?
aidandj is offline   Reply With Quote
Old 10-02-2014, 08:13 PM   #8
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Yes. It shows COM1 USB under ports in Device Manager.
whinin is offline   Reply With Quote
Old 10-03-2014, 08:31 PM   #9
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Tried on another laptop, still no go.

Anyway I can check to see if the MS3x is getting power? Should there be lights on somewhere?
whinin is offline   Reply With Quote
Old 10-04-2014, 05:39 PM   #10
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Tried a $25 serial to usb cable, still no luck.

I took the case off the ms3x and snapped some pictures. I'm not much of an electrical guy but I didn't see anything fried. I tried to get most of the capacitors/resistors in these shots.











Any help is appreciated. I have tried looking for posts related to this problem but none of them have helped.
whinin is offline   Reply With Quote
Old 10-04-2014, 06:03 PM   #11
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

I don't know if this helps either.





This is supposed to be for a 1.6L
whinin is offline   Reply With Quote
Old 10-04-2014, 06:13 PM   #12
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,997
Total Cats: 1,463
Default

Can you post a screenshot of device manager? Are you sure you got the drivers?
aidandj is offline   Reply With Quote
Old 10-04-2014, 06:19 PM   #13
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

whinin is offline   Reply With Quote
Old 10-04-2014, 06:20 PM   #14
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

Drivers are from FTDI most up to date from Virtual COM Port Drivers
whinin is offline   Reply With Quote
Old 10-04-2014, 06:21 PM   #15
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,997
Total Cats: 1,463
Default

Do you have a multimeter?
aidandj is offline   Reply With Quote
Old 10-04-2014, 06:22 PM   #16
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,997
Total Cats: 1,463
Default

Have you tried a USB cable? Connected to the MS3?
aidandj is offline   Reply With Quote
Old 10-04-2014, 06:24 PM   #17
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,997
Total Cats: 1,463
Default

Also what USB to serial converter are you using.
aidandj is offline   Reply With Quote
Old 10-04-2014, 06:25 PM   #18
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

I have tried a USB cable and a serial to USB on two different laptops.

I do have a multimeter, though still newbish with it.
whinin is offline   Reply With Quote
Old 10-04-2014, 06:25 PM   #19
Junior Member
Thread Starter
 
Join Date: Apr 2013
Location: Elgin, SC
Posts: 359
Total Cats: -4
Default

The one from Radio Shack. Gigaware.
whinin is offline   Reply With Quote
Old 10-04-2014, 06:26 PM   #20
SADFab Destructive Testing Engineer
iTrader: (5)
 
aidandj's Avatar
 
Join Date: Apr 2014
Location: Beaverton, USA
Posts: 17,997
Total Cats: 1,463
Default

Think you could figure out how to do step 24 on this guide?http://www.msextra.com/doc/ms3/build_manual.html
aidandj is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Toxikk Girz0r Gaming 23 01-18-2017 01:02 PM
An Old Driver but a newbie in Miata Patriarca Meet and Greet 17 10-13-2015 02:34 PM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
The "other" spool question stefanst DIY Turbo Discussion 44 09-28-2015 08:16 PM
ME221 Now has Autotune and Long Term Fuel Trim Tables Motorsport-Electronics ECUs and Tuning 0 09-05-2015 09:02 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:43 AM.