Intake backfire? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 06-24-2009, 11:39 AM   #1
Junior Member
Thread Starter
 
Join Date: Mar 2008
Location: GJ, CO
Posts: 224
Total Cats: 0
Default Intake backfire?

After the car has been sitting outside in the heat all day, I get in and turn the key to "on" I get an intake backfire. Doesn't really harm anything, just pops the boost gauge line off of it's vacuum tee and I have to put it back on. It was mentioned to me by someone here that a leaky injector could cause it to do that? I just want to make sure it's not something with the MS.
GT3man2001 is offline   Reply With Quote
Old 06-24-2009, 11:44 AM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

It has to do with how the megasquirt handles the coils. Look for joe's "a better spark output" thread, he explains it well.

basically, your coils let out a spark when you went to key on and you ignited some unburnt gas that was still in the cylinders.
Braineack is offline   Reply With Quote
Old 06-24-2009, 12:54 PM   #3
Junior Member
Thread Starter
 
Join Date: Mar 2008
Location: GJ, CO
Posts: 224
Total Cats: 0
Default

Thanks for the info. Weird that it does it only when it's warm outside.
GT3man2001 is offline   Reply With Quote
Old 06-24-2009, 11:56 PM   #4
Junior Member
 
Join Date: Jan 2006
Location: Toronto
Posts: 182
Total Cats: 0
Default

Quote:
Originally Posted by GT3man2001 View Post
Thanks for the info. Weird that it does it only when it's warm outside.
Not really, fuel stays vaporized better in hot air.
fluke is offline   Reply With Quote
Old 06-25-2009, 02:16 PM   #5
Elite Member
iTrader: (8)
 
Join Date: Aug 2007
Location: Bellingham, Wa
Posts: 2,732
Total Cats: 3
Default

This happens to me 83.49% of the time I turn my key to start my car. I'm going to do Joe's new spark out mod, but i'm concerned that I need to fix whichever injector is doing this. Sometimes it's bad enough to foul a plug and make it difficult to start the car/keep it running.
wayne_curr is offline   Reply With Quote
Old 06-25-2009, 02:45 PM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

do you have a tps wired up? you can always try flood clear after you shut the car down, see if it really is a leaky injector....
Braineack is offline   Reply With Quote
Old 06-25-2009, 03:08 PM   #7
Elite Member
iTrader: (8)
 
Join Date: Aug 2007
Location: Bellingham, Wa
Posts: 2,732
Total Cats: 3
Default

Quote:
Originally Posted by Braineack View Post
do you have a tps wired up? you can always try flood clear after you shut the car down, see if it really is a leaky injector....
Yea I do, good idea. I'll give this a shot. I've tried revving the engine to 2k before shutting down but cant tell if its helped or not. I'll set up flood clear tonight, need to do some other MS stuff anyway.
wayne_curr is offline   Reply With Quote
Old 06-25-2009, 03:38 PM   #8
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,440
Total Cats: 198
Default

Weird, I never had this problem with the MS1.

Jim
Reverant is offline   Reply With Quote
Old 06-25-2009, 03:46 PM   #9
Elite Member
iTrader: (8)
 
Join Date: Aug 2007
Location: Bellingham, Wa
Posts: 2,732
Total Cats: 3
Default

Quote:
Originally Posted by Reverant View Post
Weird, I never had this problem with the MS1.

Jim
Lots of people never have. Seems most commonly its happening to those of us running RX7 550s. I want to figure out what the problem is before changing my spark out mod. The new mod will get rid of the pop, but if i'm still leaking fuel into the cyls. I wanna know as its still going to be fouling plugs now and then.
wayne_curr is offline   Reply With Quote
Old 06-25-2009, 04:37 PM   #10
Junior Member
 
Join Date: Jan 2006
Location: Toronto
Posts: 182
Total Cats: 0
Default

I'm running 450s, and only backfire after a failed start. I had my injectors cleaned at RC before the build also.

It sounds like you're leaking fuel, there shouldn't be enough fuel in the intact tract to backfire unless they are. I would have them cleaned (well, let RC do it.)
fluke is offline   Reply With Quote
Old 06-25-2009, 04:39 PM   #11
Junior Member
Thread Starter
 
Join Date: Mar 2008
Location: GJ, CO
Posts: 224
Total Cats: 0
Default

The new owner of the car knows about it, and he is going to try and find a solution. I have officially parked the car until the transport comes to pick it up. Thanks for the info guys.
GT3man2001 is offline   Reply With Quote
Old 06-25-2009, 04:58 PM   #12
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,860
Total Cats: 1,788
Default

The solution is Joe's spark output.
Braineack is offline   Reply With Quote
Old 06-25-2009, 05:33 PM   #13
Elite Member
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,658
Total Cats: 39
Default

Quote:
Originally Posted by Braineack View Post
The solution is Joe's spark output.
True dat. I have RX7 500's and whilst I wasn't exactly plagued by the issue, it certainly reared it's head at least once a week. made the car a bitch to start and idle until the superheated air had been run through the system.

Joe's output mod solved it. (I'm sure if my tune was 100% rather than it#s ever present 90% it'd have been an even rarer occourance).
richyvrlimited is offline   Reply With Quote
Old 06-25-2009, 07:16 PM   #14
Junior Member
Thread Starter
 
Join Date: Mar 2008
Location: GJ, CO
Posts: 224
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
The solution is Joe's spark output.
I'll let him know.
GT3man2001 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 Yesterday 10:04 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Moroso Air Oil Separator Catch Can Aroundcorner Miata parts for sale/trade 2 10-01-2015 04:20 PM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:12 AM.