MS2 EBC sort of working - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 06-11-2011, 11:55 AM   #1
Junior Member
Thread Starter
 
Join Date: Jun 2008
Location: New Forest, U.K.
Posts: 336
Total Cats: 4
Default MS2 EBC sort of working

Now that I have the MS2 up and running smoothly (with the idle valve unplugged but that is a whole other problem) I have spent a bit of time trying to set up the EBC. it is sort of working, but I thought you guys (looking your way brain) would be able to shed some light on the issues that remain.

It is wired inside the MS as per the diy writup on this forum. I can set it to open loop and it sits at 14psi just fine. I have been setting the wole duty cycle table to the same figure as I am not really planning to use it long term and just wanted to make sure it was working. With polarity set to normal 20 gives 14psi and 40 bounces off the OBP limit. SO flipped it to inverted and set at 80. I get 14 again.

Then switched to Closed loop with the pid gain set to 150 and it bounces off the OBP limiter again, Bumped the gain up to 185, and eventually 200 and it calmed down a bit. Lots of oscillation coming up to boost and then hits the limiter again. All the tuning guides I have read say that 150 should be plenty so is there something wrong here? This is with the valve that diyautotune sells and the freq set to 19.5 Hz. Wired with the output from the MS, going thru a 3 amp micro toggle, then out to the valve. The other side of the valve wired to the 12v source at the blue plug behind the L/F headlight. and the diode at the valve as per the writup here.

All that sound right? anything I am missing? or should my 1st PID gain box really be 200+?
Blaize is offline   Reply With Quote
Old 06-11-2011, 07:50 PM   #2
Senior Member
iTrader: (8)
 
Join Date: Jun 2010
Location: Navarre, FL
Posts: 1,127
Total Cats: 39
Default

what firmware version?
aaronc7 is offline   Reply With Quote
Old 06-11-2011, 07:53 PM   #3
Junior Member
Thread Starter
 
Join Date: Jun 2008
Location: New Forest, U.K.
Posts: 336
Total Cats: 4
Default

Ms2extra serial310
Blaize is offline   Reply With Quote
Old 06-14-2011, 03:52 AM   #4
Junior Member
Thread Starter
 
Join Date: Jun 2008
Location: New Forest, U.K.
Posts: 336
Total Cats: 4
Default

Alright looks like I am the first person this has happened too. Anyone want to share their settings. I just wonder if I am in the right ball park as far as frequency for this valve.
Blaize is offline   Reply With Quote
Old 06-14-2011, 08:28 AM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

you sure it's plumbed correctly?
Braineack is offline   Reply With Quote
Old 06-14-2011, 09:14 AM   #6
Junior Member
Thread Starter
 
Join Date: Jun 2008
Location: New Forest, U.K.
Posts: 336
Total Cats: 4
Default

Pretty sure I did. Have a look. Hose from the left is the signal feed.

Name:  8d313d57.jpg
Views: 7
Size:  88.4 KB
Blaize is offline   Reply With Quote
Old 06-14-2011, 09:22 AM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

sounds and looks you you have it correct.

you have you wastegate duty open at 100 and closed at 0 with te polarity set to inverted?

what is the code doing with the duty cycle? Are your closed loop targets tuned? With a 200 P, the code should be keeping the duty fully clamped, no boost entering the wastegate, and as it nears it should fully open going straight to wastegate. As you lower P it should start reaching the boost target.
Braineack is offline   Reply With Quote
Old 06-14-2011, 08:13 PM   #8
Junior Member
Thread Starter
 
Join Date: Jun 2008
Location: New Forest, U.K.
Posts: 336
Total Cats: 4
Default

here is what I have now. This worked pretty good and sits right at 14 psi. Drop the dc to 60 and it hits the limiter.


Name:  openloop.jpg
Views: 6
Size:  79.8 KB


This however is borderline useless. The boost comes up to around 12 psi, then oscillates up and down 1 psi, creeping higher each time, and hits the OBP limiter about the 5th time. the higher I set the P Gain, the more controlled it gets but at 200 I figured something was wrong and stopped playing with it.

Name:  closedloop.jpg
Views: 6
Size:  83.5 KB
Blaize is offline   Reply With Quote
Old 06-14-2011, 08:39 PM   #9
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

it'll never work with closed at 100 and open at 0.
Braineack is offline   Reply With Quote
Old 06-15-2011, 10:11 AM   #10
Junior Member
Thread Starter
 
Join Date: Jun 2008
Location: New Forest, U.K.
Posts: 336
Total Cats: 4
Default

Ah, I think I changed that to get the duty cycle vs boost relationship correct as per the ma2exta manual writeup. But to be honest I don't remember. I'll flip it back around and try again in a couple if days (its raining now so can't test today). Thanks man.
Blaize is offline   Reply With Quote
Old 06-15-2011, 10:42 AM   #11
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

The open/closed duty cycle is in relation to the wastegate, note the ebc.

With that said, closed must be lower than open...so that's why you can change the polairty.
Braineack is offline   Reply With Quote
Old 06-15-2011, 11:36 AM   #12
Senior Member
 
Join Date: Nov 2007
Location: Belgium
Posts: 939
Total Cats: 59
Default

Is the valve fubar if you remove that red plastic cap (cough)?
WestfieldMX5 is offline   Reply With Quote
Old 06-21-2011, 07:25 PM   #13
Junior Member
Thread Starter
 
Join Date: Jun 2008
Location: New Forest, U.K.
Posts: 336
Total Cats: 4
Default

Changed it and still no joy. Made pretty much no difference. Just came across somthing on another thread regarding the tps. I have a real one in there, Variable, does that make any difference? is that what the closed and open duty cycle values are relating to?
Blaize is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:52 AM.