MS2 Tach In Confusion - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 08-26-2013, 09:20 PM   #1
Newb
Thread Starter
iTrader: (1)
 
Join Date: Jun 2012
Posts: 34
Total Cats: 1
Default MS2 Tach In Confusion

I'm having a hard time getting a proper tach signal on my ms2. It was built using Frank Westfield's writeup (which as recently been pulled, although I was able to grab the text from google's cache).

Currently my primary tach in is wired to pin 4F camshaft SGT and the secondary is wired to pin 4G camshaft SGC on my '96 miata as per another wiring diagram that I found. I'm a little confused if they should be wired to the crank angle sensor or the cam angle sensor. They're both commonly referred to as CAS, and I've seen instructions for using both. In Frank's build, it says that the crank goes to pin 24 and the cam goes to pin 25 (I built a second opto circuit instead of the simple pullup). I just don't know if I want SGT or SGC or CMP or CKP, or which crank pins on the ECU are which.

Right now my RPM bounces between 0 and around 150, So I have a feeling that I'm not using the correct input...
MrMojo is offline   Reply With Quote
Old 08-30-2013, 01:41 PM   #2
Newb
Thread Starter
iTrader: (1)
 
Join Date: Jun 2012
Posts: 34
Total Cats: 1
Default

Got it figured out. I was connected to the correct pins, I didn't realize the second sensor was just for OBDII and didn't come on earlier NA8's. The bouncing was just noise, I replaced the wires with shielded ones and the car started right up.
MrMojo is offline   Reply With Quote
Old 08-30-2013, 02:15 PM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,831
Total Cats: 1,786
Default

Quote:
Originally Posted by MrMojo View Post
Got it figured out. I was connected to the correct pins, I didn't realize the second sensor was just for OBDII and didn't come on earlier NA8's. The bouncing was just noise, I replaced the wires with shielded ones and the car started right up.
huh? there's a cmp and cmk signal on all miatas from 90-13
Braineack is online now   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM
mslabs MS2 - Idle control issue ndragun MEGAsquirt 0 09-20-2015 11:28 PM
how to Make 94-95 tach work with MSPNP2 JacksonRacingEngines Engine Performance 10 09-10-2015 10:52 AM
Sold fail wagon Miata parts for sale/trade 2 09-07-2015 09:51 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:04 PM.