MS3 & MS3X - 99% Ready to install. Help me ensure I don't screw up. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 02-08-2012, 01:56 AM   #1
Newb
Thread Starter
iTrader: (1)
 
Join Date: Mar 2011
Location: San Diego
Posts: 43
Total Cats: 1
Default MS3 & MS3X - 99% Ready to install. Help me ensure I don't screw up.

I'm so close I can taste it. My board is built, JimStim shows everything I can test works, and I have my tune based on the MSPNP tune for my car. I have a couple of questions though.

1) I can't find any settings in TS for the MS3X Tacho output (pin 26). Any necessary action here?

2)I was going to wait and tackle A/C stuff later, but since I can't install the MS until next week, I figured I'd get a head start. Here is how I have it wired:

MS3X
1j Blu/Wht -- A/C Relay Output ---- Nitrous 2 (Pin 25)
1l Blu/Wht -- Cooling Fan ---- Nitrous 1 (Pin 24)

MS3
2s Blu/Wht -- A/C Condensor Fan Relay ---- Inj G (Pin 1)

In TS (under A/C Idleup) I have Idleup Output = Nitrous 2 and Idleup Input = Nitrous In. I don't really know what to do with the A/C condenser fan relay (Inj G). I probably have this ---- all backwards so I'd appreciate some help straightening it out .


If anyone is crazy bored or interested I have attached the msq I intend to use for the first start. I'd appreciate any feedback or concerns. Thanks dudes.
Attached Files
File Type: msq 20120207_stock_94.msq (138.8 KB, 68 views)
stucky is offline   Reply With Quote
Old 02-08-2012, 01:59 AM   #2
Newb
Thread Starter
iTrader: (1)
 
Join Date: Mar 2011
Location: San Diego
Posts: 43
Total Cats: 1
Default

Also, if you do look at the msq you'll note I have it set up for narrow band. I have a LC-1, but I'd like to get the MS installed before tackling the WB. Any compelling reason to tackle the LC-1 at the same time as the MS?
stucky is offline   Reply With Quote
Old 02-08-2012, 12:45 PM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

Quote:
Originally Posted by stucky View Post
1) I can't find any settings in TS for the MS3X Tacho output (pin 26). Any necessary action here?
It's there. select Tachout.


And to be clear:

Quote:
MS3X
A/C Relay Output (1J) --> Nitrous 2 (Pin 25)
Cooling Fan (1I) --> Nitrous 1 (Pin 24)
A/C Condensor Fan Relay (2S) --> MS input??? --> MS3X Inj G (Pin 1)

What you need is:

A/C Switch ground ---> MS INPUT
MS OUTPUT ---> A/C Compressor and relay
Braineack is offline   Reply With Quote
Old 02-08-2012, 01:08 PM   #4
Newb
Thread Starter
iTrader: (1)
 
Join Date: Mar 2011
Location: San Diego
Posts: 43
Total Cats: 1
Default

Ah yes Brain. Tacho was right in front of me.

As for the A/C I posted the wrong pin in my original post. 1l the cooling fan was supposed to be 1q, the A/C switch. I copied the wrong cells from my Excel sheet.

I am clear on having 1q (A/C switch input) as the MS input. Makes sense, and I don't have to jump 1q and 1j. My confusion is with 1j (A/C Relay out) and 2S (A/C condenser fan relay). Sounds like they should be jumped and set to the MS output. I have read through the A/C FAQ and I guess my confusion was with the difference between using the MSX and the method listed in the FAQ.
stucky is offline   Reply With Quote
Old 02-08-2012, 01:50 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

Basically, a/c switch goes into the MS. When you activate the button, the MS says, "holy ----! Jigga must be hot in here." It then proceedes to bump up your idle speed based on your parameters. Then the MS is all like, "Here B, I got this ---- for you!" and activates the compressor & a/c fan.

When you jump the two pins, you're basically bypassing the MS function of bumping up the idle.
Braineack is offline   Reply With Quote
Old 02-08-2012, 02:47 PM   #6
Newb
Thread Starter
iTrader: (1)
 
Join Date: Mar 2011
Location: San Diego
Posts: 43
Total Cats: 1
Default

Best A/C explanation ever... bringing back Jigga.

Your saying jumping 1q and 1j bypasses the MS function of bumping up the idle. To be clear I still need to jump 1j and 2s. This sinks both the A/C relay for the magnetic clutch and the condenser fan relay (when it is gettin hot in hur).
stucky is offline   Reply With Quote
Old 02-08-2012, 02:55 PM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

Correct. 1Q will go into the MS for the A/C Idle Up Input.

1J and 2S (a/c fan & compressor relays) can be on the same a/c idle up output.


I can't remember if MS3 allows the option for a seperately controlled a/c fan...I don't have the option, but I've always just tied 1J and 2S together on the DIYPNPs.
Braineack is offline   Reply With Quote
Old 02-25-2012, 10:00 PM   #8
Newb
Thread Starter
iTrader: (1)
 
Join Date: Mar 2011
Location: San Diego
Posts: 43
Total Cats: 1
Default

Naturally, I need the forum's help again. I have my MS3/MSX installed and the car idles! It was a great relief when it started right up, and quite satisfying. I know dick squat about tuning so I'm trying to read as much as I can. It is very annoying switching back to the OEM ECU whenever I actually have to drive the car. Anyway, on with the questions:

1) Why can I not hit my target AFR at idle? The car is warmed up and no enrichments should be taking effect. No IAT heat soak either. FYI this is the DIYPNP tune.



2) For tuning I am following these links:
MegaManual Tuning
MS Tuning Basics
MSExtra Idle Tuning

Do you have any recommendations as far as order of operations with tuning (really any tuning recommendations at all)? Do I start with idle, then move to fuel, then VE, then spark? I have no idea. I am planning on getting VE Analyzer Live considering I'm such a . I'd also love to meet up with anyone in SD who is willing to hold my hand through some basics. Beer would be on me obviously.


-Mike
Attached Thumbnails
MS3 & MS3X - 99% Ready to install.  Help me ensure I don't screw up.-lean_afr.png  
Attached Files
File Type: msq 20120224_stock94_LC1.msq (138.8 KB, 58 views)
File Type: msl 2012-02-24_14.07.52.msl (140.9 KB, 47 views)
stucky is offline   Reply With Quote
Old 02-26-2012, 01:22 PM   #9
Junior Member
 
Join Date: Feb 2011
Posts: 51
Total Cats: 2
Default

Have you adjusted the cells in your VE table's idle region? Highlight a square around where you're idling and bring them down until you're idling at your target AFR. If you just opened and are running the DIYPNP basemap, it should get you up and running but the VE table is not going to be perfectly suited to your car by any means. You will have to manually adjust it or have VE Analyze adjust it.

I am also a n00b but I think I sorta have the basics down. I would recommend paying for the full versions of TunerStudioMS and MegaLogViewer. I think MLV used to be free but now the designer's started to lock features out in the lite version.

Simplest thing to do is tweak the cells in your idle region manually, make sure Accel Enrichment is turned off and Overrun Fuel Cut is turned off. Set a custom filter in VE Analyze Live for minimum RPM 1100 or so to make sure it doesn't change the idle cells you've set up manually. Then go drive around.

*edited to add content

Last edited by QWKDTSN; 02-26-2012 at 01:33 PM.
QWKDTSN is offline   Reply With Quote
Old 02-26-2012, 01:24 PM   #10
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

you shouldn't be running EGO at idle, so why would it just magically hit your AFR targets if you didnt reduce teh fuel in your VE fuel table 1 where you are idling at?
Braineack is offline   Reply With Quote
Old 02-26-2012, 01:28 PM   #11
Newb
Thread Starter
iTrader: (1)
 
Join Date: Mar 2011
Location: San Diego
Posts: 43
Total Cats: 1
Default

Ah now I understand. I didn't have a firm grasp on the VE table, so I didn't mess with it. I knew the equation, but was simply looking at my AFR table. I also didn't realize that the EGO control isn't active below a set RPM (for me 1300 rpm).

From the Megamanual: "You want to change the VE table entries while watching the engine MAP (in kPa) to try and lower the MAP as much as possible."

Thanks.
stucky is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Noob to Miataturbo from MA JxPhan Meet and Greet 3 10-02-2015 03:17 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:55 AM.