MSPNP HighRes firmware images - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-05-2008, 03:45 AM   #1
Senior Member
Thread Starter
 
Join Date: Dec 2004
Location: Brisbane, Australia
Posts: 1,272
Total Cats: 32
Default MSPNP HighRes firmware images

For those interested in upgrading their MSPNP to HighRes but don't want to have to mess with EasyTherm, I have created firmware images that have been modified to suit the MSPNP. The page covers 90-95 and includes firmware images for setups with and without the AFM/MAF:

HighRes firmware images for MSPNP

It is hosted on another site where I can easily make changes if needed for newer versions. On here I can't seem to edit my posts after the thread gets replies.

Hope this helps someone!

Cheers
timk is offline   Reply With Quote
Old 03-05-2008, 08:08 AM   #2
Junior Member
 
Join Date: Jan 2007
Posts: 188
Total Cats: 0
Default

Cool, just did this. You might want to add the capacitor mod as mine had the tach drop out without it.
richard_ha is offline   Reply With Quote
Old 03-05-2008, 10:03 AM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,854
Total Cats: 1,788
Default

it would have been really thoughtful to include the therm files so the temperatures are outputted correct on your tuning laptop.....because one still has to "mess" with easytherm to both create them and/or upload the firmware.
Braineack is offline   Reply With Quote
Old 03-05-2008, 06:15 PM   #4
Senior Member
Thread Starter
 
Join Date: Dec 2004
Location: Brisbane, Australia
Posts: 1,272
Total Cats: 32
Default

It would have been really thoughtful if you had read the Flashing a MegaSquirt PNP to the HighRes firmware which is linked at the bottom of the page. If you follow this, you will re-use all your old project files (including the .inc files and download-firmware.bat) which are identical to the ones packaged with HighRes.

I thought this would be advantageous so people could still follow the documented way to reflash their firmware. You won't need EasyTherm, at all.

Cheers
timk is offline   Reply With Quote
Old 03-05-2008, 07:47 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,854
Total Cats: 1,788
Default

ah gotcha, missed the whole PNP thing
Braineack is offline   Reply With Quote
Old 03-05-2008, 09:27 PM   #6
Elite Member
iTrader: (5)
 
Atlanta93LE's Avatar
 
Join Date: Sep 2006
Location: Marietta, GA
Posts: 2,198
Total Cats: 1
Default

I'll definitely try this out when I get a moment with the car. Thanks!
Atlanta93LE is offline   Reply With Quote
Old 03-15-2008, 06:27 PM   #7
Newb
 
Join Date: Sep 2007
Posts: 13
Total Cats: 0
Default

shouldn't these zips have the msns-extra.ini file in (not the megatune.ini file)
???
Very useful none-the-less !!!
smifta is offline   Reply With Quote
Old 03-16-2008, 03:00 AM   #8
Senior Member
Thread Starter
 
Join Date: Dec 2004
Location: Brisbane, Australia
Posts: 1,272
Total Cats: 32
Default

Quote:
Originally Posted by smifta View Post
shouldn't these zips have the msns-extra.ini file in (not the megatune.ini file)
Absolutely, thanks for the heads up! I will fix this in the next few days.

Cheers
timk is offline   Reply With Quote
Old 04-01-2008, 04:51 AM   #9
Senior Member
Thread Starter
 
Join Date: Dec 2004
Location: Brisbane, Australia
Posts: 1,272
Total Cats: 32
Default

Thanks again smifta, I've now fixed all the downloads.
timk is offline   Reply With Quote
Old 04-12-2008, 07:05 PM   #10
Elite Member
iTrader: (5)
 
Atlanta93LE's Avatar
 
Join Date: Sep 2006
Location: Marietta, GA
Posts: 2,198
Total Cats: 1
Default

Thanks for the firmware images, worked great. One thing: the BoostDC gauge went missing in MegaTune with the new files. I followed this thread to fix it. You might want to make the change in the downloadable files. Thanks!
Atlanta93LE is offline   Reply With Quote
Old 04-12-2008, 10:28 PM   #11
Senior Member
iTrader: (5)
 
Join Date: Nov 2007
Location: Troy, MI
Posts: 860
Total Cats: 13
Default

I have a regular v3 board with Braineack's mods and I'm running 029y4 successfully right now. Any hardware changes that i should be doing to use the HR10g code?
The_Pipefather is offline   Reply With Quote
Old 04-12-2008, 10:39 PM   #12
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

No mods needed to run 10G, just reflash.
cjernigan is offline   Reply With Quote
Old 04-12-2008, 11:14 PM   #13
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Quote:
Originally Posted by Atlanta93LE View Post
Thanks for the firmware images, worked great. One thing: the BoostDC gauge went missing in MegaTune with the new files. I followed this thread to fix it. You might want to make the change in the downloadable files. Thanks!
Ben, did you add the cap filter? If not, any issues? Thx
Ben is offline   Reply With Quote
Old 04-12-2008, 11:20 PM   #14
Elite Member
iTrader: (5)
 
Atlanta93LE's Avatar
 
Join Date: Sep 2006
Location: Marietta, GA
Posts: 2,198
Total Cats: 1
Default

Quote:
Originally Posted by Ben View Post
Ben, did you add the cap filter? If not, any issues? Thx
Nope. I had one mild misfire in boost, which I think was spark blowing out, but I'll be adding the cap after further testing. I may run over to DIY and just have them do it for the peace of mind.
Atlanta93LE is offline   Reply With Quote
Old 04-13-2008, 12:25 AM   #15
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

Sweet. I just spent the last 45 minutes hand copying everything over to a hi rez msq. Did everything by hand including the ve and spark tables. Taking no chances.
Ben is offline   Reply With Quote
Old 04-13-2008, 12:29 AM   #16
Elite Member
iTrader: (5)
 
Atlanta93LE's Avatar
 
Join Date: Sep 2006
Location: Marietta, GA
Posts: 2,198
Total Cats: 1
Default

Quote:
Originally Posted by Ben View Post
Sweet. I just spent the last 45 minutes hand copying everything over to a hi rez msq. Did everything by hand including the ve and spark tables. Taking no chances.
You didn't hear? The HR10g code cured the issue that made us hand copy

I simply reflashed, reloaded my original MSQ, tuned, and BAM.
Atlanta93LE is offline   Reply With Quote
Old 04-13-2008, 12:32 AM   #17
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

No, and thanks for telling me now. Dick.

Here's the sad part. I did all that on my desktop. Now I have to figure out how to get the folder on this old laptop. Guess it's time to run the windows networking wizard
Ben is offline   Reply With Quote
Old 04-13-2008, 12:48 AM   #18
Elite Member
iTrader: (5)
 
Atlanta93LE's Avatar
 
Join Date: Sep 2006
Location: Marietta, GA
Posts: 2,198
Total Cats: 1
Default

I guess this thread would have helped
Atlanta93LE is offline   Reply With Quote
Old 04-13-2008, 01:09 AM   #19
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

complete and total failure
car barely idles, if that. stalls with any throttle RPM does not show in megatune.
Ben is offline   Reply With Quote
Old 04-13-2008, 01:11 AM   #20
Junior Member
 
Join Date: Dec 2007
Location: San Diego to LA, CA
Posts: 297
Total Cats: 0
Default

is megatune configured correctly to see the highres controller?
91NApeewee is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1991 special edition with hard top full part out JC, NJ russian Miata parts for sale/trade 6 10-08-2015 04:01 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
In need of base map for stock 1997 brandonbkd MEGAsquirt 0 09-29-2015 12:52 AM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM
mm0105 TABLE SWITCHING WIRING? slomiata MEGAsquirt 2 09-15-2015 01:54 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:12 PM.