My MS Install - 90 Miata - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MEGAsquirt A place to collectively sort out this megasquirt gizmo

Reply
 
 
 
LinkBack Thread Tools
Old 03-15-2006, 04:34 PM   #21
Junior Member
Thread Starter
 
Join Date: Dec 2004
Location: Austin, Texas
Posts: 130
Total Cats: 0
Default

This is from the V3 assembly guide... I dont think they mind us using the image...




The Grounds are on the long(wide) side of the plug.

Most of the sensors and controls are on the narrow side of the plug...

So using this diagram and numbering, starting at the top left.

1-19 row : 8/9/10/11 & 19 are grounds for the MS

20-37 row: In the Miata setup, we dont use the stepper IAC, but we steal those plugs holes for other funtions.. (cas, coil)...


20 - Air Intake Temp
21 - Coolant Temp
22 - Throttle Position sensor
23 - 02 Sensor
24 - RPM Signal (CAS Signal?)
25 - 1A RPM Signal (CAS Signal?)
26 - TPS signal 5vref
27 - 1B Coil
28 - Power 12V
29 - 2A Coil
30 - Idle Air Control (this requires using the DIYautotune Idle Air Mod Kit)
31 - Not used
32 - 33 - Tied together Injectors
34 - 35 - Tied together Injectors
36 - Not Used - This ignition is not used in my setup (see 27 / 29)
37 - Not Used - I am wiring the FP to come on when the ignition is on at Diag port.

Any Input, am I missing anything ?
kags1969 is offline   Reply With Quote
Old 03-15-2006, 05:58 PM   #22
Junior Member
 
Join Date: Nov 2005
Location: Down Under
Posts: 252
Total Cats: 0
Default

The only thing that could be worthwhile adding (specially for a NB engine in a NA like kags1969 and I are running) is to use pin 31 with the shift light control to activate the VICS on the NB engine.
Aussie Driver is offline   Reply With Quote
Old 03-17-2006, 07:02 PM   #23
Junior Member
Thread Starter
 
Join Date: Dec 2004
Location: Austin, Texas
Posts: 130
Total Cats: 0
Default

This is the connector that I bought from boomslang for $20 and soldered it up to the MS DB37 connector... My plan is to make this plug and play...

I will add the ecu connector pinouts and ms pinouts when I have a little more mental energy...




kags1969 is offline   Reply With Quote
Old 03-17-2006, 07:22 PM   #24
Elite Member
iTrader: (6)
 
Loki047's Avatar
 
Join Date: Sep 2005
Location: Chicago
Posts: 4,145
Total Cats: 0
Default

Kags This is amazing, makes me upset i went with emanage instead of MS but in a few years im sure ill be using this tutorial too. Thank you!
Loki047 is offline   Reply With Quote
Old 03-17-2006, 07:48 PM   #25
Elite Member
 
Philip's Avatar
 
Join Date: Dec 2004
Posts: 3,270
Total Cats: -4
Default

kags, we love you.

I really apreciate the time you put into all these tutorials, always top shelf my man. I owe you a beer if you come through Denver.
Philip is offline   Reply With Quote
Old 03-17-2006, 07:53 PM   #26
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,437
Total Cats: 84
Default

Quote:
Originally Posted by Philip
kags, we love you.

I really apreciate the time you put into all these tutorials, always top shelf my man. I owe you a beer if you come through Denver.
Come through Jersey and I'll make it two.
olderguy is offline   Reply With Quote
Old 03-17-2006, 07:59 PM   #27
Elite Member
 
Philip's Avatar
 
Join Date: Dec 2004
Posts: 3,270
Total Cats: -4
Default

Even if you're just passing through and making a connecting flight, it's only 40 miles out to DIA, I'll be there
Philip is offline   Reply With Quote
Old 03-17-2006, 08:22 PM   #28
Junior Member
 
Join Date: Jan 2005
Location: San Jose, CA
Posts: 248
Total Cats: 0
Default

Quote:
Originally Posted by kags1969
This is the connector that I bought from boomslang for $20 and soldered it up to the MS DB37 connector... My plan is to make this plug and play...

I will add the ecu connector pinouts and ms pinouts when I have a little more mental energy...
Kags that PnP harness is a great idea!. (I bet you can make some money making them..) Only issue I see is the Fans and fuel pump (and whatever else the ecu turns on that I dont know about!), could you post in detail how you did this when you do it :gay:
medisyn is offline   Reply With Quote
Old 03-17-2006, 08:27 PM   #29
Junior Member
 
Join Date: Jan 2005
Location: San Jose, CA
Posts: 248
Total Cats: 0
Default

Quote:
Originally Posted by olderguy
Come through Jersey and I'll make it two.

Quote:
Even if you're just passing through and making a connecting flight, it's only 40 miles out to DIA, I'll be there
Awww
medisyn is offline   Reply With Quote
Old 03-19-2006, 12:47 AM   #30
Junior Member
Thread Starter
 
Join Date: Dec 2004
Location: Austin, Texas
Posts: 130
Total Cats: 0
Default

mmmmmmm....beer.....

Well i got the kit from diy

""This is a simple two-part kit with a 1/4w 620ohm resistor to replace R19 and a ZTX688b to replace Q4."








This means that theoretically I should be able to plug this bastard in tomorrow...

Anybody wanna share their msq file? Aussie? [email protected] if your feeling generous...
kags1969 is offline   Reply With Quote
Old 03-23-2006, 09:04 AM   #31
Junior Member
 
Join Date: Jan 2005
Location: San Jose, CA
Posts: 248
Total Cats: 0
Default

C'mon Kags did you get that thing running!? I am dying to know.
medisyn is offline   Reply With Quote
Old 03-23-2006, 10:56 PM   #32
Junior Member
Thread Starter
 
Join Date: Dec 2004
Location: Austin, Texas
Posts: 130
Total Cats: 0
Default

Quote:
Originally Posted by medisyn
C'mon Kags did you get that thing running!? I am dying to know.

I am having usb/com issues, so i ordered a new usb/serial adapter....
kags1969 is offline   Reply With Quote
Old 03-24-2006, 07:55 PM   #33
Junior Member
 
Join Date: Jan 2005
Location: San Jose, CA
Posts: 248
Total Cats: 0
Default

Ah, I see. I have a old as ***** p1 300mhz (yup its really 300mhz) w/32 mb of ram for MS. It only has 32mb of ram so I hope it will be ok, but it has serial ports so that will make life easyer.

KAGS dont they have fry's electronics out there? I bet they have what you need, I shop at that hell hole all the time. Its shitty service but they have a good stock of things like that. I found a rareish ATI dvi--> component adapter there last week!
medisyn is offline   Reply With Quote
Old 03-27-2006, 07:50 AM   #34
Senior Member
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

Quote:
Originally Posted by medisyn
Ah, I see. I have a old as ***** p1 300mhz (yup its really 300mhz) w/32 mb of ram for MS. It only has 32mb of ram so I hope it will be ok, but it has serial ports so that will make life easyer.

KAGS dont they have fry's electronics out there? I bet they have what you need, I shop at that hell hole all the time. Its shitty service but they have a good stock of things like that. I found a rareish ATI dvi--> component adapter there last week!
I/m using either 8 or 16 mb of RAM--Win 95...
Jefe is offline   Reply With Quote
Old 03-27-2006, 09:26 AM   #35
Junior Member
 
Join Date: Jan 2005
Location: San Jose, CA
Posts: 248
Total Cats: 0
Default

Quote:
Originally Posted by Jefe
I/m using either 8 or 16 mb of RAM--Win 95...
awesome my computer is a powerhouse :gay: . Anyways the battery is dead using one of those inverters that plug into the cigarette lighter to power it will be ok right? (sorry about the derail.) the ac adapter still works!
medisyn is offline   Reply With Quote
Old 04-20-2006, 01:10 PM   #36
Senior Member
iTrader: (2)
 
Join Date: Mar 2006
Location: MA
Posts: 885
Total Cats: 2
Default

any updates on this? I'm becomeing more and more interested in going to MS with my '93, as i'm going to boost and figure that if i MS first, i'll have better options for fuel once i start boosting and get the pwoer bug.

problem is that i'm nervous as hell about taking the plunge, so i've been following this thread.

looks like it's not too painful, though, overall.
devin mac is offline   Reply With Quote
Old 06-11-2006, 10:29 PM   #37
Newb
 
Join Date: Dec 2005
Posts: 12
Total Cats: 0
Default Update?

Hi kegs...

any update on this? I have been leaning towards the e-manage till I saw your thread here... please please please do give us an update

thanks!!
Sk8te is offline   Reply With Quote
Old 06-13-2006, 04:01 PM   #38
Junior Member
Thread Starter
 
Join Date: Dec 2004
Location: Austin, Texas
Posts: 130
Total Cats: 0
Default

Well, here is the update....

I melted a piston in my Emanage Ultimate 2000 Miata, and had to swap in another motor. Finished that a couple of weeks ago. I pulled the 1.6L out of the Blue Car (getting the MS) and have been prep-ing a 1.8L to go in. I have also been fabbing up intercooler pipping and such while the engine is out of the car, so I have a little room to work. I would like to stick the motor this weekend, then I will have to fab and exhaust etc. etc. after I have it running on the stock ecu, I will try the swap over. So you have a little bit of waiting to do before I add anything significant to the write up... sorry, I'd be running had I not melted that piston.. se la ve.

Chris
kags1969 is offline   Reply With Quote
Old 06-19-2006, 02:48 PM   #39
Junior Member
Thread Starter
 
Join Date: Dec 2004
Location: Austin, Texas
Posts: 130
Total Cats: 0
Default

Getting Ready to stab that motor so I thought I better get back on this...

Here is an updated ECU Pinout -> MS Pinout and I have included the stock wire colors to help in identifying stuff. This is untested, but I think it is on the right track...

20 - Air Intake Temp (ECU 2P) (red-green)
21 - Coolant Temp (ECU 2Q ) (Blue-White)
22 - Throttle Position sensor (ECU 1N) (Red)
23 - 02 Sensor (ECU 2N) (Red-Blue)
24 - RPM Signal (ECU 2E) (white)
25 - 1A RPM Signal (ECU 2I) (Black-White)
26 - TPS signal 5vref (ECU 2L) (Lt Green White)
27 - 1B Coil (ECU 1G) (Brown-yellow)
28 - Power 12V (ECU 1B) (White Red)
29 - 2A Coil (ECU H) (Brown)
30 - Idle Air Control (ECU 2W)
31 - Not used
32 - 33 - Tied together Injectors (ECU 2U) (Yellow)
34 - 35 - Tied together Injectors (ECU 2V) (Yellow Black)
36 - Not Used - This ignition is not used in my setup (see 27 / 29)
37 - Not Used - I am wiring the FP to come on when the ignition is on at Diag port
kags1969 is offline   Reply With Quote
Old 06-19-2006, 02:50 PM   #40
Junior Member
Thread Starter
 
Join Date: Dec 2004
Location: Austin, Texas
Posts: 130
Total Cats: 0
Default

Here are the relevant Pinouts on the 90 ECU with wire colors... I pulled this stuff from schematics, and haven't tested it yet, but it should be close...

90 ECU Pin-out

1B = Power (White Red)
1G = igniter 1-4 (Brown-yellow)
1H = igniter 2-3(Brown)
1M =
1N = Throttle Position Sensor (Red)

2A = Ground (Black)
2C = Ground (Black Lt Green)
2E = Crank Angle Sensor (white)
2G = Cam Angle Sensor (Yellow-Blue)
2I = RPM Signal (Black-White)
2N = O2 Signal (Red-Blue)
2O = Airflow Sensor (red)
2P = Air Temp Sensor (red-green)
2Q = Water Temp (Blue-White)
2U = Injector 1/3 (Yellow)
2V = Injector 2/4 (Yellow Black)
2W = Idle speed Control (Blue-Orange)
kags1969 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
[CT] 1999 Mazda Miata 10th Anniversary Edition - $5800 Jike Spingleton Cars for sale/trade 3 09-20-2016 05:33 PM
elesjuan's mediocre 95 Miata adventure (google fiber edition) elesjuan Build Threads 8 02-16-2016 09:36 PM
Turbo 1995 Miata Low mileage Clean Tekel Cars for sale/trade 29 02-05-2016 05:16 PM
starting issue Johnny Tater Engine Performance 3 09-23-2015 07:10 PM
New here, saying hi, here's what I'm workin with. SuperSneakySecretSquirrel Meet and Greet 5 09-06-2015 09:30 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:51 PM.